Введение

 В начало Далее

IrfanView - это компактная и простая программа просмотра картинок. Больше того, изображения можно и редактировать прямо в IrfanView, добавляя массу эффектов. Автор IrfanView - Irfan Skiljan.

Откройте IrfanView щелчком по ее значку в главном меню Windows или по значку на рабочем столе.

В меню "Файл" выберите команду "Открыть". Откроется окно выбора файла для просмотра. Поставьте в нем галочку "Предварительный просмотр", чтобы сразу видеть эскиз выбранного изображения.

С открытым изображением можно сделать многое. Основные функции обработки изображения сосредоточены в меню "Правка" и "Изображение".

Закончив работу с картинкой, можно сохранить ее в файле. Откройте следующую или выйдите из IrfanView.


Ответы на типичные вопросы

 Введение Далее

Актуальная версия этой страницы есть на сайте IrfanView:

http://www.irfanview.com/faq.htm

Здесь собраны некоторые интересные вопросы об IrfanView, сообщения об ошибках и т.п.

В: Я хочу записать на CD-ROM картинки и программу IrfanView. Как сделать, чтобы при вставке диска запускалось слайдшоу в IrfanView?
О: Можно создать программу-слайдшоу (EXE) (в окне слайдшоу) или записать на CD исходные файлы и текстовый файл-список. Пример см. на этой странице.

В: Проблема: Не открываются некоторые AVI - выдается сообщение об ошибке "воспроизведение видео невозможно, не найден декомпрессор MJPG"!
О: Метод 1: В меню "Настройки программы à Видео" поставить галочку "С помощью DirectShow".

Метод 2: Установить видеокодек MJPG (Motion JPEG). Ищите на этих сайтах:

http://www.free-codecs.com/Motion_JPEG_Codec_download.htm

http://www.mainconcept.com/downloads.shtml

http://www.morgan-multimedia.com

http://www.fourcc.org/indexcod.htm

В: Проблема: Не открываются некоторые AVI и MPG в IrfanView, постоянно выдается сообщение об ошибке "MMSYSTEMxxx, нет устройства ..."!
О: Ответ ищите на http://www.microsoft.com/ по номеру ошибки. В некоторых случаях это исправимо.

В: Общая проблема с видеофайлами: Не открываются некоторые AVI - выдается сообщение об ошибке "воспроизведение видео невозможно, не найден декомпрессор XXX"!
О: Не установлен нужный видеокодек, ищите его на этих сайтах (его имя см. в информации о файле: меню "Изображение à Свойства изображения"):

http://www.fourcc.org/indexcod.htm

http://www.codec-download.com

http://codecs.necromancers.ru

http://www.free-codecs.com

http://www.microsoft.com/downloads/results.aspx?productID=&freetext=media+8&DisplayLang=en

http://www.videohelp.com

Есть хороший набор кодеков - K-Lite Codec Pack, в него входит большинство популярных аудио-видео кодеков.

В: Как уменьшить размер сохраняемых файлов с XX КБ до YY?
О: К сожалению, этого одним движением не добьешься.
1. Откройте изображение.
2. В меню "Изображение" à "Изменить размер изображения" уменьшите размеры изображения в пикселах.
3. В меню "Файл" à "Сохранить как", выберите формат JPG и сохраните изображение как новый файл (поиграйте и с параметрами сохранения JPG: понизьте качество JPG, не сохраняйте EXIF и т.д.).
4. Проверьте размер нового файла. Если он все еще слишком велик, повторите все это, еще уменьшите размер в пикселах и (или) качество и т.д.
X. Если изображений несколько, это делается в групповых операциях с дополнительными установками.

Примечание: с версии 4.20, если установлены плагины к IrfanView, можно использовать новый параметр сохранения JPG: "Задать размер файла".

В: Обнаружил ошибку: Со вчерашнего дня IrfanView показывает все картинки черно-белыми! Почему?
О: Включен режим "Загружать все файлы JPG как монохромные" в меню "Настройки программы à JPG/PCD/GIF". Отключите его!

Примечание: в окне "Сохранить" проверьте параметры сохранения JPEG. НЕ должна стоять галочка "Записывать в оттенках серого".

В: Обнаружил ошибку: IrfanView не читает имена файлов и пути с китайскими, японскими, польскими и т.п. буквами.
О: Включите плагин UNICODE в меню "Настройки программы à Язык" и перезапустите программу.

В: Как выполнить операции без потерь с группой JPG (поворот, запись IPTC и комментария)?
О: В окне миниатюр откройте папку с этими JPG, выберите все нужные JPG и в меню миниатюр "Файл" à "Операции с JPG без потерь" выберите нужные операции. Примечание: параметр "повернуть автоматически" работает только если тег ориентации в EXIF записан правильно (не верхний левый).

В: Есть ли портативная версия IrfanView (для USB-флэшек, CD и т.п.)?
О: Да, портативна ЛЮБАЯ IrfanView. Нужно:
1. Скопировать папку установленной IrfanView на USB-флешку (рекомендуется), или
2. С дистрибутива установить IrfanView в папку на USB-флешке, или
3. Взять ZIP-вариант и распаковать его в папку на USB-флэшке.

(Примечание: ZIP-вариант IrfanView можно взять на сайте по ссылке "Other download sites" внизу страницы)

В: Почему некоторые команды в меню "Правка" (и другие) серые?
О: Многие команды правки, в том числе уборка красных глаз, работают только с выделенным фрагментом. Сначала выделите участок (выберите прямоугольник) изображения левой кнопкой мыши.

В: Как сделать, чтобы изображения всегда открывались в IrfanView?
О: Запустите IrfanView, и в меню "Настройки программы à Типы файлов" свяжите с ней нужные типы изображений.

В: Почему так медленно загружаются форматы RAW (фотосырье, например CR2)?

О: Это зависит от настроек форматов RAW в "Настройки программы à PlugIns". Быстрее всего загружается встроенное JPEG-изображение, изображения половинного размера загружаются тоже достаточно быстро, а если оба эти способа отключены, то полное сырое изображение открывается очень медленно.

В: Как рассортировать фото по дате съемки?
О: Откройте окно миниатюр и выберите папку. В меню "Параметры à Сортировка миниатюр" выберите "по дате съемки в EXIF".

В: Подвержена ли IrfanView уязвимости MS JPEG?
О: НЕТ. В IrfanView не используется GDI+.

В: Как переименовать сразу все файлы "JPG" в "jpg" (строчными буквами)?
О: В окне "Операции с группой файлов" введите шаблон переименования: $N.jpg.

В: Как добавить фоновую музыку в слайдшоу или EXE (или в заставку SCR)?
О: В окне слайдшоу добавьте файлы MP3 в список слайдшоу, лучше в начало или перед картинкой. MP3 проигрывается до конца или до открытия следующего файла MP3 из списка. Должны быть установлены плагины к IrfanView, по меньшей мере - плагин MP3.

В: Преобразование группы файлов: Как сохранить полученные файлы в их исходных папках (если они были в нескольких подпапках)?
О: В дополнительных параметрах групповых операций поставьте галочку "Создавать вложенные папки в папке назначения". Выберите папкой для результирующих файлов (в окне операций с группой файлов) корневую папку исходных файлов, например, C:\, если все они находятся на диске C.

В: Почему не прокручивается большая, увеличенная картинка (больше экрана) в полноэкранном режиме клавишами-стрелками и PgUp/PgDn?
О: Либо эта картинка на самом деле не больше экрана, либо стоит галочка "Настройки программы à Обзор à Смена изображений клавишами PgUp/PgDn...", снимите ее.

В: Почему при сохранении файлы JPG получаются намного больше исходных файлов JPG?
О: Размер файла JPG зависит прежде всего от качества сохранения JPG (в окне параметров сохранения). Нормальное качество - от 75 до 80, Чем больше число, тем тем большим получится файл.

В: Я скачал IrfanView (или плагины), но когда пробую ее запустить, выдается сообщение "Это не приложение Win32"?
О: Это сообщение характерно для поврежденных или неполных файлов EXE, скорее всего это ошибка при загрузке. Скачайте заново, попробуйте с зеркала или с другого адреса.

В: Как добавить фоновую музыку на VCD (Video CD)?
О: Спецификация VCD этого не допускает.

В: Совместима ли IrfanView с 64-битными Windows 7/Vista/XP?
О: ДА, как и примерно 95% всех 32-битных программ.

В: При запуске IrfanView под Windows 7 система каждый раз меня спрашивает о запуске с правами администратора, почему?
О: Кто-то, не сама IrfanView, настроил ее на запуск с правами администратора. Отключите эту настройку (щелчком правой по значку IrfanView, "Свойства", закладка "Совместимость") и сможете нормально запускать IrfanView. На сегодня в закладке "Совместимость" для IrfanView ничего включать не нужно.

В: Как изменить иконки файлов, связанных с IrfanView?
О: В меню "Настройки программы à Типы файлов" нажмите кнопку "Значки и другие параметры". Здесь можно выбрать значки для файлов, связанных с программой.

В: Обнаружил ошибку: Со вчерашнего дня IrfanView показывает все изображения искаженными (растянутыми)! Почему?
О: В меню "Вид" включен режим просмотра "Под размер рабочего стола" (или подобный), отключите его, включите рекомендованный режим просмотра.

В: Как извлечь изображения из EXE-слайдшоу?
О: Запустите его и нажмите F1 для вызова справки. Для извлечения нажмите клавишу "E" (лат.).

В: Как изменить данные IPTC и комментарий JPG сразу в нескольких файлах (пакетно)?
О: В окне миниатюр выберите все эти файлы JPG, и в меню "Операции с выбранными JPG-файлами без потерь à Присвоить данные IPTC". Данные из первого файла будут записаны во все остальные. Окно IPTC позволяет их изменить и кое-что добавить.

В: Не теряется ли качество JPG при редактировании данных IPTC или комментария?
О: Нет, само изображение при этом НЕ изменяется.

В: Как, листая картинки, открывать только файлы интересующих меня типов?
В: Как листая картинки, пропускать файлы определенных типов (например TXT)?
В: IrfanView может показывать файлы CR2 (например), но не показывает их в окне миниатюр?
О: В меню "Настройки программы à Типы файлов" отредактируйте расширения файлов в поле "Загружать файлы указанных ниже типов": уберите ненужные или добавьте нужные расширения (из поддерживаемых!).

В: Обнаружил ошибку: После уменьшения глубины цвета до 8 и даже меньше бит на пиксел (BPP), в сохраняемом файле JPG все равно остается 24 BPP?
О: Учтите, что JPG можно сохранить только с 24-битным цветом или 8-битным в оттенках серого. Других вариантов цветности JPG нет. Если нужна другая глубина цвета, измените формат на PNG, TIF, BMP и т.п.

В: Как изменить иконку IrfanView на рабочем столе?
О: Это настраивается в Windows. Щелкните правой по значку на рабочем столе, выберите "Свойства". Здесь можно выбрать другой значок (заменить его) и изменить (или убрать) клавишу быстрого вызова программы.

В: Как, листая картинки, открывать файлы БЕЗ расширения?
О: В меню "Настройки программы à Типы файлов" отредактируйте расширения файлов в поле "Загружать файлы указанных ниже типов": добавьте в конце "|" для включения в список пустого расширения. Не обязательно: в меню "Настройки программы à Операции с файлами" снять галочку "Предлагать переименовать файл при неверном расширении".

В: Как распечатать только часть картинки?
О: Левой кнопкой мыши выделите нужный фрагмент изображения, затем - через меню "Печать". Или: "Правка à Обрезать", затем "Печать".

В: Как распечатать сразу много файлов (одновременно)?
О: В окне миниатюр нужно выделить несколько изображений и в меню выбрать команду "Распечатать выбранные файлы по отдельности".

В: Как открыть файл PDF в IrfanView?
О: Установите плагины к IrfanView. Установите Ghostscript с сайта http://sourceforge.net/project/showfiles.php?group_id=1897.

В: Как распечатать несколько картинок на одном листе?
О: В окне миниатюр командой меню "Создать контрольный лист из выбранных файлов". Полученную сводную картинку можно распечатать или сохранить.

В: Совместима ли IrfanView с Windows 95 и 98?
О: Да, IrfanView совместима со всеми Win9x- и более новыми версиями Windows. Win9x - это: Windows 95, 98, 98 SE и Windows ME.

В: Есть ли способ отсканировать серию картинок без сканера ADF?
О: Да, нужно в меню "Файл" à "Получить/отсканировать серию изображений" снять галочку "Закрыть TWAIN-окно после получения изображения".

В: Как вставить в картинку текст в юникоде (например, китайский)?
О: Зайти в Панель управления Windows, в разделе "Язык и региональные стандарты" в закладке "Дополнительно", выбрать китайский язык для программ, не поддерживающих юникод.

В: Как воспроизвести файлы QuickTime (MOV) в IrfanView?
О: Для воспроизведения всех файлов QuickTime: установите Apple QuickTime, установите плагины к IrfanView. Поставьте галочку "Использовать Quicktime" в "Настройки программы à Видео и аудио".

В: Обнаружил ошибку: IrfanView не хочет сохранять настройки! Почему?
О: Возможны 2 причины. Первая: файл настроек (i_view32.ini) (или вся папка IrfanView) только для чтения, снимите этот атрибут. Вторая: некоторые "умные" программы-чистильщики вычищают лишнее, исключите файлы и папку IrfanView из них. Можно и переместить файл настроек в другую папку (см. ниже); это можно сделать и при установке программы.

В: Обнаружил ошибку: Кнопка "Добавить" в окне слайдшоу и групповых операций не хочет добавлять выбранные файлы в список.
О: Это - "особенность" Проводника Windows: скрывать расширения для известных типов файлов. Отключите эту стандартную (и дурацкую) настройку Проводника, чтобы видеть файлы с их реальными именами и расширениями!

В: Обнаружил ошибку: Окно миниатюр падает, если в папке много файлов!
О: Это - ошибка Windows 9x/XP (а сейчас еще и 64-битной Windows 7 => синий экран, ошибка Windows), максимальное число файлов в папке зависит от операционной системы. WinNT/Win2K работают отлично. Попробуйте разложить файлы в несколько папок.

В: Обнаружил ошибку: Почему вместо видео захватывается черный экран?
О: Попробуйте отключить ускорение видео в настройках: "Панель управления à Экран à Параметры à Дополнительно à Диагностика" на время захвата видео. Или запустите еще один проигрыватель и попробуйте захватить видео из него.

В: Обнаружил ошибку (Windows 95): В окне миниатюр при щелчке по эскизу ничего не происходит, картинка не открывается в окне просмотра!
О: У вас устаревшая библиотека comctl32.dll, обновите этот компонент Windows с сайта MS, ищите обновление Comctl32.dll.

В: Проблема: При двойном щелчке по файлу, связанному с IrfanView, выдается сообщение об ошибке "Не найден файл [путь] или один из его компонентов". В чем проблема?
О: Запустите IrfanView, и в меню "Настройки программы à Типы файлов" свяжите типы файлов с программой заново.

В: Обнаружил ошибку: IrfanView у меня запускается очень медленно! Почему?
О: Вероятно, в этом виноват устаревший антивирус или другая фоновая программа. Проверьте, что запущено в вашей системе.

В: Обнаружил ошибку: Заставка, созданная в IrfanView, показывает всего несколько картинок и закрывается. Почему?
О: Проблема вызвана другой работающей программой, отключающей заставку. Проверьте, что запущено в вашей системе.

В: Обновление: Нужно ли удалять старую версию перед установкой новой?
О: Нет. Устанавливайте новую версию прямо поверх старой. После установки просто обновите связи с файлами и настройки в меню "Настройки программы à Типы файлов".

В: Можно ли пользоваться IrfanView под Linux?
О: Да. Версии IrfanView специально для Linux нет. Тем не менее, IrfanView можно использовать в связке с WINE для Linux, имитаторами Windows для Linux и виртуальными машинами на базе Linux. См. инструкции на:

http://www.wine-reviews.net/applications/irfanview-410-on-linux-with-wine.html

Возьмите ZIP-вариант IrfanView и распакуйте, или скопируйте папку IrfanView из Windows в Linux. Так проще, потому что для запуска установки нужны системные DLL Windows.

В: Можно ли пользоваться IrfanView на Mac?
О: Да, вероятно. Версии IrfanView специально для Mac нет. Тем не менее, IrfanView можно использовать в связке с WineBottler или DARWINE для Mac.

Возьмите ZIP-вариант IrfanView и распакуйте, или скопируйте папку IrfanView из Windows в Mac. Так проще, потому что для запуска установки нужны системные DLL Windows.

В: Основы: Как конвертировать рисунки, например, BMP в JPG?
О: Откройте файл BMP через меню "Файл à Открыть". Перейдите в меню "Файл à Сохранить как", выберите для сохранения формат JPG, задайте для него новое имя и папку и сохраните. Если нужно конвертировать много файлов, воспользуйтесь "Преобразованием группы файлов".

См. также это видео: http://www.youtube.com/watch?v=cj-rDx1hH4A

В: Основы: Нужны ли мне плагины к IrfanView?
О: Вероятно, нет. Все основные функции, возможности и плагины включены в стандартный комплект IrfanView. Остальные плагины как правило нужны для работы с особыми форматами файлов. Если понадобится дополнительный плагин, IrfanView сообщит об этом, и тогда вы сможете установить и все прочие плагины.

В: Нет ли в IrfanView вирусов или подобной дряни?
О: НЕТ. Если антивирус сообщает, что в IrfanView, скачанной с официального сайта, есть вирус или еще что-то, нужно либо его обновить, или найти антивирус получше.

В: Хитрость: Есть ли способ скрыть меню и заголовок окна программы насовсем, как панель инструментов и строку состояния?
О: Да. В файле настроек впишите в раздел [Menu] Active=0 чтобы скрыть меню, а в раздел [Caption] Active=0, чтобы скрыть заголовок программы.

В: Я администратор. Как мне установить IrfanView на сервер (компьютер) с одинаковыми настройками для всех пользователей?
О: 1) Установите IrfanView на сервер (компьютер).

2) Настройте IrfanView. После этого установите файлу настроек "i_view32.ini" атрибут "только для чтения".

Пользователи больше не смогут изменить настройки IrfanView.

3) Чтобы предотвратить изменение реестра (связь файлов с программой), можно скрыть окно "Настройки программы à Типы файлов". Впишите в файл настроек:

ShowExtensionsDlg=0 в раздел [Extensions].

В: Я администратор. Как мне установить IrfanView на сервер (компьютер), чтобы у каждого пользователя были свои файлы настроек?
О: 1) Установите IrfanView на сервер (компьютер).

2) Впишите в файл настроек (i_view32.ini на сервере (компьютере)):

INI_Folder=папка в раздел [Others].

Примеры:

INI_Folder=C:\TEMP, или

INI_Folder=%TEMP%, или

INI_Folder=%APPDATA%\IrfanView, или

INI_Folder=C:\TEMP\%YOUR_ENVIRONMENT_VARIABLE%, или

INI_Folder=%YOUR_ENVIRONMENT_VARIABLE%\папка

В: Я администратор, IrfanView установлена на сервере, у каждого пользователя свой файл настроек. Как задать общий язык интерфейса, например, немецкий?
О: Метод 1: Подготовить специальный INI-файл с выбранными настройками по умолчанию и скопировать его поверх пользовательского INI-файла.

Метод 2: Вписать в глобальный файл настроек (i_view32.ini на сервере):

DefaultLang=язык.dll в раздел [Language].

Пример для немецкого:

DefaultLang=deutsch.dll в раздел [Language].

В: Я администратор. Как мне автоматически установить или удалить IrfanView?
О: Можно просто скачать ZIP-вариант IrfanView и плагинов и развернуть эти файлы. Варианты с установщиком имеют специальные ключи командной строки для "тихой" установки (без всяких запросов) (примеры для версии 4.20):

1) IrfanView:

iview420_setup.exe /silent /folder="c:\test folder\irfanview"

iview420_setup.exe /silent /folder="c:\test folder\irfanview" /desktop=1 /thumbs=1 /group=1 /allusers=0 /assoc=1 /ini="%APPDATA%\irfanview"

iview420_setup.exe /silent /folder="c:\test folder\irfanview" /ini="c:\temp"

Ключи:

folder: папка программы; если не указана, то используется прежняя папка IrfanView, если она не найдена, то в "Program Files"
desktop: ярлык на рабочем столе; 0 = не создавать, 1 = создать (по умолчанию: 0)
thumbs: ярлык на рабочем столе для окна миниатюр; 0 = не создавать, 1 = создать (по умолчанию: 0)
group: группа в главном меню; 0 = не создавать, 1 = создать (по умолчанию: 0)
allusers: для всех ли пользователей ярлыки и группа; 0 = для текущего, 1 = для всех
assoc: связывать ли с файлами; 0 = нет, 1 = только с изображениями, 2 = со всеми (по умолчанию: 0)
assocallusers: связать с файлами для всех пользователей (только для Windows XP)
ini: задать папку для файла настроек (можно использовать системные переменные среды)

2) Плагины:

irfanview_plugins_420_setup.exe /silent

3) Удаление:

iv_uninstall.exe /silent

В: Что за иконка у IrfanView, это мишка, чертик, или еще что-то?
О: Это красный кот, бродячий кот. Да, я люблю кошек, но это просто шутка ;-)

Разное: Некоторые пользователи IrfanView создали учебники для особых функций и операций. Спасибо, ребята!

- Установка: http://www.downloadtube.com/IrfanView-4-20-demo-installation-windows.html
- Общие: http://www.downloadroute.com/IrfanView-Irfan-Skiljan/tutorials.html
- Общие: http://www.sticksite.com/irfanview/
- Общие: http://www.indeavors.com/resources/tutorials.htm
- Общие: http://www.cam-web.co.uk/IrfanviewTutorials
- Общие: http://www.pc-tinkering.de/search.php?search=Irfanview&language=1
- Общие: http://www.fotowelt-online.de/software/irfanview/index.php (на немецком)
- Общие: http://www.lehrerfortbildung-bw.de/werkstatt/bild/irv/ (на немецком)
- Общие: http://www.henner.info/irfan.htm (на немецком)
- Общие: http://www.infografik.ch/bro11_irfan.pdf (на немецком, PDF)
- Общие: http://home.casema.nl/sve/irfanview/irfanview.htm (на голландском)
- Групповое изменение размера: http://www.lancelotgroup.com/tutorials/HowToResize-IrFanView-Start.asp
- Групповое изменение размера: http://www.coffeedrunk.com/2008/10/08/how-to-do-a-batch-resize-using-irfanviewtutorial/
- Командная строка: http://www.netikka.net/tsneti/info/tscmd137.htm
- Групповое преобразвание: http://www.photosapiens.com/article.php?id_article=1224 (на французском)
- Групповое преобразвание: http://www.youtube.com/watch?v=dWvlvu_4NQc (на испанском)
- Контрольный лист: http://www.photosapiens.com/article.php?id_article=1694 (на французском)
- Обрезка: http://www.peterkjohnson.com/helpSheet/demoCroppingIrfanview/croppingIrfanview.html
- Слайдщоу: http://www.zisman.ca/Irfanview/
- Установка, изменение размера: http://www.hp-h.com/p/paradj/tshootimg/irfanview/
- Установка и т.д.: http://www.kulak.ac.be/renwv/nazorg/wegwijsweb/ (на голландском)
- JPG: http://netzreport.googlepages.com/hidden_data_in_jpeg_files.html
- Фракталы: http://benscheele.com/ag/fractal_art.htm

Разное: Интересные ссылки по специфическим проблемам Windows:

- неверны эскизы в Проводнике: http://www2.whidbey.net/djdenham/Tweekz.htm
- о конвертации видео: http://www.videohelp.com


Установка

 В начало Назад Далее

Установка IrfanView для использования.

Для опытных пользователей:

Скачайте IrfanView и распакуйте файлы в выбранную папку. Создайте ярлык для программы в главном меню Windows или на рабочем столе.

Для неопытных пользователей:

Скачайте самоустанавливающийся вариант IrfanView и запустите установку.

Некоторая информация:

Архив с программой содержит несколько файлов. "i_about.txt" - это описание программы и информация об авторе. "i_changes.txt" - история разработки программы. "i_options.txt" содержит сводку ключей запуска программы. "i_view32.exe" - это сама программа IrfanView. "i_view32.chm" - файл справки к программе.

Ярлыки - это пункты в главном меню или значки на вашем рабочем столе, запускающие программы. Создайте их для IrfanView. Для этого в Windows нажмите кнопку "Пуск". Выберите "Настройка" à "Панель задач и меню Пуск". Откроется окно с двумя закладками. Выберите закладку "Меню Пуск". В ней нажмите кнопку "Добавить". Откроется окно "Создание ярлыка". Нажмите кнопку "Обзор", найдите IrfanView, щелкните по ней, нажмите кнопку "Открыть". IrfanView теперь выбрана. Нажмите "Далее". Теперь нужно выбрать папку программы в главном меню, в которую будет помещен ярлык. И наконец нужно выбрать имя программы. После этого в меню "Пуск" à "Программы" в выбранной папке появится ярлык для запуска IrfanView.

Ярлык на рабочем столе проще всего создать в самой программе. Запустите IrfanView. В меню "Сервис" выберите "Настройки программы à Разное". Здесь есть кнопка "Создать ярлык к IrfanView на рабочем столе". Нажмите ее, и ярлык появится на вашем рабочем столе. Закройте окно кнопкой "OK". Теперь запускать программу можно будет двойным щелчком по нему или сочетанием клавиш Ctrl+Shift+I.

Примечание: Новые версии можно устанавливать прямо поверх старых (обновлять). После установки просто обновите связи программы с файлами в меню "Настройки программы à Типы файлов", если не сделали этого в ходе установки.


Удаление IrfanView

Как удалить IrfanView?

Выберите в меню Windows: "Пуск à Программы à IrfanView" à "Удаление IrfanView" или: "Пуск à Настройка à Панель управления à Установка и удаление программ".


Поддерживаемые форматы файлов

Текущая версия IrfanView работает со следующими форматами файлов (расширениями):

AIF¹, ANI, AU¹, AVI, AWD, B3D, BMP, CAM, CLP, CPT, CRW/CR2, CUR, DAT¹, DCM/ACR, DCX, DDS, DIB, DJVU, DLL/EXE, DXF/DWG/HPGL/CGM/SVG, ECW, EMF, EPS/PS/PDF/AI, EXR, FITS, FLI/FLC², FPX, FSH, G3, GIF, GLCD, HDP/WDP, HDR, ICL, ICO, IFF/LBM, IMG, JLS, JP2, JPG/JPEG, JPM, KDC, Mac PICT², MAG, MED, MID, MNG/JNG, MOV¹², MP3, MPG/MPEG¹, MPO, MrSID, OGG, PBM, PCX, PDF, PDN, PGM, PhotoCD, PNG, PPM, PSD, PSP, PVR, QTIF², RAS/SUN, RealAudio, RAW, RLE, RMI, SFF, SFW, SGI/RGB, MrSID, SWF/FLV, SND¹, TGA, TIF/TIFF, TTF, TXT, WAD, WAL, WAV, WBMP, WMF, WMA, WMV, WBC/WBZ, WEBP, WSQ, XBM, XCF, XPM, (DNG, EEF, NEF, ORF, RAF, MRW, DCR, PEF, SRF, X3F, RW2, NRW).

¹ Для этих форматов нужен Microsoft Media Player.

² Для этих форматов нужен Apple QuickTime.

Примечание: Поддержка многих из них реализована в плагинах, подробнее см. в таблице ниже и в файле "i_plugins.txt".

Плагины можно скачать здесь: http://www.irfanview.com/plugins.htm

Обзор форматов IrfanView::

Расширение | Название формата | Просмотр | Сохранение
AIF | звукозапись Audio Interchange Format | ЕСТЬ¹ ³ |
ANI | "живой" курсор для Windows | ЕСТЬ |
AU, SND | кодированная звукозапись для компьютеров Sun и NeXT | ЕСТЬ¹ ³ |
AVI, WMV, ASF | видеозапись Windows (Audio Video Interleaved) | ЕСТЬ |
B3D | рисунок BodyPaint 3D | ЕСТЬ³ |
BMP, DIB | растровый рисунок Windows | ЕСТЬ | ЕСТЬ
CAM | фото цифровых камер Casio | ЕСТЬ³ (версия JPG) |
CLP | формат буфера обмена Windows | ЕСТЬ |
CPT | рисунок CorelDraw Photopaint | ЕСТЬ (CPT версии 6) |
CRW, CR2 | "фотосырьё" цифровых камер Canon | ЕСТЬ³ |
CUR | курсор для Windows | ЕСТЬ |
DCM, ACR, IMA | медицинский формат рисунков Dicom/ACR | ЕСТЬ³ |
DCX | многостраничный рисунок формата PCX | ЕСТЬ |
DDS | текстура Direct Draw Surface | ЕСТЬ³ |
DJVU, IW44 | электронная книга DjVu | ЕСТЬ³ |
DXF, DWG, HPGL, CGM, SVG | форматы чертежей CAD | ЕСТЬ³ |
ECW | рисунок Enhanced Compressed Wavelet | ЕСТЬ³ | ЕСТЬ³
EMF | рисунок Enhanced Metafile Format | ЕСТЬ | ЕСТЬ
EPS, PS, PDF, AI | форматы рисунков PostScript | ЕСТЬ³ |
EXR | рисунок OpenEXR | ЕСТЬ³ |
FITS | рисунок Flexible Image Transport System | ЕСТЬ³ |
FLI, FLC | анимация Autodesk | ЕСТЬ² ³ |
FPX | рисунок FlashPix | ЕСТЬ³ |
FSH | рисунок EA Sports | ЕСТЬ³ | ЕСТЬ³
G3 | рисунок-факс группы 3 | ЕСТЬ³ |
GIF | рисунок Graphics Interchange Format | ЕСТЬ | ЕСТЬ
HDP, WDP | фото Microsoft HD Photo | ЕСТЬ³ |
HDR | рисунок High Dynamic Range | ЕСТЬ³ |
ICL, EXE, DLL | форматы, содержащие значки (библиотеки значков) | ЕСТЬ (значки) |
ICO | значок для Windows | ЕСТЬ | ЕСТЬ
IFF, LBM | рисунок Interchange File Format | ЕСТЬ |
IMG | растровый рисунок GEM | ЕСТЬ³ |
JLS | рисунок JPEG-LS (JPEG без потери качества) | ЕСТЬ³ |
JP2, JPC, J2K | рисунок JPEG 2000 | ЕСТЬ³ | ЕСТЬ³
JPG, JPEG | рисунок Joint Photographic Experts Group | ЕСТЬ | ЕСТЬ
JPM | рисунок JPEG2000/Part6, LuraDocument.jpm | ЕСТЬ³ | ЕСТЬ³
KDC | фото цифровых камер Kodak | ЕСТЬ³ |
Mac PICT, QTIF | рисунок Macintosh PICT | ЕСТЬ² ³ |
MED | звукозапись MED/OctaMED | ЕСТЬ³ |
MID, RMI | мелодия MIDI - Musical Instrument Digital Interface | ЕСТЬ³ |
MNG, JNG | рисунок Multiple Network Graphics | ЕСТЬ³ |
MOV, MP4 | видеозапись QuickTime Movie | ЕСТЬ² ³ |
MP3 | звукозапись MPEG layer 3 | ЕСТЬ³ |
MPG, MPEG | видеозапись Moving Pictures Experts Group | ЕСТЬ¹ ³ |
MrSID, SID | рисунок LizardTech SID Wavelet | ЕСТЬ³ |
DNG, EFF, NEF, MRW, ORF, RAF, DCR, SRF, ARW PEF, X3F, RW2, NRW | "фотосырьё" цифровых камер (Adobe, Epson, Nikon, Minolta, Olympus, Fuji, Kodak, Sony, Pentax, Sigma) | ЕСТЬ³ |
OGG | звукозапись OGG Vorbis | ЕСТЬ³ |
PBM | рисунок Portable Bitmap | ЕСТЬ | ЕСТЬ
PCX | формат рисунков PC Paintbrush от корпорации ZSoft | ЕСТЬ | ЕСТЬ
PCD | рисунок Kodak Photo CD | ЕСТЬ |
PDN | формат рисунков Paint.NET | ЕСТЬ³ |
PGM | рисунок Portable Greymap | ЕСТЬ | ЕСТЬ
PNG | рисунок Portable Network Graphics | ЕСТЬ | ЕСТЬ
PPM | рисунок Portable Pixelmap | ЕСТЬ | ЕСТЬ
PSD | рисунок Adobe PhotoShop | ЕСТЬ |
PSP | рисунок Paint Shop Pro | ЕСТЬ³ |
RAS, SUN | рисунок Sun Raster | ЕСТЬ³ |
RA | звукозапись RealAudio | ЕСТЬ³ |
RAW | "сырьё" - двоичные данные | ЕСТЬ³ |
RLE | рисунок Utah RLE | ЕСТЬ³ |
SFF | рисунок-факс Structured Fax File | ЕСТЬ³ |
SFW | формат Seattle Film Works | ЕСТЬ³ |
SGI, RGB, RGBA | рисунок Silicon Graphics | ЕСТЬ³ |
SWF, FLV | видео (анимация) Macromedia Flash/Shockwave | ЕСТЬ³ |
TGA | рисунок Truevision Advanced Raster Graphics Adapter (TARGA) | ЕСТЬ | ЕСТЬ
TIF, TIFF | рисунок Tagged Image File Format | ЕСТЬ | ЕСТЬ
TTF | шрифт True Type Font | ЕСТЬ³ |
TXT | текстовый файл (ASCII) | ЕСТЬ |
WAD | игровой формат WAD3 | ЕСТЬ³ |
WAL | текстура Quake 2 | ЕСТЬ³ |
WAV, WMA | звукозапись Windows | ЕСТЬ³ |
WBC/WBZ | форматы WebShots | ЕСТЬ³ |
WBMP | рисунок WAP Bitmap | ЕСТЬ³ |
WEBP | формат файлов Weppy | ЕСТЬ³ | ЕСТЬ³
WMF | рисунок Windows Metafile | ЕСТЬ |
WSQ | рисунок Wavelet Scaler Quantization | ЕСТЬ³ |
XBM | рисунок X11 Bitmap | ЕСТЬ³ |
XCF | формат рисунка GIMP | ЕСТЬ³ |
XPM | рисунок X11 Pixmap | ЕСТЬ³ |

¹ Для этих форматов нужна программа Microsoft Active Movie.

² Для этих форматов нужна программа Apple QuickTime.

³ Для этих форматов нужен плагин, где скачать см. выше.


Плагины

Всегда пользуйтесь текущими версиями IrfanView и плагинов.

Как установить плагины к IrfanView?

1. Зайти на сайт IrfanView: http://www.irfanview.com (или его зеркало).
2. Перейти в раздел "PlugIns".
3. Скачать плагины.
4. Щелкнуть по программе установки плагинов (irfanview_plugins_XXX_setup.exe).
5. Плагины будут установлены в подпапку "Plugins" папки IrfanView.

Загрузка:

Все плагины можно скачать с сайта:

http://www.irfanview.com/plugins.htm

Дополнительные сведения о плагинах см. в файле "i_plugins.txt" (в папке IrfanView).

Имеющиеся плагины:

Примечание: Этот плагин может потребовать дополнительных системных DLL (подробнее см. в "i_plugins.txt").

- ALTALUX: позволяет IrfanView использовать художественный фильтр AltaLux.

- ANSI2UNICODE: позволяет IrfanView читать имена файлов, содержащие символы юникода. Если используется русский интерфейс, этот плагин лучше не использовать - часть сообщений будет на "птичьем" языке

- AWD: позволяет IrfanView читать файлы Artweaver.

- B3D: позволяет IrfanView читать файлы BodyPaint 3D.

- BABACAD4IMAGE: позволяет IrfanView читать CAD-файлы DXF и DWG.

- BURNING: позволяет IrfanView записывать слайдшоу на CD.

Требует Windows XP или новее, плагин Nero позволяет записывать DVD с данными и VCD.

- CRW: позволяет IrfanView читать файлы Canon CRW и CR2 (изображения с высоким разрешением).
Примечание: Этот плагин требует дополнительных DLL от Canon (подробнее см. в "i_plugins.txt").

- CADIMAGE: позволяет IrfanView читать файлы CAD (DXF, DWG, HPGL, CGM, SVG). Условно-бесплатный сторонний модуль.
Примечание: подробности и ссылку на актуальную версию см. в "i_plugins.txt".

- DICOM: позволяет IrfanView читать медицинские файлы Dicom (DCM, ACR, IMA).

- DJVU: позволяет IrfanView читать файлы AT&T DJVU.

- EA_FSH: позволяет IrfanView читать и сохранять файлы EA Sports FSH.

- ECW: позволяет IrfanView читать и сохранять файлы ECW.

- EFFECTS: содержит изобразительные эффекты и позволяет использовать фильтры Adobe Photoshop 8BF.

Примечание: несколько неплохих плагинов с эффектами Adobe 8BF можно загрузить в виде дистрибутива с:

http://www.irfanview.net/plugins/irfanview_adobe_8bf_plugins.exe

или в архиве ZIP:

http://www.irfanview.net/plugins/irfanview_adobe_8bf_plugins.zip

Примечание: некоторые устаревшие или особые 8BF требуют дополнительных системных DLL (подрбнее см. в "i_plugins.txt").

- EMAIL: позволяет IrfanView отправлять картинки по электронной почте.

- EXR: позволяет IrfanView читать файлы EXR.

- FACEDETECT: позволяет в окне миниатюр IrfanView использовать функцию обнаружения лиц.

- Filter Factory: позволяет IrfanView использовать фильтры Filter Factory 8BF (модули для Photoshop).

- FLASH: позволяет IrfanView читать файлы Macromedia Flash и Shockwave.

- FORMATS: позволяет IrfanView читать рисунки некоторых экзотических форматов.
Это форматы: PSP, IFF/LBM, G3, RAS/SUN, Bio-RAD, Mosaic, XBM, XPM, GEM-IMG, WBMP, SGI, RLE, TTF, RAW, CRW, CR2, DNG, NEF, ORF, RAF, MAG, MRW, ERF, DCR, SRF, ARW, PEF, EFF, X3F, DDS, CAM, SFW, WAD, WAL, FITS, HDR, PVR, SIF

- FPX: позволяет IrfanView читать файлы FlashPix.

- Filters Unlimited: позволяет IrfanView использовать фильтры Filters Unlimited (модули для Photoshop).

подробнее см. в "FUnlimited_Readme.txt".

- FTP: позволяет из окна миниатюр IrfanView передавать файлы по протоколу FTP.

- HDP: позволяет IrfanView читать файлы HDP/WDP (Microsoft HD Photo).

- ICONS: дополнительные значки для файлов, связанных с IrfanView.

- ICS: позволяет IrfanView читать файлы ICS и IDS.

- IMPDF: позволяет IrfanView сохранять файлы PDF.

- IMPDN: позволяет IrfanView читать файлы PDN.

- IMXCF: позволяет IrfanView читать файлы XCF.

- IrfanView Sandbox: позволяет IrfanView использовать эффекты JewelScript.

- IV_Player: позволяет IrfanView воспроизводить звуко-, видеозаписи и аудио-CD.
Это форматы: AVI, MPG, WAV, MIDI, CDA, WMA, ASF, AIF, SND, WMV и т.п.

- JPEG2000: позволяет IrfanView читать и записывать файлы JPEG 2000.

- JPEG_LS: позволяет IrfanView читать и записывать файлы JLS (JPEG-LS, JPEG без потери качества).

- JPG Transformation: позволяет IrfanView выполнять преобразования JPG без потерь.

- JPM: позволяет IrfanView читать и записывать файлы JPM.

- KDC: позволяет IrfanView читать файлы цифровых камер Kodak.

- LCMS: позволяет IrfanView использовать цветовые профили, встроенные в файлы JPG и TIF.

- MED: позволяет IrfanView воспроизводить звукозаписи MED и OctaMED.

- METADATA: позволяет IrfanView работать с информацией EXIF, IPTC и комментариями из файлов, где она есть.

- MNG: позволяет IrfanView читать и воспроизводить файлы MNG и JNG.

- MP3: позволяет IrfanView воспроизводить файлы MP3, MP2, MP1.

- MRC: позволяет IrfanView читать файлы MRC.

- MrSID: позволяет IrfanView читать файлы LizardTech SID.

Примечание: этот плагин требует дополнительных DLL, их можно загрузить в виде дистрибутива с:

http://www.irfanview.net/plugins/irfanview_mrsid_plugin.exe

или в архиве ZIP:

http://www.irfanview.net/plugins/irfanview_mrsid_plugin.zip

- NERO: позволяет IrfanView записывать слайдшоу на CD с данными и видео-CD, используя программу Nero Burning ROM.

Скачать ее можно на http://www.nero.com.

- OCR_KADMOS: придает IrfanView возможность оптического распознавания символов.

Скачать его можно на http://www.irfanview.info/plugins/kadmos/.

- PAINT: позволяет IrfanView рисовать линии, стрелки, фигуры и т.п.

- PhotoCD: позволяет IrfanView читать файлы Kodak Photo CD.

- PNGOUT: позволяет оптимизировать сохранение PNG.

- POSTSCRIPT: позволяет IrfanView читать файлы PS, EPS, PDF, AI.

Примечание: Требует наличия Ghostscript: http://sourceforge.net/projects/ghostscript/

- QuickTime: позволяет IrfanView воспроизводить видеозаписи Apple QuickTime. (MOV, FLI/FLC)

- RA_Player: позволяет IrfanView воспроизводить звукозаписи RealAudio RA.

- REGIONCAPTURE: позволяет IrfanView to захватывать прямоугольную область экрана.

- RIOT: позволяет IrfanView сохранять оптимизированные файлы JPG, GIF и PNG.

- SFF: позволяет IrfanView читать файлы SFF (структурированный факс).

- Slideshow: позволяет IrfanView создавать презентации в форматах EXE и SCR (самостоятельные программы и экранные заставки).

- SoundPlayer: позволяет IrfanView воспроизводить звукозаписи OGG (Ogg Vorbis).

- TOOLS: содержит несколько дополнительных функций для IrfanView.

- VIDEO: позволяет IrfanView воспроизводить многие форматы звука и видео и извлекать из видео отдельные кадры.

- VTF: позволяет IrfanView читать файлы VTF (текстуры Valve).

- WBZ: позволяет IrfanView читать файлы WebShot (WBZ, WBC, WB1).

- WEBP: позволяет IrfanView читать и сохранять файлы Weppy (WEBP).

- WSQ: позволяет IrfanView читать файлы WSQ (Wavelet Scaler Quantization).


Клавиатурные команды

В IrfanView используются следующие клавиатурные команды:

Клавиши: Назначение:

+ Увеличить
= Увеличить
– Уменьшить
é Прокрутить изображение вверх
ê Прокрутить изображение вниз
è Прокрутить изображение вправо ИЛИ следующий файл в папке (если нет выделения)
ç Прокрутить изображение влево ИЛИ предыдущий файл в папке (если нет выделения)
стрелки Сдвинуть выделенный фрагмент (если нет полос прокрутки)
Page Up Показать предыдущий файл в папке ИЛИ прокрутить изображение вверх
Page Down Показать следующий файл в папке ИЛИ прокрутить изображение вниз
CTRL + Page Up Показать предыдущую страницу многостраничного изображения ИЛИ показать предыдущий файл в папке
CTRL + Page Down Показать следующую страницу многостраничного изображения ИЛИ показать следующий файл в папке
Пробел Показать следующий файл в папке
Забой (Backspace) Показать предыдущий файл в папке
CTRL + стрелка Пропорциональное изменение размеров выделенного фрагмента
SHIFT + стрелка Сдвинуть выделенный фрагмент
ALT + стрелка Изменить ширину или высоту выделенного фрагмента

Листая картинки если нажат CTRL: увеличить или уменьшить № файла на 5 (без CTRL - на 1 = следующий/предыдущий файл) клавишами Пробел, Забой, è,ç и т.п.
если нажат CTRL + цифра (0 - 9), увеличить № файла на цифру (0 = 10, 1 = 1 и т.п.)
если нажат CTRL + SHIFT + цифра (0 - 9), уменьшить № файла на цифру (0 = 10, 1 = 1 и т.п.)

ESC Закрыть активное окно (главное окно, слайдшоу, полноэкранный режим, миниатюры или диалоговое окно)
Ввод (Enter) Переключение между полноэкранным и оконным режимами
TAB Переключение между главным окном и окном миниатюр (если оно открыто)
CTRL + TAB Переключатель управления в окне миниатюр
Pause/Break Приостановить слайдшоу. Для продолжения слайдшоу нажмите ее еще раз.
DEL Удалить файл
INSERT Вставить изображение из буфера обмена
Home Прокрутить в начало (горизонтально) ИЛИ показать первый файл в папке
CTRL + Home Показать первый файл в папке
SHIFT + Home Показать первую страницу многостраничного изображения
End Прокрутить в конец (горизонтально) ИЛИ показать последний файл в папке
CTRL + End Показать последний файл в папке
SHIFT + End Показать последнюю страницу многостраничного изображения
F1 Справка
F2 или F6 Переименовать файл
F3 Показать в шестнадцатеричном режиме
F4 Добавить открытый файл в слайдшоу
F5 или U Обновить (картинки и список папок)
SHIFT + F5 Обновить + ресэмплировать (если включено ресэмплирование в меню "Вид à Просмотр")
F7 Переместить файл
F8 Скопировать файл
F9 Распознать текст (во всем изображении или выделенном прямоугольнике)
F10 Предварительный просмотр многостраничных изображений
F11 Показать/скрыть мышь в полноэкранном режиме и при слайдшоу
F12 Панель рисования

A О программе
B Преобразовать/переименовать группу файлов
C Захват (снимок экрана)
D Удалить изображение (очистить экран)
E Информация EXIF из JPG (фотографическая), если она в нем есть
F Переключение подгонки между "Под размер рабочего стола" и "Под размер окна"
G Остановить/продолжить анимацию GIF или ANI (кадры остановленной анимации можно листать клавишами Page Up/Down)
H Перевернуть горизонтально
I Свойства изображения
K Фильтры Filter Factory
L Повернуть на 90° влево
M Свернуть окно IrfanView - кнопка "шеф идет" ;-)
N Вкл.-выкл. подписи в полноэкранном режиме и слайдшоу
O Открыть файл
P Настройки программы
R Повернуть на 90° вправо
S Сохранить как...
T Миниатюры
V Перевернуть вертикально
W Слайдшоу
X Отметить текущий файл (листая картинки в оконном и полноэкранном режиме)

CTRL + A Выделить все изображение/снять выделение или выделить все миниатюры (в окне миниатюр)
CTRL + B Обзор вложенных папок
CTRL + C Скопировать изображение в буфер обмена
CTRL + E Настройка эффектов
CTRL + F Найти файлы
CTRL + G Преобразовать в оттенки серого
CTRL + H Показать в исходном размере (не масштабируя)
CTRL + I Информация IPTC из JPG
CTRL + J Правка à Повторить
CTRL + K Фильтры Adobe 8BF
CTRL + M Показать случайную картинку из текущей папки
CTRL + N Показать текущий файл в новом окне IrfanView
CTRL + P Распечатать
CTRL + Q Изменить многостраничный TIF
CTRL + R Изменить размер
CTRL + S Сохранить
CTRL + T Нанести текст
CTRL + U Повернуть на произвольный угол
CTRL + V Вставить из буфера обмена
CTRL + W Начать слайдшоу из файлов текущей папки
CTRL + X Вырезать выделенный фрагмент
CTRL + Y Обрезать выделенный фрагмент
CTRL + Z Отменить последнее действие
CTRL + цифра Листая картинки (в оконном и полноэкранном режиме): увеличить № файла на цифру (0-9)
CTRL + Print Захват (снимок) выделенного участка экрана или объекта

SHIFT + 1 Открыть во внешнем редакторе №1
SHIFT + 2 Открыть во внешнем редакторе №2
SHIFT + 3 Открыть во внешнем редакторе №3
SHIFT + A Автоматический просмотр - старт/стоп (слайдшоу в окне)
SHIFT + C Создать пользовательское выделение
SHIFT + F Уменьшать большие изображения до размера экрана
SHIFT + G Коррекция цветов
SHIFT + H Показать гистограмму
SHIFT + J Обработка JPG без потерь
SHIFT + L Заблокировать/разблокировать масштаб (также в полноэкранном режиме)
SHIFT + M Отправить картинку по электронной почте
SHIFT + N Создать новое изображение
SHIFT + O Окно в размер изображения (показ 1:1)
SHIFT + P Скопировать имя текущего файла в буфер обмена
SHIFT + Q Листая картинки (в оконном и полноэкранном режиме): показать отмеченные файлы в окне миниатюр
SHIFT + R Открыть файл повторно
SHIFT + S Повысить резкость
SHIFT + T Ввод № файла в панели инструментов
SHIFT + U Автоматически скорректировать цвета
SHIFT + V Изменить размер холста (добавить поля)
SHIFT + W Подгонять изображения под размер окна
SHIFT + X Листая картинки (в оконном и полноэкранном режиме): снять отметку с текущего файла
SHIFT + Y Убрать красные глаза

Alt + SHIFT + S Показать/скрыть строку состояния
Alt + SHIFT + T Показать/скрыть панель инструментов
Alt + SHIFT + M Показать/скрыть меню
Alt + SHIFT + C Показать/скрыть заголовок окна

CTRL + SHIFT + A Получить/отсканировать серию изображений
CTRL + SHIFT + J Обрезка JPG без потерь
CTRL + SHIFT + M Комментарий к JPG
CTRL + SHIFT + K Заблокировать точку прокрутки
CTRL + SHIFT + L Поворот JPG влево без потерь
CTRL + SHIFT + R Поворот JPG вправо без потерь
CTRL + SHIFT + C Создать фоновый рисунок рабочего стола по центру
CTRL + SHIFT + T Создать фоновый рисунок рабочего стола - замостить
CTRL + SHIFT + S Создать фоновый рисунок рабочего стола - растянуть
CTRL + SHIFT + P Вернуть предыдущий фоновый рисунок рабочего стола
CTRL + SHIFT + W Растянуть изображение на все мониторы (вкл.-выкл.)
CTRL + SHIFT + X Создать фоновый рисунок рабочего стола - растянуть пропорционально
CTRL + SHIFT + Y Автообрезка границ
CTRL + SHIFT + цифра Листая картинки (в оконном и полноэкранном режиме): уменьшить № файла на цифру (0-9)

CTRL + SHIFT + стрелка Точный поворот: стрелки влево-вправо: 0.10 градуса; стрелки вверх-вниз: 0.05 градуса

CTRL + ALT + P Распечатка картинки без показа окна печати (прямая печать)

1 Полноэкранный режим: Показывать изображения в исходном размере (1:1)
2 Полноэкранный режим: Уменьшать большие изображения
3 Полноэкранный режим: Вписывать все в экран
4 Полноэкранный режим: Растягивать все до заполнения
5 Полноэкранный режим: Вписывать изображения по ширине экрана
6 Полноэкранный режим: Вписывать изображения по высоте экрана

Серая 5 Отцентрировать изображение

В IrfanView используются следующие команды для выделенного фрагмента:

Нажать левой и провести Выделить фрагмент
CTRL + левая кнопка Выделить с пропорциями "пользовательского выделения"
ALT + левая кнопка Выделить с пропорциями, обратными "пользовательскому выделению"
Щелчок левой Укрупнить выделенный фрагмент
Правая кнопка Сдвинуть выделенный фрагмент
стрелки Сдвинуть выделенный фрагмент (если нет полос прокрутки)
SHIFT + стрелки Сдвинуть выделенный фрагмент
CTRL + стрелки Пропорциональное изменение размеров выделенного фрагмента
ALT + стрелки Изменить ширину или высоту выделенного фрагмента

В IrfanView используются следующие команды мышью:

В обычном режиме:

Нажать и удерживать левую кнопку Показать в заголовке окна координаты мыши и цвет пиксела (или укрупнить выделение)
SHIFT +левая кнопка Показать координаты и цвет пиксела + скопировать № цвета в буфер обмена
Нажать левой и провести Выделить фрагмент
CTRL + левая кнопка Выделить с пропорциями "пользовательского выделения"
Щелчок правой кнопкой Прокрутить изображение или контекстное меню (если включено или при просмотре видео).
CTRL + нажать правой и провести Прокрутить изображение в этом направлении (даже если включено контекстное меню).
Нажать правой и провести Прокрутить изображение в этом направлении. Если внутри выделения - сдвинуть выделенный фрагмент.
Двойной щелчок левой Перейти в полноэкранный режим

Ролик вверх Показать предыдущий файл в папке ИЛИ прокрутить изображение вверх
Ролик вниз Показать следующий файл в папке ИЛИ прокрутить изображение вниз
CTRL + ролик вверх Увеличить (центруя мышью)
CTRL + ролик вниз Уменьшить (центруя мышью)
SHIFT + ролик Прокрутить изображение горизонтально

В окне миниатюр:

CTRL + щелчок левой В дереве папок: Загрузить миниатюры из выбранной папки и всех её подпапок

В полноэкранном режиме и при слайдшоу:

Щелчок левой Показать предыдущий файл в папке
Щелчок правой Показать следующий файл в папке
CTRL + щелчок правой При просмотре видео: показать контекстное меню видео
Щелчок левой ... в верхнем левом или правом углу экрана = выйти из полноэкранного режима.
C Вкл/выкл. центровку картинки на экране
F Смена (циклическая) режима полноэкранного масштабирования
è Показать следующий файл в папке
ç Показать предыдущий файл в папке
F8 Скопировать файл (текущий)
F11 Показать/скрыть мышь
SHIFT + . Переключение режима слайдшоу: случайный/автоматический (по нажатию клавиши)
SHIFT + Z Смена режима: показывать все картинки или пейзажи/портреты (на основе пропорций изображения)

Клавиши управления воспроизведением (через DirectShow) в полноэкранном режиме и слайдшоу:

B Скрыть/показать панель управления
Y Скрыть/показать имя файла в панели управления
CTRL + C Скопировать текущий кадр в буфер
Стрелки вверх-вниз Изменить громкость звуковой дорожки
+ / - Масштаб видео (больше / меньше)
Стрелки влево-вправо Пропустить 10% видео
CTRL + стрелки влево-вправо Пропустить 5% видео
SHIFT + стрелки влево-вправо Пропустить 1% видео
Движение мыши внизу экрана: Скрыть/показать панель управления

В автономном слайдшоу (EXE):

E Извлечь все картинки из слайдшоу
T или N Показать/скрыть подписи к картинкам
F Смена (циклическая) режима полноэкранного масштабирования
F1 Вызов справки
F11 Показать/скрыть мышь


Ключи командной строки

==&qt; Актуальную сводку ключей командной строки см. в файле "i_options.txt" (в папке IrfanView).

Ключи командной строки позволяют передать IrfanView некоторые команды еще до ее запуска.

В командной строке IrfanView можно использовать следующие ключи:

/one - команда "Запрет одновременного запуска нескольких копий IrfanView"
/fs - открыть в полноэкранном режиме
/bf - показать, подогнав под размер рабочего стола
/title=текст - написать в заголовке окна "текст"
/pos=(x,y) - переместить окно в положение x,y (если это позволяют параметры экрана)
/convert=ИмяФайла - конвертировать файл(ы) в "ИмяФайла" и ЗАКРЫТЬ IrfanView

(подробнее о шаблонах имен см. в "Настройке шаблона")

/slideshow=список - показать слайдшоу с файлами, перечисленными в списке
/slideshow=папка - показать слайдшоу с файлами из папки "папка"
/reloadonloop - после окончания /slideshow начать с начала
/filelist=список - взять имена файлов из списка, см. примеры ниже
/thumbs - открыть окно миниатюр
/killmesoftly - закрыть все сеансы IrfanView (выход после отработки командной строки)
/cmdexit - закрыть текущую IrfanView после отработки командной строки
/closeslideshow - в конце слайдшоу закрыть IrfanView
/page=X - открыть страницу номер X многостраничного изображения
/crop=(x,y,w,h,C) - обрезать картинку: x начала, y начала, w-ширина, h-высота, C-начало отсчета (0-4)
/print - распечатать картинку и закрыть IrfanView
/print="имя" - распечатать на указанном принтере и закрыть IrfanView
/resize=(w,h) - изменить размеры картинки на w (ширина) и h (высота)
/resize_long=X - изменить размеры картинки: длинную сторону сделать = X
/resize_short=X - изменить размеры картинки: короткую сторону сделать = X
/resample - изменять размер ресэмплированием (повышает качество)
/aspectratio - сохранять пропорции при /resize
/capture=X - захват экрана или окна (см. примеры ниже)
/ini - читать и сохранять файлы настроек и списки в папке Windows
/ini="папка" - читать и сохранять файлы настроек и списки в папке "папка"
/clippaste - вставить изображение из буфера обмена
/clipcopy - скопировать изображение в буфер обмена
/silent - не выдавать сообщения об ошибках чтения-записи
/invert - инвертировать изображение (преобразовать в негативное)
/dpi=(x,y) - изменить значения DPI, задать DPI для сканирования
/scan - отсканировать изображение, открыв окно TWAIN
/scanhidden - отсканировать, скрыв окно TWAIN
/batchscan=(пар-ры) - сканирование серии изображений, см. примеры ниже
/bpp=БитНаПиксел - изменить глубину цвета изображения на БитНаПиксел
/swap_bw - поменять белый и черный цвета
/gray - преобразовать изображение в оттенки серого
/rotate_r - повернуть изображение на 90° вправо
/rotate_l - повернуть изображение на 90° влево
/hflip - перевернуть горизонтально
/vflip - перевернуть вертикально
/filepattern="x" - показывать только указанные файлы
/sharpen=X - повысить резкость изображения (фильтр "sharpen") до X
/effect=(X,п1,п2) - применить фильтр эффекта X, см. примеры ниже
/contrast=X - установить контрастность изображения = X
/bright=X - установить яркость изображения = X
/gamma=X - установить гамма-коррекцию изображения = X
/advancedbatch - выполнить заданные операции с группой файлов (из файла настроек)
/hide=X - скрыть указанные элементы окна (см. примеры ниже)
/transpcolor=(r,g,b) - задать прозрачный цвет для форматов GIF, PNG, ICO
/info=файл - записать информацию об изображении в "файл"
/fullinfo - записать данные EXIF, IPTC и комментарий при /info
/shortinfo - записать только номер и имя файла при /info
/append=ФайлTIFF - добавить изображение как страницу (TIF) в "ФайлTIFF"
/multitif=(tif,файлы) - создать многостраничный TIF из файлов
/panorama=(X,файлы) - создать панораму из файлов; X = направление (1 или 2)
/jpgq=X - качество сохранения JPG
/tifc=X - тип сжатия TIF при сохранении
/wall=X - сделать картинку обоями рабочего стола; см. примеры ниже
/extract=(папка,расш) - извлечь все страницы из многостраничного файла
/import_pal=палитра - открыть палитру (PAL) и применить ее к изображению
/jpg_rotate=(пар-ры) - поворот JPG без потерь, см. примеры ниже
/monitor=X - запустить EXE-слайдшоу на мониторе X
/window=(x,y,w,h) - задать положение и размер окна EXE-слайдшоу
/clearmonitors - показать EXE-слайдшоу на одном мониторе, очистить все остальные мониторы

Примечания:

- ключи пишутся только строчными буквами (не используйте ЗАГЛАВНЫЕ)!

- имя открываемого файла (при необходимости) всегда должно быть первым параметром!

- имена с пробелами берите в кавычки, например: "c:\images\dummy test file.jpg".

- в именах файлов всегда указывайте ПОЛНЫЙ путь к ним (включая букву диска).

- в одной команде можно совмещать несколько ключей.

- шаблоны имен можно использовать только с /convert, /multitif, /panorama, /print, /info и /jpg_rotate.

- длина командной строки ограничена Windows, поэтому указывайте короткие имена и пути.

- большинство настроек программа берет из INI-файла. Можно расширить возможности, используя подготовленные заранее файлы настроек и ключ /ini=папка.

- код завершения IrfanView - 0. С ключами /convert и /print он может быть равен 1 или 2, информируя об ошибках при открытии или сохранении.

Пример преобразования:

i_view32.exe c:\test.bmp /convert=c:\test.jpg

Конвертировать файл: "c:\test.bmp" в "c:\test.jpg" , не открывая окна программы.

i_view32.exe c:\*.jpg /convert=d:\temp\*.gif

i_view32.exe c:\*.jpg /resize=(500,300) /convert=d:\temp\*.png

i_view32.exe c:\*.jpg /resize=(500,300) /aspectratio /resample /convert=d:\temp\*.png

i_view32.exe /filelist=c:\mypics.txt /resize=(500,300) /aspectratio /resample /convert=d:\temp\*.png

i_view32.exe c:\test.bmp /convert=c:\test_$Wx$H.jpg

i_view32.exe c:\test.bmp /resize=(100,100) /resample /aspectratio /convert=d:\$N_thumb.jpg

i_view32.exe c:\test.bmp aspectratio /convert=d:\temp\$T(%Y%m%d)\test_$Wx$H.jpg

i_view32.exe c:\test.bmp /convert=$D$N.jpg

i_view32.exe c:\*.bmp /convert=$D$N.jpg

i_view32.exe c:\*.jpg /advancedbatch /convert=c:\temp\*.jpg

i_view32.exe c:\test.bmp /transpcolor=(255,255,255) /convert=c:\giftest.gif

(Примечание: Применимо ко всем форматам, которые IrfanView может открыть и сохранить, кроме аудио и видео.)

Пример слайдшоу:

i_view32.exe /slideshow=c:\mypics.txt

(Примечание: В каждой строке файла "c:\mypics.txt" должно быть имя файла изображения с полным путем ИЛИ путем относительно i_view32.exe.)

i_view32.exe /slideshow=c:\mypics.txt /reloadonloop

i_view32.exe /slideshow=c:\images\

i_view32.exe /slideshow=c:\images\ /reloadonloop

i_view32.exe /slideshow=c:\images\*.jpg

i_view32.exe /slideshow=c:\images\test*.jpg

Если нет ключа /closeslideshow, то в конце слайдшоу нужно будет закрыть IrfanView вручную.

Пример с ключом /closeslideshow:

i_view32.exe /slideshow=c:\mypics.txt /closeslideshow

IrfanView закроется после показа последней картинки из списка "c:\mypics.txt".

Пример миниатюр:

i_view32.exe c:\test\image1.jpg /thumbs

Открыть "image1.jpg" и показать миниатюры в папке "c:\test".

i_view32.exe c:\test\ /thumbs

i_view32.exe /thumbs c:\test\

Показать миниатюры в папке "c:\test".

i_view32.exe /filelist=c:\mypics.txt /thumbs

Открыть файлы из списка "c:\mypics.txt" и показать их миниатюры.

Пример списка файлов:

i_view32.exe /filelist=c:\mypics.txt

i_view32.exe /filelist=c:\mypics.txt /convert=d:\test\*.jpg

i_view32.exe /filelist=c:\mypics.txt /thumbs

Пример закрытия:

i_view32.exe /killmesoftly

Закрыть все открытые окна IrfanView.

Пример открытия страницы:

i_view32.exe c:\test.tif /page=3

Открыть страницу номер 3 многостраничного изображения "c:\test.tif".

Пример обрезки:

Варианты начала отсчета: 0 = слева сверху, 1 = справа сверху, 2 = слева снизу, 3 = справа снизу, 4 = центр.

i_view32.exe c:\test.jpg /crop=(10,10,300,300,0)

Открыть "c:\test.jpg" и обрезать: x начала=10, y начала=10, ширина=300, высота=300 (пикселов), начало отсчета = слева сверху.

i_view32.exe c:\test.jpg /crop=(10,10,300,300,4) /convert=c:\giftest.gif

Открыть "c:\test.jpg" и обрезать: x начала=10, y начала=10, ширина=300, высота=300 (пикселов), начало отсчета = центр.

Пример распечатки:

i_view32.exe c:\test.jpg /print

Открыть "c:\test.jpg", распечатать на используемом по умолчанию принтере и закрыть IrfanView.

i_view32.exe c:\test.jpg /print="Epson"

Открыть "c:\test.jpg", распечатать на принтере "Epson" и закрыть IrfanView.

i_view32.exe c:\*.jpg /print

Распечатать все JPG из папки "C:\" и закрыть IrfanView.

Примечание: Настройки печати берутся из INI-файла.

Пример изменения размера:

i_view32.exe c:\test.jpg /resize=(300,300) /resample

Открыть "c:\test.jpg" и ресэмплировать (передискретизировать) до размера: ширина=300, высота=300.

(Примечание: используется фильтр ресэмплирования, указанный в INI-файле.)

i_view32.exe c:\test.jpg /resize=(300,300) /aspectratio

Открыть "c:\test.jpg" и, сохранив пропорции, изменить размеры: ширина= не более 300, высота= не более 300.

i_view32.exe c:\test.jpg /resize_long=300 /aspectratio /resample

Открыть "c:\test.jpg" и ресэмплировать до размера: длинная сторона=300, короткая сторона=пропорциональна.

i_view32.exe c:\test.jpg /resize=(300,0)

Открыть "c:\test.jpg" и изменить размеры: ширина=300, высота=исходная.

i_view32.exe c:\test.jpg /resize=(300,0) /aspectratio

Открыть "c:\test.jpg" и изменить размеры: ширина=300, высота=пропорциональна.

i_view32.exe c:\test.jpg /resize=(150p,150p)

Открыть "c:\test.jpg" и изменить размеры: ширина=150%, высота=150%.

Пример захвата:

i_view32.exe /capture=0

Захват всего экрана.

i_view32.exe /capture=6

Захват с настройками из INI-файла.

режимы захвата:

0 = весь экран

1 = текущий монитор (на котором находится мышь)

2 = активное окно

3 = активное окно - только содержимое

4 = выделенный прямоугольник

5 = объект, выбранный мышью

6 = с последними настройками захвата (несовместим с другими ключами)

7 = заданный прямоугольник (из последних настроек захвата)

Дополнительные примеры:

i_view32.exe /capture=2 /convert=c:\test.jpg

Захват активного окна с сохранением результата в файле.

i_view32.exe /capture=2 /convert=c:\capture_$U(%d%m%Y_%H%M%S).jpg

Захват активного окна с сохранением результата в файле, в имени которого указано время захвата.

Пример загрузки настроек из INI-файла:

i_view32.exe /ini

i_view32.exe c:\test.jpg /ini

i_view32.exe c:\test.jpg /ini="c:\temp\"

Пример вставки из буфера обмена:

i_view32.exe /clippaste

i_view32.exe /clippaste /convert=c:\test.gif

Пример копирования в буфер обмена:

i_view32.exe c:\test.jpg /clipcopy

i_view32.exe c:\test.jpg /clipcopy /killmesoftly

Пример инвертирования:

i_view32.exe c:\test.jpg /invert

Пример задания DPI:

i_view32.exe c:\test.jpg /dpi=(72,72)

Пример сканирования:

С этим ключом совместимы только: /print, /dpi, /gray и /convert.

i_view32.exe /scan

i_view32.exe /scanhidden

i_view32.exe /scanhidden /dpi=(150,150)

i_view32.exe /scan /convert=c:\test.gif

i_view32.exe /scan /append=c:\test.tif

i_view32.exe /scanhidden /convert=c:\test.gif

i_view32.exe /scanhidden /gray /convert=c:\test.gif

i_view32.exe /print /scan

Пример сканирования серии изображений /batchscan=(параметры):

параметры = все 8 параметров пакетного сканирования:

имя файла, начальный номер, приращение, число цифр в номере, пропускать ли, папка назначения, формат сохранения (расширение), многостраничный ли

i_view32.exe /batchscan=(scanfile,1,1,2,1,c:\temp,bmp,0)

i_view32.exe /batchscan=(scanfile,1,1,2,1,c:\temp,bmp,0) /dpi=(150,150)

i_view32.exe /batchscan=(scanfile,1,1,2,0,c:\temp,tif,1)

i_view32.exe /batchscan=("crazy, filename",1,1,2,0,"c:\temp\crazy, (folder)",tif,1)

i_view32.exe /batchscan=(scanfile,1,1,2,1,c:\temp,bmp,0) /scanhidden

Пример изменения глубины цвета:

i_view32.exe c:\test.jpg /bpp=8

Открыть "c:\test.jpg" и уменьшить до 256 цветов. Допустимые значения BPP: 1, 4, 8 и 24 (уменьшение или увеличение глубины цвета).

Пример отбора файлов по шаблону:

i_view32.exe c:\images\ /filepattern="*.jpg"

В папке "'c:\images" открывать при обзоре только файлы JPG.

i_view32.exe c:\images\ /thumbs /filepattern="*.jpg"

В папке "'c:\images" показать миниатюры только файлов JPG.

i_view32.exe c:\images\ /thumbs /filepattern="123*.jpg"

В папке "'c:\images" показать миниатюры только файлов JPG с именами, начинающимися с "123".

Пример эффекта /effect=(№эффекта,параметр1,параметр2)::

i_view32.exe c:\test.jpg /effect=(6,3,0)

Медианный фильтр, сила = 3.

i_view32.exe c:\test.jpg /effect=(2,3,50)

Размытие-2, параметр1 = 3, параметр2 = 50.

Номера эффектов (из окна "Все эффекты"):

1 = Размытие (Blur)

2 = Размытие 2

...

38 = Металлик - лед (Metallic Ice)

Пример повышения резкости:

i_view32.exe c:\test.jpg /sharpen=33

Пример скрытия:

Значения (можно совмещать - складывать):

Панель инструментов 1
Строка состояния 2
Меню 4
Заголовок окна 8

i_view32.exe c:\test.jpg /hide=1

Открыть "c:\test.jpg", скрыв панель инструментов.

i_view32.exe c:\test.jpg /hide=3

Открыть "c:\test.jpg", скрыв панель инструментов и строку состояния.

i_view32.exe c:\test.jpg /hide=12

Открыть "c:\test.jpg", скрыв заголовок и меню.

i_view32.exe c:\test.jpg /hide=15

Открыть "c:\test.jpg", скрыв всё.

Пример сохранения информации в файле:

i_view32.exe c:\test.jpg /info=c:\test.txt

i_view32.exe c:\test.jpg /info=c:\jpgs.txt /fullinfo

i_view32.exe c:\*.jpg /info=c:\jpgs.txt

Пример добавления страницы:

i_view32.exe c:\test.jpg /append=c:\test.tif

Открыть "c:\test.jpg " и добавить его как страницу в "c:\test.tif".

Пример создания многостраничного TIF:

Синтаксис: /multitif=(имя.tif,файл1,...,файлN)

Первое имя - создаваемого файла TIF.

i_view32.exe /multitif=(c:\test.tif,c:\test1.bmp,c:\dummy.jpg)

создать многостраничный TIF ("c:\test.tif") из 2 других изображений.

i_view32.exe /multitif=(c:\test.tif,c:\*.bmp)

i_view32.exe /multitif=(c:\test.tif,c:\*.bmp,c:\dummy.jpg,c:\123*.gif)

Пример создания панорамы:

Синтаксис: /panorama=(X,file1,...,fileN)

Первый параметр (X) - направление: 1 = горизонтальная, 2 = вертикальная.

i_view32.exe /panorama=(1,c:\test1.bmp,c:\dummy.jpg)

Создать горизонтальную панораму из 2 других файлов.

i_view32.exe /panorama=(1,c:\test.tif,c:\*.bmp)

i_view32.exe /panorama=(2,c:\test.tif,c:\*.bmp,c:\dummy.jpg,c:\123*.gif)

Пример задания качества JPG:

i_view32.exe c:\test.jpg /jpgq=75 /convert=c:\new.jpg

Открыть "c:\test.jpg" и сохранить его как "c:\new.jpg" с качеством = 75. Диапазон качества: от 1 до 100.

Пример задания типа сжатия TIF:

i_view32.exe c:\test.jpg /tifc=4 /convert=c:\new.tif

Открыть "c:\test.jpg" и сохранить его как "c:\new.tif" со сжатием = Fax4.

Типы сжатия: 0 = без сжатия, 1 = LZW, 2 = Packbits, 3 = Fax3, 4 = Fax4, 5 = Huffman, 6 = JPG, 7 = ZIP.

Пример обоев:

i_view32.exe c:\test.jpg /wall=0

Открыть "c:\test.jpg" и сделать его обоями рабочего стола (по центру).

виды обоев: 0 (по центру), 1 (черепицей), 2 (растянуть), 3 (растянуть пропорционально)

i_view32.exe c:\images\*.jpg /random /wall=0 /killmesoftly

i_view32.exe /filelist=c:\mypics.txt /random /wall=0 /killmesoftly

Взять случайный файл из папки (списка), сделать его обоями рабочего стола и закрыть IrfanView.

Пример извлечения страниц:

i_view32.exe c:\multipage.tif /extract=(c:\temp,jpg)

Открыть "c:\multipage.tif" и сохранить все его страницы в папке "c:\temp" в формате JPG.

Пример запуска автономного слайдшоу (EXE):

MySlideshow.exe /monitor=2

=> запустить слайдшоу на мониторе №2.

MySlideshow.exe /window=(0,0,800,600)

=> запустить слайдшоу в верхнем левом углу в окне размером 800x600.

MySlideshow.exe /monitor=2 /clearmonitors

=> запустить слайдшоу на мониторе №2, очистить экран монитора №1 (и все остальные).

Пример операций с группой файлов:

i_view32.exe c:\test.jpg /advancedbatch /convert=c:\image.jpg

("Разное" в дополнительных параметрах не поддерживается)

Открыть c:\test.jpg', применить групповые операции с настройками из INI-файла и сохранить как новый файл.

Пример вращения JPG /jpg_rotate=(параметры):

параметры= все 8 параметров преобразования JPG без потерь:

операция, оптимизировать, датировать по EXIF, не изменять датировку, установить DPI, значение DPI, параметры маркеров, свой выбор маркеров

Примечание: этот ключ заменяет исходные файлы измененными!

Значения:

Операция : нет (0), перевернуть по вертикали (1) ... повернуть автоматически (6)
Оптимизировать : 0 или 1
Датировать по EXIF : 0 или 1
Не изменять дату : 0 или 1
Установить DPI : 0 или 1
Значение DPI : число
Маркеры : сохранить все (0), сбросить все (1), свой выбор (2)

Свой выбор маркеров (можно совмещать - складывать):

сохранить комментарий 1

сохранить EXIF 2

сохранить IPTC 4

сохранить прочие 8

i_view32.exe c:\test.jpg /jpg_rotate=(6,1,1,0,1,300,0,0)

=> повернуть по данным EXIF, оптимизировать, датировать по данным EXIF, задать DPI = 300, сохранить все маркеры

i_view32.exe c:\test.jpg /jpg_rotate=(6,1,1,0,0,0,2,6)

=> повернуть по данным EXIF, оптимизировать, датировать по данным EXIF, сохранить маркеры EXIF и IPTC

i_view32.exe c:\test.jpg /jpg_rotate=(3,1,0,1,0,0,1,0)

=> повернуть на 90°, оптимизировать, сохранить с исходной датой, сбросить все маркеры

i_view32.exe c:\images\*.jpg /jpg_rotate=(6,1,1,0,0,0,0,0)

=> все JPG повернуть по данным EXIF, оптимизировать, датировать по данным EXIF, сохранить все маркеры


Панель инструментов

Панель инструментов обеспечивает быстрый доступ к некоторым наиболее полезным функциям IrfanView.

Включается панель инструментов командой "Панель инструментов" из меню "Вид". Отключается повторением той же команды.

В окне "Настройки программы à Панель инструментов", можно выбрать разные обложки (дизайны кнопок) и добавить или убрать кнопки с панели инструментов.

Дополнительные обложки панели инструментов есть на домашней странице IrfanView.


Открыть

В меню "Файл" выберите "Открыть" (или нажмите на одноименную кнопку панели инструментов). Откроется окно выбора файла для просмотра в IrfanView.

Найдите нужный файл в поле "Папка" или введите его имя в поле "Имя файла". Поле "Тип файлов" позволяет ограничить выбор, показывая только файлы выбранного типа (например, JPG). Изначально это -распространенные графические форматы. (Примечание: Windows не позволяет выбрать одновременно файлы всех типов, поддерживаемых IrfanView, в одной строке списка.)

Если поставить галочку "Предварительный просмотр", то при щелчке по имени файла изображения будет показан его эскиз. Второй щелчок открывает файл для просмотра. Можно и сразу сделать двойной щелчок.

Для ускорения выбора здесь показаны последние папки, в которых открывались файлы. Это можно отключить в меню "Настройки программы à Разное".

Для отмены открытия файла нажмите "Отмена". или щелкните по кнопке "X" в верхнем правом углу окна выбора файла.

Открыв файл, вы увидите картинку или сообщение об ошибке, если IrfanView не может показать его содержимое.

Если открыта большая картинка, то рассмотреть ее всю можно с помощью полос прокрутки. Прокручивать картинку можно и клавишами-стрелками, PgUp, PgDn, Home и End, а также правой кнопкой мыши: нажмите её и передвигайте мышь.


Открыть повторно, Открыть недавние файлы

В меню "Файл" выберите "Открыть повторно", чтобы заново открыть последний открытый (текущий) файл.

В меню "Файл" выберите "Открыть недавние файлы", чтобы выбрать файл из списка последних открывавшихся, и открыть его одним щелчком. Можно очистить список недавних файлов или полностью отключить его показ в меню "Настройки программы à Разное".


Открыть во внешнем редакторе

В меню "Файл" выберите "Открыть во внешнем редакторе". Будет запущен выбранный внешний редактор, и в нем откроется это изображение (например, Adobe Photoshop, Paint Shop Pro и т.п.).

Для этого нужно предварительно выбрать внешний редактор.


Открыть как

В меню "Файл" выберите "Открыть как".

Как HEX-файл (в шестнадцатеричном режиме): можно открыть любой файл в окне шестнадцатеричного просмотра.

В нем все байты открытого файла отображаются как шестнадцатеричные коды и как текстовые символы (для опытных пользователей).

Как ASCII-файл (текстовый): можно открыть любой текстовый файл (TXT, HTM, INI и т.п.) и просмотреть его изображение.

Как RAW-файл: можно попытаться загрузить любой файл как "фотосырьё" - необработанный снимок цифровой камеры. (для опытных пользователей, с помощью плагина Formats)


Миниатюры

Откройте картинку из выбранной папки. В меню "Файл" выберите "Миниатюры". Откроется окно, заполненное миниатюрами-эскизами картинок из этой папки.

В левой его части - дерево дисков и папок.

Двойным щелчком по эскизу эта картинка открывается в главном окне программы. Если открыть картинку из другой папки, то откроются и эскизы из нее.

Чтобы закрыть это окно, выберите "Выход" в его меню или нажмите Esc.

Меню "Файл":

"Переместить выбранные файлы" позволяет переместить все выбранные эскизы (файлы) в другую папку.

"Скопировать выбранные файлы" позволяет скопировать все выбранные эскизы (файлы) в другую папку.

"Удалить выбранные файлы" позволяет удалить все выбранные эскизы (файлы).

"Запустить слайдшоу из выбранных файлов": Запуск слайдшоу из выбранных картинок с действующими настройками слайдшоу. Примечание: Текущий (глобальный) список картинок для слайдшоу (файл slideshow.lst) не изменяется.

"Сохранить выбранные файлы как текущее слайдшоу": Запись выбранных эскизов в текущий (глобальный) список слайдшоу (файл slideshow.lst).

"Добавить выбранные файлы в текущее слайдшоу": Добавление выбранных эскизов в текущий список слайдшоу.

"Операции с группой выбранных файлов": Открыть окно групповых операций с выбранными эскизами (файлами).

"Передать выбранные файлы по FTP": Открыть окно FTP с выбранными эскизами (файлами).

"Сохранить список выбранных файлов": Сохранение списка имен выбранных файлов в текстовый файл.

"Операции с выбранными JPG-файлами без потерь": Открыть окно преобразования JPG без потерь и преобразовать все выбранные файлы JPG. Их можно повернуть, перевернуть, обрезать, оптимизировать, вычистить, добавить комментарий или данные IPTC.

Примечание: преобразование JPG без потерь возможно только если установлен плагин JPG_Transform. Для просмотра и редактирования данных IPTC и комментария нужен плагин Metadata.

"Создать контрольный лист из выбранных файлов": позволяет создать одну большую сводную картинку (контрольный лист или каталог) из выбранных эскизов. Откроется окно выбора настроек контрольного листа.

Примечание: Контрольный лист создается в оперативной памяти. Из-за этого в 32-битных версиях Windows его размер ограничен примерно 6000x5500 пикселов.

В 64-битных версиях Windows предел значительно выше, допускается даже размер 25000x25000 пикселов.

"Создать панорамное изображение из выбранных файлов": Открыть окно сборки панорамы из выбранных картинок.

Создать многостраничный TIF/PDF из выбранных файлов: Открыть окно создания многостраничного TIF/PDF из выбранных картинок.

"Сохранить выбранные миниатюры как одно изображение": Создать одну большую сводную картинку из выбранных эскизов и сохранить ее. Можно будет выбрать папку для ее сохранения. Картинки выбираются щелчком по эскизам при нажатой клавише Ctrl, или командой "Выбрать все" (см. ниже).

"Сохранить выбранные миниатюры как отдельные изображения": Создать из выбранных эскизов картинки и сохранить их каждую отдельно. Можно будет выбрать папку для их сохранения. Картинки выбираются щелчком по эскизам при нажатой клавише Ctrl, или командой "Выбрать все" (см. ниже).

"Сохранить выбранные миниатюры как HTML-файл": Создать страницу миниатюр, которую можно будет открыть в обозревателе Интернета или разместить на сайте. Можно будет выбрать некоторые параметры HTML и папку для сохранения файла. Картинки выбираются щелчком по эскизам при нажатой клавише Ctrl, или командой "Выбрать все" (см. ниже). Подробнее о шаблонах HTML и примеры см. на этой странице.

Типовые файлы-шаблоны HTML находятся в подпапке "HTML" папки IrfanView. Их можно редактировать: удалить ненужные строки и переменные или добавить свой код, например стили CSS и т.п. Можно подготовить несколько папок с разными шаблонами для разных целей.

"Распечатать выбранные файлы по отдельности": Распечатка выбранных картинок (групповая печать). Картинки выбираются щелчком по эскизам при нажатой клавише Ctrl, или командой "Выбрать все" (см. ниже).

"Отправить выбранные файлы по электронной почте": Отправка выбранных картинок по E-Mail (нужен плагин EMail). Картинки выбираются щелчком по эскизам при нажатой клавише Ctrl, или командой "Выбрать все" (см. ниже).

Открыть во внешнем редакторе: Открыть в другой программе просмотра или редактирования изображение, эскиз которого выбран. Для этого нужно предварительно выбрать внешний редактор.

Найти лица: Открыть в окне поиска лиц все выбранные изображения (или всю папку) (нужен плагин FaceDetect).

Меню "Параметры":

"Запомнить текущие размер/компоновку окна" - запомнить размер и положение окна миниатюр. Их можно настроить вручную - мышью.

"Выбрать все" выбрать все эскизы для последующей обработки (см. выше).

"Параметры окна миниатюр" - настройка размера и качества эскизов. Щелчком вызывается окно настроек.

Первый параметр в нем - "Использовать ресэмплирование при создании миниатюр". Поставьте галочку для улучшения качества эскизов. Но из-за этого они будут создаваться дольше. Второй параметр - "Размер миниатюр". Щелкните по стрелке справа в поле размера для выбора размера эскизов. Исходный размер - 100 x 100 пикселов.

Из параметров вида миниатюр можно выбрать цвет фона и рамки для миниатюр и цвет фона окна миниатюр. И можно отключить предупреждение о том, что глубина цвета экрана ниже 24 бит на пиксел (true color).

Можно задать максимальное число папок (недавно использовавшихся) для окна миниатюр. Для очистки их списка нажмите кнопку "Очистить список недавних папок".

Можно отключить или настроить текстовую информацию об эскизе, на который указывает мышь. Подробнее о текстовых шаблонах см. на этой странице.

Галочкой "Показывать общесистемные папки" - можно задать, показывать ли в дереве папок над дисками системные папки пользователя, такие как рабочий стол, "Мои рисунки" и т.п. Изменив эту настройку, обновите окно миниатюр, чтобы увидеть изменения.

"При сортировке по именам учитывать пути (если загружены вложенные папки)" - можно выбрать, по какой части имени сортировать файлы, если показаны эскизы и из подпапок. Либо по полному имени (включая путь), либо по короткому (только имя + расширение). По коротким именам удобно искать одноименные файлы.

Выбрав параметры, нажмите "OK", чтобы запомнить их, или "Отмена" для отмены изменений.

"Сортировка миниатюр" позволяет сортировать файлы (эскизы) в текущей папке.

Примечание: В окне миниатюр есть дополнительные способы сортировки, такие как по дате съемки в EXIF, по высоте или ширине изображения. Эти способы не запоминаются, они действуют только пока открыто окно миниатюр.

Примечание: можно сортировать миниатюры и вручную - перетаскиванием. Можно выбрать одну или несколько миниатюр и переместить их в окне миниатюр в другое место.

"Загрузить список файлов" позволяет показать эскизы по заранее подготовленному списку файлов.

"Загрузить миниатюры из всех вложенных папок" - просмотреть все подпапки текущей папки и показать эскизы и из них.

Меню "Вид":

"Дерево папок" скрывает и показывает дерево папок в левой части окна миниатюр.

"Недавние папки" скрывает и показывает выпадающий список недавно использовавшихся папок в верхней части окна миниатюр (под меню).

"Удалить из списка выбранные миниатюры" удаляет эти эскизы из окна миниатюр (только эскизы, НЕ УДАЛЯЯ файлы).

Обновить перечитывает дерево папок и все картинки в папке, и обновляет все эскизы.

Обновить выбранные миниатюры перечитывает только выбранные файлы и обновляет их эскизы.

Совет: Файлы (эскизы) можно копировать и перемещать в папки в дереве папок мышью. Удерживайте нажатой клавишу Shift чтобы переместить файлы, как в Проводнике Windows.

Совет: При щелчке по папке в дереве с нажатой клавишей Ctrl загружаются миниатюры из выбранной папки и всех её подпапок.

Совет: Можно используя Drag&Drop перетащить выбранные миниатюры (файлы) в другую программу обработки графики (в её открытое окно!), такую как Windows Paint, Photoshop и т.д., при этом выбранные файлы будут открыты в ней.


Экспорт в HTML

Миниатюры - Экспорт в HTML

Подпапка "HTML" папки IrfanView содержит 3 шаблона файлов HTML.

Шаблон 1: thumbnails.html (или thumbnails.htm, thumbnails.php, thumbnails.asp - годится любое из этих расширений)

Шаблон 2: frame.html (или frame.htm, frame.php, frame.asp - годится любое из этих расширений)

Шаблон 3: slideshow.html

Эти шаблоны можно редактировать: удалить ненужные строки и переменные или добавить свой код, например стили CSS и т.п. Можно подготовить несколько папок с разными шаблонами для разных целей.

Каждый шаблон файла содержит несколько переменных - шаблонов данных о рисунке или эскизе. IrfanView заменит каждый из них соответствующей информацией.

Вот пример использования этих шаблонов данных в шаблонах файлов:

Данные о картинке Получится текст

Имя файла - "image1.jpg" (выбранный в окне миниатюр)
Подпапка эскизов - "thumbs" (из окна "Экспорт в HTML")
Префикс - "t" (из окна "Экспорт в HTML")
Подпапка изображений - "images" (из окна "Экспорт в HTML")

Шаблон 1: thumbnails.html (или thumbnails.htm, thumbnails.php, thumbnails.asp)

Допустимые шаблоны данных:

Шаблон Данные о картинке

#TITLE# - заголовок страницы (из окна "Экспорт в HTML")
#BGCOLOR# - цвет фона окна миниатюр (из параметров миниатюр)
%IMAGE_BEGIN% - начало блока данных об одном эскизе (внутренняя переменная), включающего:
#LINK# - если не обзор HTML => "./images/image1.jpg" = полное имя файла, с путем к подпапке изображений из окна HTML

- при обзоре HTML => "image1.html" = путь к файлу HTML с кадром-картинкой

#TARGET# - параметр окна HTML: "Вывод ссылок/изображений" (в том же окне обозревателя или во втором окне)
#THUMB# - "./thumbs/t_image1.jpg" - полное имя эскиза, с путем к подпапке эскизов, префиксом и суффиксом из окна HTML
#TXT_ALIGN# - способ выравнивания теста из окна HTML
#IMAGE_TEXT# - подпись к картинке, задаваемая шаблонами в поле файловой информации окна HTML
%IMAGE_END% - конец блока данных об эскизе (внутренняя переменная)
#IMAGE_NAME# - "image1.jpg", имя файла изображения

Шаблон 2: frame.html (или frame.htm, frame.php, frame.asp)

Допустимые шаблоны данных:

Шаблон Данные о картинке

#TITLE# - заголовок страницы (из окна "Экспорт в HTML")
#BGCOLOR# - цвет фона окна миниатюр (из параметров миниатюр)
#PREV_LINK# - ссылка на файл HTML предыдущей (левой) картинки
#IMAGE_NAME# - "image1.jpg", имя файла изображения
#NEXT_LINK# - ссылка на файл HTML следующей (правой) картинки
#IMAGE# - "./images/image1.jpg" - полное имя файла, с путем к подпапке изображений из окна HTML
#IMAGE_PATH# - только путь к файлу: ./images/
#IMAGE_BASENAME# - только имя файла: image1
#IMAGE_EXT# - только расширение файла: .jpg
#WIDTH# - ширина изображения
#HEIGHT# - высота изображения
#IMAGE_TEXT# - подпись к картинке, задаваемая шаблонами в поле файловой информации окна HTML
#BACK_LINK# - ссылка на первый файл HTML (эскизы)
#SELF_LINK# - ссылка на этот же файл HTML
#TXT_ALIGN# - способ выравнивания теста из окна HTML

Примечание: #IMAGE# означает то же, что "#IMAGE_PATH##IMAGE_BASENAME##IMAGE_EXT#"

Шаблон 3: slideshow.html

Допустимые шаблоны данных:

Шаблон Данные о картинке

#TITLE# - заголовок страницы (из окна "Экспорт в HTML")
#BGCOLOR# - цвет фона окна миниатюр (из параметров миниатюр)
#IMAGES# - массив путей к файлам, к подпапке изображений из окна "Экспорт в HTML"
#TEXT# - массив подписей к картинкам, по умолчанию заполнен именами файлов изображений
#IMAGE1# - "./images/image1.jpg" - путь к первой картинке


Слайдшоу

В меню "Файл" выберите "Слайдшоу". Откроется окно для выбора папки, из которой будут браться файлы. Поля "Папка", "Имя файла" и "Тип файлов" позволяют ограничить выбор.

Выберите файлы для слайдшоу щелчком по их именам. Для выбора большой группы файлов: щелкните по имени первого, удерживая нажатой клавишу Shift, щелкните по имени последнего файла группы. Для выбора отдельных файлов удерживайте нажатой клавишу Ctrl и щелкайте по каждому. Выбрав, нажмите кнопку "Добавить". Для добавления в слайдшоу всех файлов из текущей папки нажмите кнопку "Добавить все". "Убрать" и "Убрать все" убирают выбранные или все файлы из списка слайдшоу.

Нажмите кнопку "Сортировка" для выбора способа сортировки - по имени, дате, размеру или расширению. Для каждого возможна сортировка в прямом и обратном порядке. Для отключения сортировки поставьте переключатель в положение "не сортировать".

Поставьте галочку "Закрыть IrfanView после показа последнего файла", если вы этого хотите.

У слайдшоу есть несколько параметров. Если перед параметром стоит галочка, то он включен. Если не стоит - отключен.

Можно задать "Начинать с №", по умолчанию - с первого. Если включить "Запоминать № последнего файла при выходе", то слайдшоу начнется с того файла, на котором закончилось предыдущее.

Включите "Цикличный показ изображений", чтобы слайдшоу шло бесконечно. Можно "Не сообщать об ошибках при показе". Можно включить "Цикличное воспроизведение файлов MP3". Файлы MP3 можно проигрывать как фоновую музыку (с установленными плагинами), для этого удобно зациклить мелодию MP3 до начала следующей или до конца слайдшоу. Предпоследний параметр - "Прятать курсор мыши" делает курсор "невидимым" на время слайдшоу. Правее есть еще один параметр - "Показывать текст"; включите его, чтобы показывать подписи к картинкам. IrfanView может включить в подпись имя файла, размер, датировку, данные EXIF, IPTC, комментарий и т.п. Подробнее о настройке текстового шаблона см. на этой странице.

Выберите порядок смены слайдов - поставьте переключатель в выбранное положение. Верхний вариант - автоматическая поочередная смена картинок с заданным интервалом времени (большинство клавиш останавливает слайдшоу, например Esc или "Ввод" (Enter) ); интервал вводится в поле справа. Второй вариант - показ очередной картинки по нажатию клавиши на клавиатуре или по движению мыши. Третий вариант - показ случайно выбранных картинок с заданным интервалом времени, нажатие любой клавиши (не имеющей своей функции в слайдшоу, например Esc) останавливает слайдшоу; четвертый - показ случайной картинки по нажатию клавиши или движению мыши. При случайном порядке каждая картинка показывается в слайдшоу только раз, есть список показанных.

Первую картинку можно выбрать, введя ее номер или двойным щелчком по файлу в списке слайдшоу.

Нажмите кнопку "Начать слайдшоу" для запуска слайдшоу.

Совет: Если смена слайдов автоматическая, ее можно остановить клавишей "Pause". Для продолжения нажмите любую другую клавишу.

Слайдшоу можно сохранять на будущее. Когда слайды выбраны, и начинается их показ, IrfanView создает файл с именем:

Slideshow.lst

в своей папке. Он будет загружен снова при следующем открытии окна слайдшоу.

Нажмите кнопку "Загрузить список файлов", и откроется окно, похожее на окно "Открыть" из меню "Файл". Найдите нужный файл и нажмите "Открыть" для его загрузки. Нажмите кнопку "Сохранить список файлов", и откроется окно, похожее на окно "Сохранить как". Присвойте этому списку слайдшоу имя и нажмите "Сохранить" для записи его на диск.

Слайдшоу можно сохранить и как автономное - файл EXE или SCR (самостоятельная программа или экранная заставка), если установлен плагин Slideshow. Для начала создайте и запустите слайдшоу. Затем, если оно работает как задумано, нажмите кнопку "Сохранить слайдшоу как EXE/SCR". Получится самостоятельный легко переносимый файл.

При создании EXE возможны следующие ошибки: невозможно открыть файл или заполнен диск (временная папка).

Примечание: Все аудио и видеофайлы, сохраненные в EXE(SCR), воспроизводятся с помощью DirectX или других установленных драйверов и кодеков, а не плагинов к IrfanView.

Совет: Если слайдшоу не полноэкранное (в окне, и координаты начала не 0,0), то панель задач Windows нельзя скрыть с началом показа.

Если у вас Windows XP (или новее) или Nero Burning ROM (полная версия или демо, но НЕ OEM), можно записать слайдшоу на CD или DVD (CD или DVD с данными) или создать видео-CD (VCD), если установлены плагины Burning или Nero для IrfanView (соответственно).

Слайдшоу можно создать и в текстовом редакторе, а потом показать в IrfanView. Для этого нужен редактор, сохраняющий документы в обычном текстовом формате, например Блокнот Windows. Файл-список слайдшоу должен содержать только имена файлов изображений с полными путями, каждое в отдельной строке. Это должно выглядеть примерно так:

C:\Images\myimage.jpg

Создайте такой список и сохраните его на диске. Запустив IrfanView, откройте окно слайдшоу и кнопкой "Загрузить список файлов" откройте файл-список. Слайдшоу можно запустить и вместе с программой, вызвав ее с соответствующим ключом командной строки.

Закончив, нажмите "Закрыть". Эту кнопку можно нажать и не запуская слайдшоу. Другой способ выхода - нажать кнопку "X" в верхнем правом углу окна.

Как приостановить автоматическую смену слайдов? Просто нажмите клавишу "Pause". Для продолжения слайдшоу нажмите ее еще раз.


Слайдшоу с CD или DVD

Как запустить слайдшоу в IrfanView с CD или DVD?

 В начало Назад Далее

1. Метод: Проще всего, если у вас Windows XP (или новее) или установлена программа Nero Burning ROM:

1.1. Создайте и проверьте (запустите) слайдшоу в окне "Слайдшоу".

1.2. Нажмите в нем кнопку "Записать слайдшоу на CD/DVD". (Примечание: должен быть установлен плагин Burning или Nero для IrfanView.)

1.3. Нажмите "Запустить плагин", рекомендуется (по умолчанию) формат "CD (DVD) с данными".

1.4. Вставьте чистый CD(DVD)-R(-RW) в дисковод и запишите на него.

1.5. Готово.

2. Метод: Вручную или специальное слайдшоу с CD(DVD):

2.1. Скопируйте файлы IrfanView в корневую папку CD(DVD). (можно скопировать туда и INI-файл "i_view32.ini" со своими настройками.)

2.2. Скопируйте на CD(DVD) картинки в папку, например, "images".

2.3. Создайте файл TXT (в окне слайдшоу или в Блокноте) с именами этих файлов. Если, например, их имена "image1.jpg", "image2.jpg" и т.п. то файл TXT должен выглядеть так:

.\images\image1.jpg

.\images\image2.jpg

и т.д.

В каждой его строке - имя файла с относительным путем (относительно IrfanView, i_view32.exe).

Сохраните этот файл TXT, например как "slideshow.txt" в корневой папке CD(DVD).

2.4. Создайте файл "autorun.inf" (в Блокноте). Впишите в него 2 строки:

[AutoRun]

open = i_view32.exe /slideshow=slideshow.txt

Сохраните "autorun.inf" в корневой папке CD(DVD).

2.5. Готово. Запишите этот CD(DVD) своей программой прожига.


Преобразовать/переименовать группу файлов

В меню "Файл" выберите "Преобразовать/переименовать группу файлов". Откроется окно для выбора папки, из которой будут браться файлы. Поля "Папка", "Имя файла" и "Тип файлов" позволяют ограничить выбор.

Выберите папку для результирующих файлов слева в середине окна. Ее можно найти, нажав кнопку "Обзор". Найдя и выбрав папку, нажмите "OK", чтобы она стала папкой для сохранения файлов.

Можно задать для сохранения файлов текущую папку, нажав кнопку "Использовать текущую папку".

Будьте осторожны, если файлы записываются в ту же папку, откуда читаются. Некоторые настройки могут работать неправильно (например, "изменения ко всем страницам"), а в случае ошибки восстановить замененные файлы будет непросто.

Групповое преобразование:

Выберите результирующий формат слева вверху. Он выбирается так же, как в окнах "Сохранить" и "Сохранить как". Кнопка "Параметры" отрывает дополнительное окно для выбора особых параметров сохранения в различных форматах (тоже как в "Сохранить" и "Сохранить как").

Галочка "С дополнительными установками" позволяет применить при преобразовании изображения массу специальных операций, таких же, как в меню "Изображение". Среди них:

обрезка, изменение размера, изменение глубины цвета, автокоррекция цветов, переворот по горизонтали и вертикали, поворот влево и вправо, преобразование в оттенки серого и в негативное, изменение резкости, яркости, контрастности, насыщенности, цветового баланса, гамма-коррекция и др.

Команды будут выполняться в том порядке, в каком они представлены в окне "Параметры для всех изображений" (сначала обрезка, затем изменение размера и т.д.). Изменить порядок операций можно галочкой "Свой порядок обработки".

Совет для обрезки: Ширина и (или) высота могут быть отрицательными числами, это позволяет обрезать от правого (или нижнего) края. Координаты X и (или) Y могут быть отрицательными, если начало отсчета - центр. Пример: если начало отсчета - слева сверху, и задана ширина = -10, то будет обрезано 10 пикселов с правого края картинки. Еще пример: чтобы обрезать по 100 пикселов со всех краёв, задайте: начало отсчета = слева сверху, X = 100, Y = 100, ширина = -100 и Высота = -100.

Совет для изменения размера: Если задать и ширину, и высоту, например = 640 и поставить галочку "Сохранять пропорции", размеры полученной картинки будут: ширина = не более 640, высота = не более 640, с прежними пропорциями.

Галочка "Создавать вложенные папки в папке назначения" создает при записи файлов такую же структуру папок, как та, из которой читались исходные файлы.

Совет: (для опытных) Имя папки назначения может включать шаблоны. Это удобно, например, для сортировки файлов в папки по дате или по другим свойствам файла (изображения) или для сохранения результирующих файлов в новой подпапке исходной папки (например "\уменьшенные\".

Групповое переименование:

Исходные файлы можно переименовать или скопировать (переместить) в папку назначения и переименовать уже в ней. Для новых имен можно задать шаблон имени и номер, с которого начнется нумерация файлов.

Будьте очень осторожны с переименованием, сначала проверьте его работу на пробных файлах! Автоматическое переименование очень могуче и потому опасно! При неверном шаблоне имени в сочетании с "Перемещать/Переименовывать исходные файлы" и (или) "Перезаписывать имеющиеся файлы", при определенных обстоятельствах можно удалить все исходные файлы! Не используйте его, пока не проверите, что оно делает В ДЕЙСТВИТЕЛЬНОСТИ.

Совет: Если нужно, чтобы в новом имени было 3 цифры номера, укажите в шаблоне имени три "#"!
Пример: Шаблон image_### при начале нумерации с 1 образует файлы с именами "image_001", "image_002" и т.д.

Кнопка "Параметры" открывает окно параметров переименования.

Текущие (видимые) значения параметров можно сохранить как профиль, чтобы использовать (загружать) их впоследствии.

Кнопка "Проверить" позволяет увидеть результат переименования файлов, не выполняя его фактически.

Выберите нужные и нажмите "OK" для применения изменений или "Отмена" для их отмены.

Групповое преобразование с переименованием:

Этот вариант - сочетание обычного преобразования группы файлов с их переименованием. Можно задать шаблон имени для записываемых файлов.

Выберите файлы, которые нужно преобразовать, щелчком по их именам. Для выбора большой группы файлов щелкните по имени первого и, удерживая нажатой клавишу Shift, щелкните по имени последнего файла группы. Для выбора отдельных файлов удерживайте нажатой клавишу Ctrl и щелкайте по каждому.

Нажмите кнопку "Добавить" для добавления выбранных файлов в список преобразуемых. Для добавления всех файлов из текущей папки с расширением, выбранным в поле "Тип файлов", нажмите кнопку "Добавить все". "Убрать" и "Убрать все" убирают выбранные или все файлы из списка преобразуемых.

Если стоит галочка "С вложенными папками", то кнопка "Добавить все" добавляет в список все файлы выбранного типа из всех подпапок выбранной папки.

Нажмите кнопку "Загрузить TXT" для загрузки списка изображений из текстового файла. В каждой строке этого файла должно быть указано имя файла изображения с полным путем.

Можно также сохранить текущий список файлов в формате TXT, чтобы затем его использовать, например, в групповых операциях, для переименования, в окне миниатюр и т.д.

Для запуска операций нажмите кнопку "Старт". Появится индикатор хода преобразования. Если нужно его остановить, нажмите кнопку "Стоп". Когда процесс завершится, нажмите "Выход", чтобы закрыть это окно.

Преобразование файлов можно запустить и извне, вызвав IrfanView с соответствующим ключом командной строки.

Для выхода без преобразования файлов нажмите кнопку "Отмена" или кнопку X в верхнем правом углу окна.


Найти файлы

В меню "Файл" выберите "Найти файлы". Откроется окно поиска. В нем можно задать шаблон имени файла, место поиска, дату файла и искомый текст.

Примеры шаблона имени файла:

* - найти все файлы, с любыми расширениями
*.* - то же, что и *
*.jpg - найти только файлы JPG
123*.jpg - найти только JPG с "123" в начале имени
*123.jpg - найти только JPG с "123" в любом месте в имени
image - найти только файлы, в имени которых есть текст "image"

Текст: можно искать текст в данных EXIF (для форматов JPG, TIF, RAW), IPTC и комментариях (для JPG).

Если введено несколько слов (через пробел), в список попадут все файлы, содержащие ЛЮБОЕ из этих слов (например, слово_1 ИЛИ слово_2).

Совет: если нужно найти текст из нескольких слов, введите искомую фразу в кавычках. Например: если ввести текст:

"наша поездка в Лас-Вегас"

(в кавычках), в список попадут только файлы, содержащие всю фразу: наша поездка в Лас-Вегас. Но если ввести это так:

наша поездка в Лас-Вегас

(без кавычек), в список попадут все файлы, содержащие слова "наша" ИЛИ "поездка" ИЛИ "в" ИЛИ "Лас-Вегас" в любом из используемых полей метаданных.

Совет: чтобы просто проверить, есть ли в файле данные EXIF, IPTC и комментарий, введите в поле "Искать текст" символ *.


Переименовать файл

В меню "Файл" выберите "Переименовать файл". Откроется окно для ввода имени файла; введите новое имя и нажмите "OK". Файл будет переименован и в окне просмотра, и на диске. Для выхода без переименования нажмите "Отмена".

Примечание: последнее положение этого окна запоминается.


Переместить файл

В меню "Файл" выберите "Переместить файл". Текущий файл будет перемещен в другую папку (на жестком диске или на другом носителе).

Можно в настройках программы задать папку в которую будут перемещаться файлы по умолчанию и перемещать в нее все файлы, либо можно включить "Перед перемещением показывать диалоговое окно с настройками", чтобы открывалось окно, предлагающее для каждого файла выбрать одну из нескольких папок.

В окне перемещения файлов есть масса способов задания папок назначения.

Совет: можно использовать и относительные пути, чтобы (например) переместить файл в подпапку текущей рабочей (исходной) папки.

Пример: текущий файл "C:\images\image1.jpg". Если задать путь назначения (без кавычек) вида: ".\test" (точка в начале очень важна!), этот файл будет перемещен в "C.\images\test\image1.jpg". Можно задавать и более глубокие пути вида ".\test\big images\" и т.д. - программа автоматически создаст всю цепочку папок целиком.

См. также:

Настройки программы à Операции с файлами


Скопировать файл

В меню "Файл" выберите "Скопировать файл". Текущий файл будет скопирован в другую папку (на жестком диске или другом носителе).

Можно в настройках программы задать папку в которую будут копироваться файлы по умолчанию и копировать в нее все файлы, либо можно включить "Перед копированием показывать диалог с настройками", чтобы появлялось окно, предлагающее для каждого файла выбрать одну из нескольких папок.

В окне копирования файлов есть масса способов задания папок назначения.

Совет: можно использовать и относительные пути, чтобы (например) скопировать файл в подпапку текущей рабочей (исходной) папки.

Пример: текущий файл "C:\images\image1.jpg". Если задать путь назначения (без кавычек) вида: ".\test" (точка в начале очень важна!), этот файл будет скопирован в "C.\images\test\image1.jpg". Можно задавать и более глубокие пути вида ".\test\big images\" и т.д. - программа автоматически создаст всю цепочку папок целиком.

См. также:

Настройки программы à Операции с файлами


Удалить файл

В меню "Файл" выберите "Удалить файл". Текущий файл будет удален с жесткого диска или другого носителя. Постарайтесь не ошибиться, файл удаляется сразу.

Файлы по умолчанию удаляются в Корзину, но это можно изменить в меню "Настройки программы à Операции с файлами".

Если файл удалили по ошибке, просто сохраните текущее изображение.

Есть еще команда "Удалить изображение" в меню "Правка". Она удаляет только изображение с экрана (из памяти), а файл с этим изображением, хранящийся на диске, останется нетронутым.

См. также:

Настройки программы à Операции с файлами


Сохранить (в исходной папке)

В меню "Файл" выберите "Сохранить".

Откроется окно записи файла на диск. С помощью полей "Папка" и "Имя файла" найдите папку, куда нужно сохранить файл.

Окно сохранения открывается только если стоит галочка "Показывать диалоговое окно сохранения для команды 'Файл à Сохранить'" в меню "Настройки программы à Операции с файлами".

Для изменения формата файла в поле "Тип файла" щелкните по стрелочке и выберите формат из выпадающего списка. При сохранении файл будет преобразован в этот новый формат.

Если стоит галочка "Показывать параметры", то автоматически отрывается дополнительное окно для выбора особых параметров сохранения в форматах ECW, GIF, ICO, JP2, JPG, JPM, PBM, PGM, PNG, PPM, RAW и TIFF.

Нажмите "Сохранить" для записи файла на диск или "Отмена" для отмены сохранения.

Заметьте, что команда "Сохранить" предлагает последнюю (текущую) папку, из которой открывали файл. А "Сохранить как" предлагает последнюю папку, в которую сохраняли файл.

См. также:

Сохранить как

Параметры сохранения JPEG/GIF

Параметры сохранения JPEG2000

Параметры сохранения JPM

Параметры сохранения PNG / PBM/PGM/PPM / ICO

Параметры сохранения TIFF


Сохранить как

В меню "Файл" выберите "Сохранить как" (или нажмите на одноименную кнопку панели инструментов).

Откроется окно записи файла на диск. С помощью полей "Папка" и "Имя файла" найдите папку, куда нужно сохранить файл.

Для изменения формата файла в поле "Тип файла" щелкните по стрелочке и выберите формат из выпадающего списка. При сохранении файл будет преобразован в этот новый формат.

Если стоит галочка "Показывать параметры", то автоматически отрывается дополнительное окно для выбора особых параметров сохранения в форматах ECW, GIF, ICO, JP2, JPG, JPM, PBM, PGM, PNG, PPM, RAW и TIFF.

Для ускорения выбора здесь показаны последние папки, в которых сохранялись файлы. Это можно отключить в меню Настройки программы à Разное.

Нажмите "Сохранить" для записи файла на диск или "Отмена" для отмены сохранения.

Заметьте, что команда "Сохранить как" предлагает последнюю папку, в которую сохраняли файл. А "Сохранить" предлагает последнюю (текущую) папку, из которой открывали файл.

См. также:

Сохранить

Параметры сохранения JPEG/GIF

Параметры сохранения JPEG2000

Параметры сохранения JPM

Параметры сохранения PNG / PBM/PGM/PPM / ICO

Параметры сохранения TIFF


Сохранить для Интернета

В меню "Файл" выберите "Сохранить для Интернета".

Это позволит сохранить оптимизированное для Интернета изображение в формате JPG, GIF или PNG с помощью плагина RIOT.

Плагин RIOT имеет некоторые настройки оптимизации, размера файла и т.п.

Текущую версию плагина RIOT можно найти здесь:

http://luci.criosweb.ro/riot/download/


Параметры сохранения JPEG и GIF

JPEG

В верхней половине окна задается уровень качества для формата JPG. Ползунком выберите нужный. Чем ниже уровень, тем меньше будет файл, но тем хуже качество изображения. При высоком уровне лучше качество, но файл больше. Изначально установлен уровень 80, хороший для большинства изображений.

Для сохранения изображения в оттенках серого поставьте соответствующую галочку. Не забудьте, что она включена!

Поставьте галочку "Записывать в прогрессивном формате" для сохранения в этой разновидности формата (для Интернета). Для отключения снимите ее.

Поставьте галочку "Не субсэмплировать цвета" для получения наилучшего качества цвета при сжатии JPG, при этом блоки пикселов будут 1x1, а размер файла JPG увеличится. Обычно размер блока - 2x2 пиксела (с субсэмплированием цветов).

Можно сохранить исходные данные EXIF, IPTC, XMP и комментарий в новый файл JPG.

Сохранение IPTC, XMP и комментария возможно только если исходный файл был в формате JPG, другие форматы (TIF или RAW с данными EXIF и IPTC) пока не поддерживаются.

Сохранение EXIF возможно, если исходный файл был в формате JPG, и из тех файлов RAW и TIF, где данные EXIF были записаны в начале файла.

Поставьте галочку Пытаться сохранить с исходным качеством, чтобы IrfanView попыталась оценить качество и субсэмплирование исходного файла JPG и применила эти значения при его сохранении. Если исходные значения невозможно оценить и восстановить, при сохранении используются настройки качества и субсэмплирования, выбранные в этом окне.

Можно задать примерный размер в байтах получаемого файла JPG, если установлен плагин RIOT. ВАЖНОЕ ПРИМЕЧАНИЕ: файл (картинку) JPG нельзя сделать меньшим, чем при качестве = 1, поскольку есть некоторые ограничения на минимальный размер файла JPG. Если задать размер файла меньшим, чем можно сжать в JPG (при качестве = 1), программа сообщит об ошибке.

GIF

В нижней половине окна - настройки для формата GIF.

Поставьте галочку "Записывать в чересстрочном формате" для сохранения в этой разновидности формата (для Интернета).

Поставьте галочку "Записывать с прозрачным цветом" для создания изображения GIF с прозрачностью.

"Выбрать прозрачный цвет при сохранении": при нажатии на кнопку "Сохранить" открывается окно с эскизом, в котором щелчком по эскизу нужно выбрать прозрачный цвет, это очень просто.

"Сделать прозрачным этот элемент палитры": введите в окошке номер цвета в палитре, который должен быть прозрачным. Подробнее об этом см. "Изменить палитру". Если изображение полноцветное, то чтобы увидеть палитру, нужно сначала уменьшить глубину цвета до 256 цветов.

Если включить "Прозрачный цвет - по цвету главного окна", то в качестве прозрачного автоматически выбирается текущий цвет главного окна ("Настройки программы à Просмотр").

Примечание: IrfanView не сохраняет анимированные GIF.

Текущие (видимые в этом окне) настройки можно сохранить как профиль, а в дальнейшем загружать их и использовать.

Настроив режим сохранения, нажмите "Сохранить", чтобы сохранить изображение и запомнить настройки. Для отмены сохранения файла и настроек нажмите "Отмена".

Новые настройки останутся в силе, пока вы их не измените.

См. также:

Сохранить

Сохранить как


Параметры сохранения JPEG2000

JPEG2000

Переключателем задайте уровень сжатия (compression) для формата JP2 . В вариантах "Качество" и "Сжать до размера" нужно ввести числовое значение. "Сжатие без потерь" позволяет сохранять изображение без потерь информации (то есть с наилучшим качеством).

Примечание: Сохранение в формате JPEG2000 возможно, если установлен плагин JPEG2000.

Настроив режим сохранения, нажмите "Сохранить", чтобы сохранить изображение и запомнить настройки. Для отмены сохранения файла и настроек нажмите "Отмена".

Новые настройки останутся в силе, пока вы их не измените.

См. также:

Сохранить

Сохранить как


Параметры сохранения JPM

JPM

Выберите профиль сохранения. Есть 5 стандартных профилей для разных типов изображений. Можно задать и качество получаемой картинки.

Чтобы встроить в файл JPM эскиз (для быстрого просмотра), поставьте галочку "Сохранять миниатюру".

Для создания многостраничного изображения JPM в меню "Сервис" выберите "Многостраничные изображения à Создать многостраничный файл JPM".

Примечание: Сохранение в формате JPM возможно, если установлен плагин JPM.

Настроив режим сохранения, нажмите "Сохранить", чтобы сохранить изображение и запомнить настройки. Для отмены сохранения файла и настроек нажмите "Отмена".

Новые настройки останутся в силе, пока вы их не измените.

См. также:

Сохранить

Сохранить как


Параметры сохранения PNG, PBM/PGM/PPM и ICO

PNG

Задайте уровень сжатия и прозрачный цвет (как в GIF и ICO) для формата PNG. Примечание: PNG - формат со сжатием без потерь (как GIF) и поддержкой полного цвета (true color). Этот формат как правило идеален для снимков экрана, потому что размер файла часто получается даже меньше, чем JPG, качество изображения не теряется и он читается многими программами.

"Сохранять прозрачный цвет": при нажатии на кнопку "Сохранить" открывается окно с эскизом, в котором щелчком по эскизу нужно выбрать прозрачный цвет.

Если включить "Делать прозрачным цвет окна", то в качестве прозрачного автоматически выбирается текущий цвет главного окна ("Настройки программы à Просмотр").

Для оптимизации сохранения PNG можно использовать плагин PNGOUT. Он позволяет уменьшить размер полученного файла.

PBM, PGM, PPM

Переключателем задайте тип кодирования для формата PBM/PGM/PPM. При кодировании ASCII получаются очень большие файлы.

ICO

Изображения ICO можно сохранять с прозрачным цветом, выбираемым при сохранении щелчком по эскизу.

Если включить "Делать прозрачным цвет окна", то в качестве прозрачного автоматически выбирается текущий цвет главного окна ("Настройки программы à Просмотр").

Настроив режим сохранения, нажмите "Сохранить", чтобы сохранить изображение и запомнить настройки. Для отмены сохранения файла и настроек нажмите "Отмена".

Новые настройки останутся в силе, пока вы их не измените.

См. также:

Сохранить

Сохранить как


Параметры сохранения TIFF

TIFF

Переключателем выберите тип сжатия TIFF. Левый переключатель - для цветных картинок, правый - для черно-белых.

"Сохранять палитру у изображений в оттенках серого": у некоторых графических редакторов есть "проблемы" с такими TIF, содержащими палитру. На этот случай можно не сохранять палитру.

Если открыто многостраничное изображение, можно сохранить все её страницы в одном TIF, поставив галочку "Сохранять все страницы из исходного изображения".

Настроив режим сохранения, нажмите "Сохранить", чтобы сохранить изображение и запомнить настройки. Для отмены сохранения файла и настроек нажмите "Отмена".

Новые настройки останутся в силе, пока вы их не измените.

См. также:

Сохранить

Сохранить как


Печать

В меню "Файл" выберите "Печать".

Появится окно параметров печати изображения.

В его левой части можно выбрать принтер и ориентацию распечатки на листе.

Предварительный просмотр показывает, как она будет выглядеть при книжной и альбомной ориентации.

Кнопкой "Настройка печати" можно изменить формат листа и другие настройки принтера.

Переключателями выберите, как распечатать изображение.

"Исходный размер" распечатывает изображение в его исходных размерах, определенных по разрешению (DPI). Для изображений без данных о разрешении принимается DPI = 72.

Примечание: Если размер изображения больше размера листа, будет напечатана лишь его видимая часть.

"Заполнить страницу" максимально заполняет лист бумаги изображением, не изменяя его пропорций.

Примечание: ИСПОЛЬЗУЕТСЯ "Сохранять пропорции".

"Растянуть до размера страницы" заполняет изображением всю область печати, даже если при этом пропорции не сохранятся.

Примечание: НЕ используется "Сохранять пропорции".

"Указанный размер" позволяет распечатать изображение в указанном размере. Введите ширину, высоту и размер полей сверху и слева в сантиметрах или дюймах.

Примечание: Размер изображения ограничен размерами листа бумаги; пропорции сохраняются, если стоит соответствующая галочка. Ширина и высота не пересчитываются при смене картинки, перещелкните галочку "Сохранять пропорции" или щелкните по размеру, который нужно исправить.

"Масштабировать" пропорционально изменяет размер изображения на листе. Введите нужный масштаб; 1.00 - это исходный размер.

Примечание: Размер изображения ограничен размерами листа бумаги.

Поставьте галочку "По центру" чтобы изображение печаталось в центре листа.

Можно распечатать имя файла, путь к нему или любой текст в верхнем и (или) нижнем колонтитуле.

В параметре "Страницы:" номера страниц следует указывать через точку с запятой.

Можно задать и Число копий (сколько экземпляров распечатать).

Можно Разобрать по копиям (то есть рассортировать) распечатываемые в нескольких экземплярах многостраничные изображения.

Примечание: На предварительном просмотре не видны поля на листе (зависят от принтера). Если выбран (выделен) фрагмент исходного изображения, распечатывается только выделение.

Выбрав параметры, нажмите "Печать".

Нажмите "Отмена" для выхода из окна "Параметры печати", не печатая картинку.


Выбрать сканер

В меню "Файл" выберите "Выбрать сканер/TWAIN-источник".

Здесь можно выбрать сканер или другое TWAIN-совместимое устройство (цифровую камеру, телевизионный приемник и т.п.), из установленных на компьютере (если их несколько).

Примечание: этим окном управляет Windows, а не IrfanView.

Выберите нужное устройство и нажмите кнопку "Выбрать". Для выхода без выбора устройства нажмите "Отмена".

См. также:

Получить/отсканировать серию изображений

Отсканировать и распечатать


Получить/отсканировать серию изображений

В меню "Файл" выберите "Получить/отсканировать серию изображений".

· Если нужно отсканировать только одно изображение, выберите первый вариант.

Запустится программа, управляющая вашим сканером или другим TWAIN-совместимым устройством (цифровой камерой, телевизионным приемником и т.п.). Отсканируйте изображение как указано в руководстве вашего сканера.

Отсканированное изображение появится в IrfanView.

· Для сканирования серии изображений выберите второй вариант.

Для него можно задать:

• имя результирующего файла
• номер первого записываемого файла
• приращение счетчика изображений (может быть и отрицательным)
• число цифр в номере файла
• возможность пропускать существующие одноименные файлы (не заменять)
• запоминать ли значение счетчика (для следующего сеанса)
• папку, в которую будут записываться отсканированные изображения
• формат сохранения изображений

Совет: для задания имён результирующих файлов можно использовать некоторые шаблоны. Допустимы шаблоны имён файлов: $W, $H, $B, $p and $U.

Пример: задав имя файла в виде: $U(%d_%m_%Y)-

получим файлы с именами: 25_07_2013-01, 25_07_2013-02 и т.д.

Если для сохранения используется формат TIF, можно создать одно многостраничное изображение из нескольких отсканированных (по результатам сохраняется только один файл, без номера).

Запустится программа, управляющая вашим сканером или другим TWAIN-совместимым устройством (цифровой камерой, телевизионным приемником и т.п.). Отсканируйте изображения как указано в руководстве вашего сканера. IrfanView не будет закрывать окно предварительного просмотра TWAIN.

Файлы с полученными изображениями будут сохранены в папке назначения под именами "ScanImage001.bmp", "ScanImage002.bmp" и т.д. (при исходных настройках).

Последнее отсканированное изображение появится в IrfanView.

См. также:

Выбрать сканер/TWAIN-источник

Отсканировать и распечатать


Отсканировать и распечатать

В меню "Файл" выберите "Отсканировать и распечатать".

Откроется окно для печати изображения прямо со сканера или другого TWAIN-совместимого устройства (цифровой камеры, телевизионного приемника и т.п.).

Кнопка "Выбрать TWAIN-источник" позволяет выбрать TWAIN-совместимое устройство (как правило, сканер) из списка.

Поставьте галочку "Показывать диалоговое окно предпросмотра TWAIN" для просмотра отсканированного изображения перед печатью.

Введите значение разрешения (DPI) сканирования; изначально = 100. Как правило, хорошо подходит разрешение вдвое меньше выбранного для печати.

Выберите принтер и настройте его.

Введите число экземпляров (распечатываемых).

Примечание: настройки печати берутся из окна "Печать".

Настроив всё, нажмите "СТАРТ". Для отмены копирования нажмите "Отмена".

См. также:

Печать

Выбрать сканер/TWAIN-источник

Получить/отсканировать серию изображений


Выход

Есть несколько способов выйти из программы:

Нажмите клавишу Esc. Программа сразу закроется. (Если открыто любое меню или диалоговое окно, Esc закроет его. Для выхода из программы нажмите Esc еще раз.)

Для выхода из IrfanView можно в меню "Файл" нажать клавишу "X" (при русском интерфейсе - "ы"). Или мышью щелкнуть по команде "Выход".

Можно щелкнуть по логотипу в левом верхнем углу окна программы для вызова стандартного меню Windows и выбрать команду "Закрыть" или двойным щелчком по логотипу сразу закрыть IrfanView.

Можно щелкнуть по кнопке X в правом верхнем углу окна программы. Это тоже сразу закроет программу.

Примечание: IrfanView не задает глупый вопрос "Не хотите ли сохранить ля-ля-ля?" - она закрывается сразу (по умолчанию). Заранее сохраните все, что хотите сохранить, или включите "Выдавать запрос на сохранение изменений при выходе..." в "Настройки программы à Запуск и выход".


Отменить - Повторить

В меню "Правка" выберите "Отменить" (или нажмите на одноименную кнопку панели инструментов).

Восстановится предыдущее состояние изображения. Отменить можно многие команды IrfanView. Но отменяется только последнее действие; программа их не запоминает. Эту команду можно отключить в закладке "Обзор и редактирование" окна "Сервис à Настройки программы".

Команда "Повторить" возвращает то, что было до отмены.

Отменить можно:

автокоррекцию цветов, поворот на произвольный угол, преобразование в оттенки серого, обрезку, вырезание, уменьшение глубины цвета, коррекцию цветов, увеличение глубины цвета, преобразование в негатив, изменение размера изображения, рисование и все эффекты.


Панель рисования

Открыть панель рисования (плагин IrfanPaint)

 В начало Назад Далее

В меню "Правка" выберите "Открыть панель рисования".

Обзор

IrfanPaint - это плагин рисования для IrfanView, написанный Matteo Italia в сотрудничестве с Irfan Skiljan. Он позволяет выполнять основные задачи фоторедактирования, не пользуясь внешним редактором.

Пользуйтесь последней версией IrfanPaint: ее можно скачать с сайта IrfanPaint.

Подсказки и хитрости

· Включив контекстные подсказки( [image]), наведите мышь на инструмент - появится подсказка к нему. Размер шрифта подсказки можно настроить в "Windows à Рабочий стол à Оформление".
· Панель рисования магнитная. Перетащите ее к любому боку окна IrfanView, и она к нему прилипнет. Теперь она будет двигаться вместе с окном.
· Можно переключать инструменты, прокручивая ролик мыши при нажатых Ctrl и Shift.
· Можно изменять толщину кисти, прокручивая ролик мыши при нажатом Shift.
· Можно использовать пункт меню (кнопку) "Отменить" главного окна IrfanView (отменяет последнюю операцию панели рисования)

Инструменты

Обзор

Выделение: ограничивает действие инструментов выделенным фрагментом

Кисть: левая/правая кнопка мыши = рисование основным/дополнительным цветом

Ластик: левая/правая кнопка мыши = стирание до фона/до исходного изображения

Штамп: копирует выбранный фрагмент в указанное место

Замена цвета: меняет основной и дополнительный цвета

Текст: вставка форматированного текста

Линия: прямая линия; Shift/Control - поворот

Стрелка прямая со стрелкой; щелчок правой кнопкой мыши прерывает рисование

Эллипс: Shift = круг; Ctrl = центр

Прямоугольник: Shift = квадрат; Ctrl = центр

Ведро: левая/правая кнопка мыши = заливка основным/дополнительным цветом

Пипетка: выбор основного/дополнительного цвета

Поворот: поворот изображения на произвольный угол

Измеритель: измерение расстояний и углов наклона линий

Настройка кисти: стили линий и заливки

Подсказки: краткие/подробные контекстные подсказки

О плагине: номер версии и благодарности

Толщина: размер кисти настраивается роликом мыши

Допуск: настраивается роликом мыши

Заливка: эллипсов и прямоугольников

Дополнительный цвет: изменяется щелчком мыши

Основной цвет: изменяется щелчком мыши

Подробная справка

Название

Значок

Описание

Выделение

Делает активным окно IrfanView для выделения, обрезки и т.п. Инструменты IrfanPaint, например, кисть или ведро не будут действовать вне выделенного фрагмента.

Кисть

Левая кнопка мыши рисует основным цветом, а правая - дополнительным. Для изменения толщины кисти покрутите ролик мыши, удерживая нажатой клавишу Shift, или измените ее в поле "Толщина" панели рисования.

Ластик

Проведите мышью с нажатой левой кнопкой для стирания (замены) участка изображения дополнительным цветом. Проведите мышью с нажатой правой кнопкой для стирания (отмены) нарисованного до этого - возврата исходного изображения. Для изменения толщины ластика покрутите ролик мыши, удерживая нажатой клавишу Shift.

Штамп

Щелчком правой кнопки мыши задайте "донорскую" область; проведите мышью с нажатой левой кнопкой для копирования (повторения) ее в новом месте. Для изменения толщины штмапа покрутите ролик мыши, удерживая нажатой клавишу Shift.

Замена цвета

Этот инструмент заменяет один цвет другим. Проведите мышью с нажатой левой кнопкой для замены дополнительного цвета основным. Проведите мышью с нажатой правой кнопкой для замены основного цвета дополнительным. Для изменения толщины заменителя цвета покрутите ролик мыши, удерживая нажатой клавишу Shift, или измените ее в поле "Допуск" панели рисования.

Текст

Этот инструмент вставляет отформатированный текст в изображение. Перекрестие курсора будет точкой отсчета для вставки текста. Текст может быть выровнен влево, вправо или по центру относительно этой точки.

При щелчке в выбранном месте изображения откроется окно "Вставить текст". В нем можно выбрать текст, отформатировать его - выбрать шрифт, размер, цвет и начертание, а также способ выравнивания.

Текст в юникоде можно вставить из буфера обмена или набрать с помощью настроенной клавиатуры Windows.

Текст можно нарисовать кистью, кистью с заполнением, как обычный или сглаженный текст. Для текста кистью значок цвета текста заменяется значком настройки кисти, позволяющим выбрать линию и заполнение текста.

Текст из поля ввода можно скопировать в буфер обмена (на будущее), при этом все форматирование сохранится.

Кнопка "Нажмите для просмотра" поможет увидеть, как будет выглядеть отформатированный и настроенный текст на изображении, прежде чем он будет вставлен кнопкой "OK".

Линия

Проведите мышью с нажатой левой кнопкой для рисования прямой линии основным цветом. Щелкните при проводке правой кнопкой мыши для отмены линии. Удерживайте нажатой клавишу Shift для рисования линий под углами, кратными 45°. Удерживайте нажатой клавишу Ctrl, чтобы начальная точка стала центром линии. Для изменения толщины линии покрутите ролик мыши, удерживая нажатой клавишу Shift. Стиль и концы линии настраиваются в настройках кисти.

Стрелка

Работает так же, как линия. Для настройки стиля стрелок щелкните правой кнопкой мыши по кнопке стрелки.

Эллипс/круг

Проведите мышью с нажатой левой кнопкой для рисования эллипса. Удерживайте нажатой клавишу Shift для рисования круга. Удерживайте нажатой клавишу Ctrl, чтобы начальная точка стала центром фигуры. Щелкните при проводке правой кнопкой мыши для отмены фигуры.

Прямоугольник/квадрат

Проведите мышью с нажатой левой кнопкой для рисования прямоугольника. Удерживайте нажатой клавишу Shift для рисования квадрата. Удерживайте нажатой клавишу Ctrl, чтобы начальная точка стала центром фигуры. Щелкните при проводке правой кнопкой мыши для отмены фигуры.

Ведро

Щелкните левой кнопкой мыши для заливки области основным цветом. Щелкните правой кнопкой мыши для заливки области дополнительным цветом. Если нужно, сначала выделите область заливки. В поле "Допуск" панели рисования задается допуск заливки (рекомендуется: 40).

Пипетка

Щелкните левой кнопкой мыши для выбора основного цвета. Щелкните правой кнопкой мыши для выбора дополнительного цвета. После "набора" цвета автоматически возвращается предыдущий инструмент, если выбирая пипетку не удерживать нажатой клавишу Shift.

Выравнивание/поворот изображения

Проведите мышью с нажатой левой кнопкой вдоль прямой линии или между двумя точками, которые после выравнивания должны быть на одной горизонтали или вертикали. При повороте образуются поля, которые будут иметь текущий дополнительный цвет. Цвет фона, выбранный в IrfanView для поворота на произвольный угол, к этому инструменту не относится. Здесь используется дополнительный цвет IrfanPaint.

Измеритель расстояний и углов

Проведите мышью с нажатой левой кнопкой в нужную точку и отпустите кнопку. Углы отсчитываются от горизонтали. Щелкните при проводке правой кнопкой мыши для отмены измерения. Удерживайте нажатой клавишу Ctrl, чтобы начальная точка стала центром измерителя. Удерживайте нажатой клавишу Shift для измерения под углами, кратными 45°. Для настройки единиц измерения щёлкните правой кнопкой мыши по кнопке измерителя.

Настройки ручки и кисти

Открывает окно настроек кисти, в котором задаются стили линий и заполнения и концы линий. Результаты зависят от толщины линий. Эти настройки относятся к кисти, линиям, стрелкам, эллипсам и прямоугольникам.

Здесь задается цвет линий, толщина пера и стили линии, конца линии, соединения линий (угла) и штриховки.

Закладка дополнительного цвета позволяет задать цвет и стиль штриховки для заполнения. Дополнительный цвет штриховки может быть прозрачным для создания эффекта выделения при рисовании по тексту дополнительным цветом (правой кнопкой мыши по кисти).

Чтобы это выглядело как будто без ручки, выберите для линии те же цвет и штриховку, что и для заполнения.

В тексте кистью тоже используются настройки кисти. Если текст очень большой, скорее всего придется выбрать толщину линии всего 1 или 2 пиксела.

Поле просмотра показывает (примерно) каким будет результат. Щелчком по нему обмениватся цвета и стили основного и дополнительного цветов.

Справка (всплывающие подсказки)

Выбор между краткими подсказками и развернутой контекстной справкой по инструменту панели рисования, на который указывает мышь.

Об IrfanPaint

Номер версии плагина IrfanPaint, информация о переводе, благодарности и ссылка на сайт IrfanPaint, с которого можно скачать актуальную версию IrfanPaint.

Толщина линии

Вводится толщина линии в пикселах, ее можно изменить стрелками в поле ввода, или клавишами-стрелками "вверх-вниз". Толщину линии можно изменить и во время рисования, покрутив ролик мыши, удерживая нажатой клавишу Shift.

Допуск

Чем больше значение допуска, тем больший диапазон цветов заменяется при замене цвета и заливке. При уменьшении его до нуля заменяются только пикселы выбранного цвета; при увеличении до 255 заменяются все цвета.

Заливка

Используется в стрелках, эллипсах и прямоугольниках. Если галочка стоит, то фигура будет сплошной (залитой), если нет - пустотелой (незалитой).

Панель цвета

Щелкните по переднему прямоугольнику для выбора основного цвета.

Щелкните по заднему прямоугольнику для выбора дополнительного цвета.

Щелкните по стрелочке, чтобы поменять эти цвета местами.

Благодарности

Исходный текст этой страницы справки написал Bhikkhu Pesala; затем его адаптировал и добавил рисунки Matteo Italia.


Создать пользовательское выделение

В меню "Правка" выберите "Создать пользовательское выделение". Откроется окно создания выделенной области (выбора прямоугольника) на текущем изображении.

Можно задать положение, размер и отношение ширины выделения к высоте.

Если на изображении уже выделен фрагмент, в полях этого окна будут его параметры.

Выделение можно создать и мышью. Поместите мышь в угол фрагмента, который нужно выделить. Удерживайте нажатой ее левую кнопку - курсор примет вид двойного креста. Проведите мышью по диагонали до его противоположного угла. Появится граница выделения. Закончив, отпустите кнопку.

Чтобы снять выделение, щелкните мышью вне выделенного фрагмента (где курсор обычной формы).

Если нажать левую кнопку мыши внутри выделения (где курсор в форме лупы), масштаб выделения увеличится.

Для изменения размера выделения поместите мышь на границу, которую нужно сдвинуть. Курсор станет двухсторонней стрелкой. Удерживая нажатой левую кнопку мыши, сдвиньте границу. Для пропорционального изменения размеров выделения удерживайте нажатой клавишу Ctrl.

Если назначение кнопок мыши поменяно, это делается правой кнопкой.

Для перемещения выделения удерживайте нажатой правую кнопку мыши внутри него. Курсор станет четырехсторонней стрелкой. Сдвиньте мышью выделение в нужное место и отпустите кнопку мыши.

Координаты левого верхнего угла выделения, его размеры в пикселах и соотношение сторон отображаются в заголовке окна.

См. также:

Вырезать

Обрезать

Скопировать

Вставить

Добавить текст

Убрать красные глаза


Создать максимизированное выделение

Эта команда позволяет выделить на рисунке максимально возможную область выбранного формата (из числа наиболее популярных).

Создать максимизированное пользовательское выделение

Эта команда выделяет на рисунке максимально возможную область того же формата, который имело последнее пользовательское выделение.


Максимизировать и центрировать выделение

Если выделена прямоугольная область, можно в меню "Правка" выбрать "Максимизировать и центрировать выделение".

При этом выделение будет пропорционально увеличено до максимального размера и помещено в центре картинки.

Совет: если при выборе этой команды нажать и удерживать клавишу CTRL, выделение центрируется без изменения его размера.


Сетка на выделении

Эта команда показывает на выделенном прямоугольнике специальную сетку: золотого сечения или правила третей.

Цвет сетки (выделения) и размер ячейки сетки можно задать в меню "Настройки программы à Обзор и редактирование".

Переместить выделение можно клавишами-стрелками или правой кнопкой мыши (см. страницу "клавиатурные команды").


Фиксированная сетка

Эта команда показывает на изборажении сетку (растр).

Цвет сетки (выделения) и размер ячейки сетки можно задать в меню "Настройки программы à Обзор и редактирование".


Добавить текст

Можно начать с этой команды, а затем указать место текста щелчком мыши по изображению (в главном окне); либо можно сначала левой кнопкой мыши выбрать (выделить) участок изображения, куда будет нанесен текст, а затем в меню "Правка" выбрать "Добавить текст".

Как создать выделение? Просто нажмите левую кнопку мыши и проведите мышью. Появится выделенный прямоугольник. Если щелкнуть на изображении вне выделения, то выделение исчезнет.

Если это делается в групповых операциях с дополнительными установками ("Добавить текст"), откроются поля для ввода координат, и можно будет задать начальную точку и размеры прямоугольника, в который будет вставлен текст.

В поле "Текст" введите наносимый текст.

Кнопкой "Выбрать шрифт" выберите для текста шрифт, размер, цвет и т.п. Выбранный для текста шрифт показан ниже поля ввода текста.

Если изображение уменьшено (масштаб < 100%), IrfanView может пересчитать размер шрифта по текущему масштабу, чтобы текст "правильно" выглядел в текущем масштабе. Например: если картинка уменьшена до 66%, и выбран шрифт размером 12 пунктов, то реальный размер шрифта составит 18 пунктов (=шрифт x 100/масштаб), что в текущем масштабе будет выглядеть как 12 пунктов.

Снимите галочку "Прозрачный фон" для выбора фона. В этом случае выбранный для текста участок будет залит цветом фона. Выбранный цвет фона показан в поле слева от кнопки выбора.

Можно выбрать разные цвета и эффекты, не стесняйтесь комбинировать.

Текущие (видимые в этом окне) настройки можно сохранить как профиль, а в дальнейшем загружать их и использовать.

Нажмите "OK", чтобы нанести текст на изображение, или "Отмена" для отмены нанесения текста.

Нанесение текста можно отменить командой "Отменить" из меню "Правка".

Совет: С помощью SHIFT + щелчок по изображению (в главном окне) можно сделать указанный на изображении цвет цветом текста.

См. также:

Создать пользовательское выделение

Настройка шаблона текста


Добавить водяной знак

В меню "Правка" выберите "Добавить водяной знак". Откроется диалоговое окно нанесения водяного знака на текущее изображение.

Это можно сделать и в групповых операциях с дополнительными установками ("Добавить водяной знак")

Можно выбрать, какой файл изображения наложить, и задать степень его прозрачности, чтобы он выглядел как водяной знак (0 - непрозрачный, 100 - полностью прозрачный).

Можно выбрать на изображении точку начала отсчета (угол) и задать горизонтальное и вертикальное смещение водяного знака от него в пикселах (X и Y), или поместить водяной знак в центре изображения.

Можно указать точку начала отсчета щелчком мыши по изображению (в главном окне), при этом программа покажет предварительный результат наложения.

Или можно заранее выделить фрагмент изображения мышью. В этом случае в качестве начального угла будет выбран соответствующий угол выделения, и автоматически будет рассчитано нужное смещение водяного знака.

Примечание: можно использовать в качестве водяного знака изображения с прозрачностью (например, в формате PNG или GIF). При наложении такой картинки её прозрачные участки будут полностью прозрачны, а степень прозрачности остальных задается в настройках водяного знака.

Нажмите "OK" чтобы нанести водяной знак на изображение или "Отмена" для отмены нанесения водяного знака.

Добавление водяного знака можно отменить командой "Отменить" из меню "Правка".


Вырезать

Левой кнопкой мыши выделите участок изображения, в меню "Правка" выберите "Вырезать" (или нажмите на одноименную кнопку панели инструментов).

Вырезать участок внутри выделения

Выделенный фрагмент будет удален из изображения. Эта область обычно заполняется черным цветом. Вырезанный фрагмент помещается в буфер обмена Windows как растровое изображение и его можно будет вставить куда угодно.

Вырезать участок вокруг выделения

Область вне выделения будет удалена из изображения и заменена заданным цветом фона при вырезании.

Примечание: Цвет фона при вырезании задается в меню "Настройки программы à Обзор и редактирование".

Это действие можно отменить командой "Отменить" из меню "Правка".

См. также:

Обрезать

Скопировать

Вставить

Создать пользовательское выделение


Обрезать

Левой кнопкой мыши выберите (выделите) участок изображения, в меню "Правка" выберите "Обрезать выделение".

Обрезать выделение

Область вне выделения будет отброшена, останется только выделенный фрагмент. Изменится размер изображения.

Полезно для обрезки ненужных краев (как правило чистых полей) изображения и для центровки фотографий с плохой композицией.

Автообрезка границ

Будут обрезаны поля (одноцветные края) изображения.

Для расширения полей можно задать цветовой допуск для автообрезки границ в меню "Настройки программы à Обзор и редактирование".

Обрезать по видимой границе окна

Останется только та часть картинки, которая сейчас видна на экране.

Это действие можно отменить командой "Отменить" из меню "Правка".

Совет: для рисунков JPG предпочтительна обрезка без потерь через меню "Сервис à Обрезка JPG без потерь".

См. также:

Вырезать

Скопировать

Вставить

Создать пользовательское выделение


Скопировать

Левой кнопкой мыши выделите участок изображения, в меню "Правка" выберите "Скопировать" (или одноименную кнопку на панели инструментов).

Выделенный фрагмент помещается в буфер обмена Windows как растровое изображение, и его можно вставить куда угодно.

Если выделения нет, то в буфер обмена Windows копируется всё изображение целиком.

См. также:

Вырезать

Обрезать

Вставить

Создать пользовательское выделение


Вставить

Вставить, Вставить рядом

Вставка

В меню "Правка" выберите "Вставить" (или нажмите на одноименную кнопку панели инструментов).

Если выбран (выделен) фрагмент изображения, то находящийся в буфере обмена Windows растровый рисунок, метафайл или текст будет вставлен в выделение. Содержимое буфера обмена подгоняется под размер выделения, а оставшаяся часть изображения остается неизменной. Это очень удобно для редактирования изображений или их фрагментов.

Вставка в выделение настраивается в меню "Настройки программы à Обзор и редактирование".

Если выделения нет, содержимое (рисунок, метафайл или текст) буфера обмена Windows заменит всю картинку целиком.

Вставка рядом

В меню "Правка" выберите "Вставить рядом".

Эта команда добавит рисунок из буфера обмена к существующему изображению с той стороны, которая выбрана в подменю.

Подгонка вставляемого рисунка настраивается в меню "Настройки программы à Обзор и редактирование".

См. также:

Вырезать

Обрезать

Скопировать

Создать пользовательское выделение


Удалить изображение

В меню "Правка" выберите "Удалить изображение (очистить экран)".

Изображение будет удалено с экрана. Файл с этим изображением, хранящийся на диске, останется нетронутым.

Есть еще команда "Удалить файл" в меню "Файл", которая удаляет файл с изображением с диска.


Очистить буфер обмена

В меню "Правка" выберите "Очистить буфер обмена".

Будет удалено содержимое буфера обмена Windows.


Свойства изображения

В меню "Изображение" выберите "Свойства изображения" (или нажмите на одноименную кнопку панели инструментов). Откроется окно со следующими сведениями об изображении:

Имя файла

Размещение

Полный путь

Метод сжатия

Разрешение - можно изменить значения DPI и установить их кнопкой "Установить".

Исходный размер (ширина и высота в пикселах)

Текущий размер (ширина и высота в пикселах)

Размер отпечатка (в см или дюймах, определенная по DPI изображения)

Исходные цвета (глубина цвета, бит на пиксел)

Текущие цвета (глубина цвета, бит на пиксел)

Число уникальных цветов в изображении

Объем файла на диске (в KБ)

Объем изображения в памяти (в KБ, распакованного)

Текущий номер в папке

Дата и время файла

Время загрузки файла

Если открыт файл JPG, TIF или RAW с данными EXIF о фотографии, то видна кнопка "Информация EXIF" в левом нижнем углу окна, и можно просмотреть в IrfanView информацию EXIF.

Щелкнув мышью по полю "Filename", можно клавишами-стрелками прокручивать эту информацию. В ней можно найти дату и время, размер изображения, диафрагму, фокусное расстояние, режим качества, выдержку, использовалась ли вспышка, чувствительность ISO матрицы CCD, изготовителя и модель фотокамеры. Список тегов EXIF см. на этой странице. Эта информация - в текстовом формате (.txt). Ее можно выделить и скопировать в буфер обмена, а затем вставить в текстовый редактор и распечатать или сохранить на будущее в одной папке с фотографиями.

Примечание: Работа с EXIF возможна, если установлен плагин Metadata!

Если открыт файл JPG, то видна кнопка "Информация IPTC", и можно просмотреть, изменить и сохранить в IrfanView информацию IPTC. Редактирование IPTC - это операция без потерь информации, изображение при этом не изменяется. Данные IPTC из файлов TIF и RAW тоже можно просмотреть, но пока нельзя редактировать.

Примечание: Работа с IPTC возможна, если установлен плагин Metadata!

Если открыт файл JPG, то видна кнопка "Комментарий", и можно просмотреть, изменить и сохранить в IrfanView комментарий JPG. Редактирование комментария - это операция без потерь информации, изображение при этом не изменяется.

Примечание: Работа с комментарием JPG возможна, если установлен плагин Metadata!

Примечание: Если в открытом файле JPG есть данные EXIF, IPTC или комментарий, то в конце названия соответствующей кнопки стоит звездочка ( * ).

Прочитав информацию, нажмите "OK" .


Создать новое (пустое) изображение

В меню "Изображение" выберите "Создать новое (пустое) изображение". Откроется окно для создания нового (пустого) изображения.

В нем можно задать ширину и высоту изображения, выбрать число цветов (бит на пиксел) или оттенки серого и цвет фона (изначально - черный).


Создать панорамное изображение

В меню "Изображение" выберите "Создать панорамное изображение". Откроется окно для сборки панорамы.

Исходные картинки можно добавлять по вертикали или по горизонтали. Первая картинка в цепочке используется как основа для следующих.

Можно вставить в панораму имена файлов (в левый верхний угол исходных картинок) и добавить промежутки между картинками. 0 пикселов означает без промежутков (исходный режим).

Примечание: Чтобы собрать панораму в несколько рядов (или столбцов), воспользуйтесь командой "Создать контрольный лист" в окне миниатюр.


Повернуть

Повернуть влево / вправо / на произвольный угол

Повернуть на 90° влево

В меню "Изображение" выберите "Повернуть на 90° влево". Изображение повернется на 90 градусов против часовой стрелки.

Повернуть на 90° вправо

В меню "Изображение" выберите "Повернуть на 90° вправо". Изображение повернется на 90 градусов по часовой стрелке.

Совет: для изображений в формате JPG лучше использовать преобразование без потерь информации в меню "Сервис à Поворот/преобразование JPG без потерь".

Повернуть на произвольный угол

Откроется окно для ввода угла поворота изображения (в диапазоне от -360 до +360).

Введя число, увидите эскиз повернутого изображения; положительные числа (например, 30) означают поворот по часовой стрелке, отрицательные (например, -30) поворот против часовой стрелки; чем больше число, тем больше угол поворота; изначально = 45. Можно выбрать и цвет фона, который появится при повороте.

Примечание: Поворот на произвольный угол реализован в плагине Effects, который устанавливается вместе с программой.

См. также:

Перевернуть


Перевернуть

В меню "Изображение" выберите "Перевернуть вертикально". Изображение перевернется вверх ногами. Левая и правая стороны не меняются местами.

В меню "Изображение" выберите "Перевернуть горизонтально". Изображение перевернется справа налево, как в зеркале.

Примечание: Этот эффект можно применить как к фрагменту (выделенному прямоугольнику) изображения, так и ко всему изображению целиком.

Совет: для изображений в формате JPG лучше использовать преобразование без потерь информации в меню "Сервис à Поворот/преобразование JPG без потерь".

См. также:

Повернуть


Изменить размер изображения

В меню "Изображение" выберите "Изменить размер изображения". Откроется окно выбора нового размера изображения; при изменении размера изображения можно использовать фильтры ресэмплирования (передискретизации).

Размер можно выбрать из предлагаемых вариантов или ввести взамен старого. Первое число - это ширина, а второе - высота, оба в пикселах. Если стоит галочка "Сохранять пропорции", то достаточно ввести один размер, второй программа рассчитает сама.

Ресэмплирование при изменении размера как правило улучшает качество изображения, особенно при его увеличении. При простом увеличении (без ресэмлирования) изображение размывается.

Для ресэмплирования можно выбрать, какой фильтр использовать, и применять ли только для уменьшения особый (быстрый) фильтр. Обычные фильтры ресэмплирования работают медленнее его.

Фильтры и операции ресэмплирования могут слегка изменить гамму (яркость) изображения, поэтому можно включить улучшение гаммы при ресэмплировании (для опытных).

Совет: если задать единицы размера - см или дюймы, то размер изображения можно будет изменять, просто меняя значение DPI.

Пример: картинка имеет размер 600x500 пикселов и разрешение 300 DPI, если задать единицы размера см или дюймы и установить DPI = 150, то размеры картинки станут 300x250 пикселов, при разрешении 150 DPI.

Эта же возможность есть в групповых операциях с дополнительными установками ("Менять размер только по новому/старому DPI").

Для изменения размера нажмите "OK".

Это действие можно отменить командой "Отменить" из меню "Правка".


Добавить рамку

В меню "Изображение" выберите "Изменить размер холста" или "Добавить границу/рамку".

Размер холста: откроется окно для выбора размера и цвета полей, добавляемых вокруг картинки.

При отрицательных значениях размера поля рисуются внутри картинки.

Добавить границу/рамку: откроется окно для выбора размера и цвета рамки (границы) вокруг картинки. В нем есть несколько заготовок рамок разных видов и размеров. Для каждой рамки можно задать до 4 полей, до 4 размеров и цветов.

Если задать размер поля равным нулю, этого поля не будет.

Примечание: Эти эффекты реализованы в плагине Effects, который устанавливается вместе с программой.

Нажмите "OK" для добавления выбранной рамки.

Это действие можно отменить командой "Отменить" из меню "Правка".


Увеличить (уменьшить) глубину цвета

В меню "Изображение" выберите "Увеличить глубину цвета". Откроется окно для выбора количества цветов. Выберите нужное.

В меню "Изображение" выберите "Уменьшить глубину цвета". Откроется окно для выбора количества цветов. Выберите нужное.

Наилучший цвет: в этом случае используется иной (более медленный) метод понижения цветности, обеспечивающий очень высокую точность цветопередачи.

Нажмите "OK" для изменения.

Это действие можно отменить командой "Отменить" из меню "Правка".


Преобразовать в оттенки серого

В меню "Изображение" выберите "Преобразовать в оттенки серого".

Оттенки серого (grayscale) - это фактически цветной режим, как и RGB. Он содержит больше информации об изображении, чем черно-белый. Преобразование цветного изображения в оттенки серого как правило дает лучший результат, чем в черно-белое.

Примечание: Этот эффект можно применить как к фрагменту (выделенному прямоугольнику) изображения, так и ко всему изображению целиком.

Это действие можно отменить командой "Отменить" из меню "Правка".


Показать канал

Эта команда показывает существующий красный, зеленый, синий цветовой канал или альфа-канал (прозрачность) изображения.

Примечание: для показа каналов в цвете см. "Настройки программы à Обзор и редактирование".

Это действие можно отменить командой "Отменить" из меню "Правка".


Преобразовать в негативное

В меню "Изображение" выберите "Преобразовать в негативное". Изображение преобразуется в негативное.

Инвертировать можно всё изображение или лишь один из цветовых каналов.

Примечание: Этот эффект можно применить как к фрагменту (выделенному прямоугольнику) изображения, так и ко всему изображению целиком.

Это действие можно отменить командой "Отменить" из меню "Правка".


Коррекция цветов

В меню "Изображение" выберите "Коррекция цветов". Откроется окно с регуляторами-ползунками. Перемещайте их вправо-влево (больше-меньше) для изменения яркости, контрастности, гамма-коррекции, насыщенности и цветового баланса.

Щелчком по эскизу исходного изображения (левый эскиз, щёлкайте по ярким участкам) можно изменять баланс белого.

Примечание: Все эти эффекты можно применить как к фрагменту (выделенному прямоугольнику) изображения, так и ко всему изображению целиком.

Эти эффекты реализованы в плагине Effects, который устанавливается вместе с программой.

При перемещении ползунков сразу видны изменения эскиза изображения. Кнопка "Применить к исходному" заменяет исходное изображение измененным, но не навсегда, а только до закрытия этого окна.

Поставьте галочку "Запомнить значения при выходе" чтобы запомнить сделанные настройки для следующего изображения.

Текущие (видимые в этом окне) настройки можно сохранить как профиль, а в дальнейшем загружать их и использовать.

Нажмите "OK", если добились нужного эффекта, или "Отмена" для его отмены.

Это действие можно отменить командой "Отменить" из меню "Правка".

Примечание: последнее положение этого окна запоминается.


Гистограмма

В меню "Изображение" выберите "Гистограмма". Откроется окно с гистограммой изображения. Можно выбрать, какой цветовой канал отображать.

Просмотрев, нажмите "Закрыть".


Заменить цвет

В меню "Изображение" выберите "Заменить цвет". Откроется окно замены цвета. Здесь можно выбрать, какой цвет следует заменить другим.

Заменяемый цвет (исходный) можно указать щелчком в главном окне.

Примечание: Этот эффект можно применить как к фрагменту (выделенному прямоугольнику) изображения, так и ко всему изображению целиком.

Для замены выбранного цвета нажмите "OK".


Автокоррекция цветов

В меню "Изображение" выберите "Автокоррекция цветов".

Эта команда улучшает яркость изображения, автоматически вычисляя оптимальные значения яркости и гаммы.

Примечание: Результат можно улучшить, выбрав (выделив) предварительно ключевой фрагмент изображения левой кнопкой мыши. Если при выборе команды удерживать нажатой клавишу Ctrl, то расчет выполняется на основе выбранного участка, а результат применяется ко всей картинке, в противном случае корректируется только выделение.

Это действие можно отменить командой "Отменить" из меню "Правка".


Убрать красные глаза

В меню "Изображение" выберите "Убрать красные глаза".

Эту команду можно применить только к выделенному (выбранному) левой кнопкой мыши фрагменту изображения. При этом уменьшается значение красной составляющей цвета в выделенной области (там, где глаза). Степень уменьшения можно изменить в меню "Все эффекты".

"Все эффекты" позволяет также "Убрать зеленые или желтые глаза" для кошек, собак и т.п.

Это действие можно отменить командой "Отменить" из меню "Правка".


Эффекты

Для их использования в меню "Изображение" выберите (при открытом изображении) "Эффекты".

Примечание: Большинство из этих эффектов можно применить к фрагменту (выделенному) изображения, и ко всему изображению целиком.

Эти эффекты реализованы в плагине Effects, который устанавливается вместе с программой.

Эффекты можно отменить командой "Отменить" из меню "Правка".

Здесь представлены избранные эффекты:

Объемная кнопка

В меню "Изображение" выберите "Эффекты" à "Объемная кнопка".

Придает изображению вид выпуклой кнопки со скошенными краями. Ширина краев настраивается в меню "Все эффекты".

Размытие

В меню "Изображение" выберите "Эффекты" à "Размытие".

Смягчает изображение, придавая ему размытый, нерезкий вид. Степень размытия настраивается в меню "Все эффекты".

Тиснение

В меню "Изображение" выберите "Эффекты" à "Тиснение".

Придает изображению вид гравюры на сером фоне.

Живопись

В меню "Изображение" выберите "Эффекты" à "Живопись".

Придает изображению вид картины, написанной маслом. Текстура - "мазки" настраивается в меню "Все эффекты".

Обнаружение краев

В меню "Изображение" выберите "Эффекты" à "Обнаружение краев".

Находит главные линии изображения и заменяет их цвет противоположным, а большинство цветов заливки затемняет, делая их фоном. Придает изображению вид "живописи на бархате". Для правильной реализации этого эффекта глубина цвета должна быть не больше 256.

Медианный фильтр

В меню "Изображение" выберите "Эффекты" à "Медианный фильтр".

Выравнивает яркость групп пикселов по яркости "среднего" пиксела в группе. В большинстве случаев создается эффект "сглаживания" фильтруемого фрагмента. Степень фильтрации настраивается в меню "Все эффекты".

Взрыв

В меню "Изображение" выберите "Эффекты" à "Взрыв".

Разрывает изображение, как будто взорвались темные пикселы. Сила взрыва настраивается в меню "Все эффекты".

Пикселизация

В меню "Изображение" выберите "Эффекты" à "Пикселизация".

Придает изображению вид мозаики, как будто состоящей из пикселов-переростков. Размер пикселов настраивается в меню "Все эффекты".

Дополнительно в этом меню:

Все эффекты

В меню "Изображение" выберите "Эффекты" à "Все эффекты". Откроется окно, в котором настраиваются все перечисленные эффекты.

Фильтр AltaLux

В меню "Изображение" выберите "Эффекты" à "Фильтр AltaLux". Если установлен плагин AltaLux, то откроется окно, в котором можно применить фильтр.

Фильтр Sandbox

В меню "Изображение" выберите "Эффекты" à "Фильтр Sandbox". Если установлен плагин IrfanView Sandbox, то откроется окно, в котором можно применить фильтр, использующий эффекты JewelScript.

Фильтры Filter Factory

В меню "Изображение" выберите "Эффекты" à "Фильтры Filter Factory". Если установлен плагин FFactory (Filter Factory), то откроется окно, в котором можно выбрать много других эффектов.

Фильтры Filters Unlimited

В меню "Изображение" выберите "Эффекты" à "Фильтры Filters Unlimited". Для этого сначала нужно установить плагин Funltdiv (Filters Unlimited) и скачать несколько фильтров с http://www.icnet.de. Подробнее см. в файле FUnlimited_Readme.txt в подпапке PlugIns папки IrfanView.


Настройка эффектов

Настройка эффектов (Все эффекты)

 В начало Назад Далее

В меню "Изображение" выберите "Эффекты" à "Все эффекты". Откроется окно дополнительных настроек массы изобразительных эффектов. Эти эффекты реализованы в плагине Effects, который устанавливается вместе с программой.

Закончив, нажмите "OK" для применения эффекта или "Отменить" для его отмены.

Примененный кнопкой "OK" эффект можно отменить командой "Отменить" из меню "Правка".

Большинство эффектов имеют числовую настройку (например, от 1 до 99), регулирующую силу эффекта.


Фильтры Adobe 8BF

В меню "Изображение" выберите (при открытом изображении) "Фильтры Adobe 8BF (плагины)" à "Управление фильтрами".

Откроется окно управления фильтрами, в котором можно загрузить и применить фильтры (эффекты, плагины), совместимые с Adobe Photoshop. Кнопкой "Добавить фильтры 8BF" выберите (импортируйте) папку с фильтрами 8BF. Выберите один из загруженных (показанных) фильтров и запустите его клавишей "пробел", кнопкой или двойным щелчком.

Вторая подгруппа (подменю): здесь представлены особенно полезные фильтры, совместимые с Adobe Photoshop, для упрощения их запуска. Эти стандартные эффекты можно загрузить с сайта IrfanView в виде дистрибутива:

http://www.irfanview.net/plugins/irfanview_adobe_8bf_plugins.exe

или в архиве ZIP:

http://www.irfanview.net/plugins/irfanview_adobe_8bf_plugins.zip

Третья подгруппа: сюда можно добавить дополнительные фильтры (плагины) 8BF. Можно либо скопировать файлы 8BF (и все нужные им DLL) в подпапку IrfanView\Plugins\Adobe 8BF\ либо можно указать путь к плагинам 8BF в "Настройки программы à PlugIns".

Совет: Неплохие сайты с эффектами 8BF:

http://www.richardrosenman.com/software/downloads/ (например, Grid Generator и т.п.)

Примененный нажатием "OK" эффект можно отменить командой "Отменить" из меню "Правка"..


Фильтры Filter Factory

Примечание: Фильтры Filter Factory реализованы в плагине, который нужно скачать и установить:

http://www.irfanview.com/plugins.htm

Примечание: Несколько фильтров (эффектов) 8BF можно найти здесь:

http://www.stevesdesktopphotography.com

http://hno.freeshell.org/download.htm

http://www.thepluginsite.com/

В меню "Изображение" выберите "Эффекты" à "Фильтры Filter Factory". Откроется окно для управления фильтрами (загруженными).

Ползунки "Параметры" управляют фильтрами. Они регулируют действие фильтров на изображение. Как правило, сдвиг ползунка вправо усиливает действие, а влево - ослабляет. Кнопка "Стандартные значения" сбрасывает ползунки в исходное состояние, определенное автором фильтра.

Поле "Группы фильтров" помогает уследить за ними. Показаны названия всех имеющихся групп фильтров. Можно добавлять группы в список и исключать из него.

В поле "Фильтры" показаны названия фильтров выбранной группы. Можно добавлять фильтры в список. Щелчком по имени можно просмотреть фильтр. Эскиз покажет, как подействует выбранный фильтр на изображение. Чтобы применить фильтр, нажмите "Применить к изображению". Отменить это можно кнопкой "Отменить операцию" или командой "Отменить" из меню "Правка".

Кнопка "Добавить FF-фильтр" добавляет фильтры. Откроется окно для выбора папки, в которой находятся фильтры. Выбрав папку, нажмите "OK". Все группы фильтров из этой папки будут добавлены в список. Для возврата без добавления фильтров нажмите "Отмена".

Кнопка "Убрать фильтр из списка" удаляет выбранный фильтр из списка. Для удаления нескольких фильтров используйте "Убрать группу" или "Убрать все". Фильтр удаляется только из списка, но не с диска.

Кнопка "О фильтре" показывает имя файла, название фильтра, имя автора и авторские права на выбранный фильтр. Прочитав это, нажмите "OK".

Нажав "Благодарности...", увидите благодарность Michael Johannhanwahr за библиотеку, предоставленную для использования в IrfanView.

Закончив с фильтрами, нажмите "Выход".


Поменять местами цветовые каналы

В меню "Изображение" выберите "Поменять местами цветовые каналы". В подменю выберите, какой цвет на какой заменить в изображении.

Эта команда работает с пикселами, изменяя цвет каждого или большинства из них, в зависимости от выбранного варианта.

Пример: Если выбрать RGB à RBG, то зеленые пикселы станут синими, а синие - зелеными (в этом варианте цвет красных пикселов остается прежним).

Возможные варианты замены (здесь "R" обозначает красный, "G" - зеленый, а "B" - синий):

RGB à RBG

RGB à BGR

RGB à BRG

RGB à GRB

RGB à GBR


Палитра

Для изображений в 256 цветах и менее.

Если изображение полноцветное, можно уменьшить глубину цвета в меню "Изображение".

Изменить

Окно покажет цвета, используемые в изображении. Щелчком выбирается цвет для просмотра информации о нем. Двойным щелчком - для изменения. Изменения цветов сразу видны на изображении. Если цвет устраивает, нажмите кнопку "OK" для изменения палитры.

Совет: при щелчке по изображению (в главном окне) указанный номер цвета будет выбран в окне палитры.

Это действие можно отменить командой "Отменить" из меню "Правка".

Экспортировать

Откроется окно для выбора папки и имени файла. Палитра сохраняется в формате палитры Paint Shop Pro - как файл PAL.

Импортировать

Откроется окно для выбора файла PAL (палитры Paint Shop Pro). Изображение будет перекрашено в цвета выбранной палитры.

Если хотите применить исходную палитру 1:1 или найти ближайшие цвета, см. "Настройки программы à Обзор и редактирование".


Настройки программы

В меню "Сервис" выберите "Настройки программы" (или нажмите на одноименную кнопку панели инструментов).

Откроется окно настройки большинства основных функций IrfanView.

Выберите одну из закладок для просмотра соответствующего раздела настроек программы. Вот эти разделы:

Запуск и выход, JPG/PCD/GIF, Типы файлов, Просмотр, Обзор и редактирование, Полный экран и слайдшоу, Видео и аудио, Операции с файлами, Язык, Панель инструментов.

PlugIns, Разное,


Настройки, Запуск и выход

Здесь можно выбрать папку запуска программы IrfanView.

"Запрет одновременного запуска нескольких копий IrfanView": если снять галочку, можно будет отрыть одновременно несколько окон программы с разными файлами. Если галочка стоит, то все картинки будут открываться в одном и том же ее окне.

"Запуск в полноэкранном режиме": картинки в IrfanView будут открываться сразу в полноэкранном режиме. Клавиша Esc будет закрывать программу, а не полноэкранный режим.

"Предупреждать при выходе по клавише Esc": поставьте галочку, если боитесь случайно закрыть IrfanView клавишей Esc.

"Выдавать запрос на сохранение изменений...": поставьте галочку, если боитесь случайно закрыть IrfanView (или изображение), не сохранив внесенные изменения.

"При открытом окне миниатюр закрывать по Esc только окно просмотра": поставьте галочку, если хотите при открытом окне миниатюр не закрывать IrfanView по Esc в главном окне, а только скрывать главное окно.

Нажмите "OK", чтобы применить внесенные изменения, или "Отмена" для их отмены.


Настройки программы, JPG/PCD/GIF

JPEG

Если хотите автоматически поворачивать изображение JPG согласно данным в EXIF (если они есть), поставьте первую галочку.

Если поставить галочку "Загружать все файлы JPG как монохромные", то ВСЕ JPG будут показаны в оттенках серого. Не забудьте, если включите ее!

Photo CD

Здесь можно переключателем выбрать размер изображения, которое будет открываться (файлы Photo CD содержат несколько изображений разных размеров).

GIF

Для формата GIF есть две специальные настройки-галочки. Первая - "Воспроизводить анимированные GIF". Изначально она стоит. Если ее снять, в них будет показан только первый кадр.

Вторая галочка управляет прозрачностью неанимированных GIF. Поставьте ее, чтобы показывать прозрачность и в обычных файлах GIF (неанимированных). Не забудьте, если включите ее! Если фон главного окна (изначально черный) совпадет с прозрачным цветом GIF, в некоторых случаях картинку не будет видно (только фон). Либо снимите галочку, или измените цвет фона в меню "Настройки программы à Просмотр".


Настройки программы, Типы файлов

Здесь можно выбрать, какие типы файлов будут связаны с IrfanView.

Эти файлы в Проводнике обозначаются значком связанной с ними программы; двойным щелчком по их имени запускается эта программа, и в ней открывается этот файл. Для связывания поставьте галочки у выбранных типов файлов. Чтобы связать с IrfanView все типы, нажмите "Выбрать все". Кнопка "Снять все отметки" разрывает все связи; "Только графика" связывает с IrfanView все известные ей типы изображений.

Ниже поля выбора форматов есть поле для ввода расширений, которых нет в списке. Поставьте галочку "Другие" и введите дополнительные расширения, разделяя их вертикальной чертой - "|".

"Для всех пользователей": с этой галочкой в Windows XP расширения связываются для всех пользователей; по умолчанию же - только для текущего пользователя.

Если включить "При обзоре папок загружать только файлы ассоциированных типов", то листая картинки клавишами "пробел" и "забой"(backspace), вы увидите только файлы, связанные с IrfanView.

Совет: Ненужные при пролистывании расширения легко исключить, выбрав "Загружать файлы указанных ниже типов" и отредактировав список расширений (например, исключив TXT).

Галочка "Добавить IrfanView в контекстное меню 'Отправить'" добавляет IrfanView в раздел "Отправить" контекстного меню файлов. Галочка "Пункт 'Обзор в IrfanView' в контекстном меню дисков и папок" добавляет IrfanView в соответствующие меню дисков и папок.

Чтобы показывать значки BMP как миниатюры, есть соответствующая галочка. По умолчанию она стоит.

Значки:

Кнопка "Значки и другие параметры" открывает окно настроек.

В поле "Общий значок для всех файлов" можно выбрать один значок для всех файлов, связанных с IrfanView.

Если выбрать "Свой значок для каждого формата", то каждому формату, связанному с IrfanView, будет присвоен свой значок (если установлен плагин Icons).


Настройки программы, Просмотр

"Показывать альфа-канал/прозрачность в файлах PNG/TIF/TGA/DDS": Некоторые PNG, TGA и DDS сохраняются с прозрачным цветом или альфа-каналом. На таких изображениях области прозрачного цвета будут в этом случае показаны цветом главного окна IrfanView.

"Показывать встроенные аннотации в файлах TIF": Для TIF, созданных в Wang/Kodak Imaging: встроенные в них текстовые аннотации можно показывать на изображении.

"Растрировать 24-битрные изображения в 16-битовых режимах экрана": Поставьте эту галочку для улучшения вида полноцветных изображений, если режим экрана Windows - 65536 цветов.

"Гамма-коррекция": Можно включить для регулировки интенсивности каждого открываемого изображения. Её исходное значение = 1.00 (без изменений), а диапазон изменения - от 0.01 (очень темное) до 6.99 (очень яркое). Гамма-коррекция удобна для просмотра серий фото с разными экспозициями. Она особенно полезна на ноутбуках, снижающих яркость экрана для экономии заряда батареи. При уровне гамма-коррекции выше 1.00 изображения будут все равно видны с их реальной яркостью.

"Гамма-коррекция для ч/б изображений" включена по умолчанию для настройки интенсивности передискретизированных черно-белых изображений. Исходное значение = 0.50 (темное), диапазон изменения - от 0.01 до 6.99.

"Показывать полный путь к файлу в заголовке окна": Включите, если хотите видеть полный путь к файлу (включая диск и папки) в заголовке главного окна. Иначе отображается только имя файла с расширением (по умолчанию).

"Правая кнопка мыши вызывает контекстное меню": Правую кнопку мыши можно использовать для прокрутки (по умолчанию) или вызова контекстного меню.

Следующая галочка - "Центрировать окно при загрузке нового изображения". Поставьте ее, и каждая новая картинка будет открываться в центре экрана.

Следующая галочка - "Запоминать последние размер и положение окна". Работает только при просмотре в режимах "Подгонять все изображения под размер окна" и "Не подгонять ничего". Если ее поставить, окно с картинкой будет открываться в том месте экрана, где оно было закрыто.

"Цвет главного окна" позволяет задать цвет фона главного окна IrfanView. Можно выбрать любой цвет. Изначально он черный.

"Текст в строке состояния": можно задать текст, отображаемый в правом поле строки состояния. Подробнее о настройке шаблона текста см. на этой странице.


Настройки программы, Масштаб и цвет

Шаг масштабирования задает коэффициент или величину увеличения и уменьшения. По умолчанию он = 10% на каждый шаг изменения масштаба изображения. Для его изменения введите в поле нужное значение.

"Вычисление масштаба" задает метод расчета масштаба. Относительный: масштаб рассчитывается умножением предыдущего(текущего) размера, на шаг масштабирования; Абсолютный: масштаб вычисляется добавлением абсолютного шага масштабирования к текущему значению; Фиксированный: значения масштаба берутся из таблицы общепринятых (популярных) масштабов.

"Управление цветом, задать цветовой профиль": некоторые файлы JPG и TIF сохраняются со встроенным цветовым профилем, эта галочка - для применения таких профилей. Можно взять текущий профиль монитора из параметров экрана Windows или выбрать другой файл ICC(ICM).

Если включить "Применять и к файлам без встроенного цветового профиля", управление цветом будет применяться для ВСЕХ (!) открываемых изображений, что намного замедляет их загрузку.

Для изображений без встроенного цветового профиля можно задать (выбрать) ICC/ICM профиль ввода. По умолчанию - sRGB.

Профиль можно применять к исходным цветам только если установлен плагин LCMS.

Примечание: цветовые профили намного замедляют загрузку изображений.


Настройки программы, Обзор и редактирование

Обзор

"Показывать все файлы в папке": Поставьте галочку, чтобы можно было просмотреть в каждой папке все файлы, поддерживаемые IrfanView. Если ее снять, нельзя будет открыть следующий/предыдущий файл клавишами пробел/забой или стрелками на панели инструментов.

"Показывать скрытые файлы/папки": Включает показ скрытых файлов при обзоре в текущей папке.

"По достижении конца/начала папки": Можно выбрать, что произойдет после открытия последней(первой) картинки в папке: IrfanView может открыть окно обзора вложенных папок для выбора, в какой из них продолжить просмотр; или начать сначала обзор картинок в той же папке; или ничего не делать - просто остановить обзор.

"Звук при цикличном переходе в папке (и при сохранении снимка экрана)": подсказывает, что в фоне произошло одно из этих событий.

"Смена изображений клавишами PgUp/PgDn роликом мыши": Не прокручивать большие изображения этим способом, а переходить к предыдущему или следующему файлу.

Редактирование

"Разрешить отмену": Если снять галочку, то эта команда в меню "Правка" не будет работать.

"Задать цвет выделения/сетки": можно задать цвет (на самом деле инвертированный цвет) прямоугольника выделения или ячеек сетки. По умолчанию это серый.

"Использовать ближайший цвет при импорте палитры": по умолчанию цвета изображения заменяются на цвета с тем же номером из файла PAL, с этой галочкой будет подбираться лучший (ближайший по тону) цвет из файла PAL.

Можно задать и цвет фона при вырезании.

"Заполнять выделенную область при вставке": по умолчанию вставляемое изображение растягивается до размера выделения, эта галочка позволяет вставить изображение с сохранением пропорций.

"Вставка рядом: подгонять вставляемое изображение под текущее": по умолчанию вставляемое изображение подгоняется под размер существующего, это позволяет вставлять изображение, не меняя исходный размер.

"Размер ячейки сетки": можно задать размер ячеек сетки (из меню "Правка").

"Допуск для автообрезки границ": можно задать допустимую разницу в цвете пикселов рамки, что расширит обрезаемую рамку.

Можно задать "Параметры для текстовых файлов и вставки текста": шрифт, цвет шрифта (текста) и цвет фона.


Настройки программы, Полный экран и слайдшоу

1 Показывать изображения/видео как есть: При этом положении переключателя размер картинок и видео не адаптируется к размеру экрана. Если они меньше экрана, то они автоматически центрируются. Если они больше, то будет видна только их верхняя левая часть, помещающаяся на экране. Клавишами-стрелками можно сдвинуть картинку или видео, чтобы увидеть другие фрагменты.

2 Уменьшать большие изображения: Рекомендуемый способ просмотра в полноэкранном режиме. Картинки, размер которых больше разрешения экрана, уменьшаются - подгоняются под размер экрана с сохранением соотношения сторон (пропорционально). Маленькие картинки показываются в центре экрана в их настоящем размере, как в первом случае.

3 Вписывать в экран все изображения/видео: Похоже на второй вариант, но слишком маленькие картинки и видео увеличиваются (пропорционально) до размера экрана.

4 Растягивать все до заполнения: В этом случае все картинки и видео растягиваются до полного заполнения экрана. Их пропорции при этом не принимаются во внимание, что может привести к заметному искажению изображения.

5 Вписывать изображения по ширине экрана: Ширина картинок подгоняется под ширину экрана, а высота - пропорционально.

6 Вписывать изображения по высоте экрана: Высота картинок подгоняется под высоту экрана, а ширина - пропорционально. Удобно для просмотра панорам.

В полноэкранном режиме можно временно перейти в любой из этих 6 режимов клавишами 1, 2, 3, 4, 5 и 6. Такое изменение режима полноэкранного отображения не запоминается в настройках программы.

Масштабирование вывода: полезно для широкоформатных мониторов, для настройки пропорций изображения.

Центрировать изображение на экране: этот параметр определяет, отображать ли картинку в центре экрана или в его верхнем левом углу.

Ресэмплировать при первом показе: Поставьте эту галочку, чтобы в полноэкранном режиме картинка сразу (при первом появлении) отображалась с наилучшим качеством, если она подгоняется по размеру. Но передискретизация требует больше времени на расчеты (загрузку изображения).

Ресэмплировать при изменении масштаба вручную: Поставьте эту галочку, чтобы в полноэкранном режиме картинка отображалась с наилучшим качеством, если она масштабируется. Но передискретизация требует больше времени на расчеты (загрузку изображения).

Цвет экрана позволяет задать цвет фона на время загрузки изображения и цвет полей между краем изображения и краем экрана, зависящих от режима полноэкранного отображения.

Шрифтом текста задается шрифт, начертание, размер и цвет отображаемого текста. Можно выбрать и фон текста, если он видимый - если снята галочка "Прозрачный фон". В этом случае текст появляется в прямоугольнике выбранного цвета, что улучшает его разборчивость. А текст на прозрачном фоне накладывается прямо на изображение, не портя его, но может читаться хуже, в зависимости от цвета картинки.

Если стоит галочка "Несколько мониторов: растягивать изображение на все", картинка растягивается на все подключенные мониторы, как на один большой экран.

Два параметра внизу - только для полноэкранного режима.

Галочка "Скрывать курсор мыши" убирает курсор мыши с экрана на время показа картинки.

Но если при этом сдвинуть мышь, он появится ненадолго, и его можно будет использовать.

Поставьте галочку "Показывать текст" для вывода текстовой информации о картинке, показанной на экране. IrfanView может сообщить о файле многое - имя, размер, дату и время, данные EXIF/IPTC/комментарий и т.п. Подробнее о настройке текстового шаблона см. на этой странице.


Настройка шаблона текста

Это - очень эффективный способ генерации текста для следующих случаев:

· Добавить текст в выделение
· Преобразовать/переименовать группу файлов
· Печать
· Слайдшоу
· Полноэкранный режим
· Контрольный лист
· Экспорт в HTML
· Преобразование из командной строки

Допустимые шаблоны свойств файла (изображения):

Шаблон Тег или функция

$D - папка (каталог) файла - полный путь
$d - папка (каталог) файла - последняя подпапка
$F - имя файла (с расширением)
$N - имя файла (без расширения)
$O - расширение файла
$S - размер файла
$T - дата и время файла (дополнительные параметры см. в Приложении A (ниже) )
$U - системная дата и время (дополнительные параметры см. в Приложении A (ниже) )
$X - № файла в папке
$M - № страницы в многостраничном изображении
$Z - текущий масштаб (для полноэкранного режима и слайдшоу)
$W - ширина картинки
$H - высота картинки
$B - глубина цвета, бит на пиксел
$p - разрешение, точек на дюйм
$Q - "верное" расширение файла, по возможности (для файлов с неверным расширением)
$P - размер отпечатка, из окна "Изображение" à "Свойства изображения"
$C - для JPG и Webshots - комментарий, если он есть
$I - все данные IPTC
$Ix - для JPG - значение тега x из IPTC, если он есть (x - № тега, см. ниже) (нужен плагин Metadata)
$E - все данные EXIF
$Ex - для JPG - значение тега x из EXIF, если он есть (x № тега, см. ниже) (нужен плагин Metadata)
| - новая строка
$| - вставить символ '|'
$$ - вставить символ '$'
[A-B] - используется совместно с $D, $d, $F и $N; выдает диапазон (часть) текста от A до B

пример: $N[0-5] => выдает 5 символов имени файла

Важные и интересные теги и шаблоны IPTC, согласно спецификации IPTC:

Шаблон Тег или функция (описание)

$I5 - Object Name (название объекта, заголовок документа)
$I7 - Edit Status (состояние редактирования)
$I10 - Priority (приоритет)
$I15 - Category (категория)
$I20 - Supplemental Category (дополнительная категория)
$I25 - Keywords (ключевые слова)
$I30 - Release Date (дата выпуска; дополнительные параметры см. в Приложении A)
$I35 - Release Time (время выпуска)
$I40 - Special Instructions (особые указания)
$I45 - Reference Service (служба ссылок)
$I47 - Reference Date (дата ссылки)
$I50 - Reference Number (№ ссылки)
$I55 - Created Date (дата создания; дополнительные параметры см. в Приложении A)
$I60 - Created Time (время создания)
$I65 - Originating Program (программа создания)
$I70 - Program Version (версия программы)
$I75 - Object Cycle (цикл объекта)
$I80 - Byline (автор)
$I85 - Byline Title (авторское название)
$I90 - City (город)
$I92 - Sublocation (район)
$I95 - Province State (провинция, штат)
$I100 - Country Code (код страны)
$I101 - Country (страна)
$I103 - Original Transmission Reference (ссылка на первоисточник)
$I105 - Headline (заголовок)
$I110 - Credit (благодарности)
$I115 - Source (источник)
$I116 - Copyright (авторские права)
$I120 - Caption (подпись)
$I121 - Local Caption (локальная подпись)
$I122 - Caption Writer (автор подписи)

Важные и интересные теги и шаблоны EXIF, согласно спецификации EXIF:

Шаблон Тег или функция (описание)

$E270 - ImageDescription (описание снимка)
$E271 - Make (производитель камеры)
$E272 - Model (модель камеры)
$E274 - Orientation (ориентация камеры при съемке)
$E282 - XResolution (разрешение вывода по координате X)
$E283 - YResolution (разрешение вывода по координате Y)
$E296 - ResolutionUnit (единицы измерения разрешения)
$E305 - Software (программа)
$E306 - DateTime (датировка снимка; дополнительные параметры см. в Приложении A)
$E315 - Artist (исполнитель)
$E318 - WhitePoint (определение точки белого изображения)
$E531 - YCbCrPositioning (положение точки, определяющей цвет в ячейке YСbCr данных)
$E532 - ReferenceBlackWhite (определение точки черного/белого для YCbCr)
$E33432 - Copyright (авторские права)
$E33434 - ExposureTime (выдержка, она же - экспозиция)
$E33437 - FNumber (диафрагма)
$E34850 - ExposureProgram (программа выдержки)
$E34855 - ISOSpeedRatings (эквивалентная светочувствительность)
$E36864 - ExifVersion (версия формата Exif)
$E36867 - DateTimeOriginal (датировка съемки; дополнительные параметры см. в Приложении A)
$E36868 - DateTimeDigitized (датировка оцифровки снимка; дополнительные параметры см. в Приложении A)
$E37121 - ComponentsConfiguration (формат представления данных в файле изображения)
$E37122 - CompressedBitsPerPixel (средняя степень уплотнения JPEG)
$E37377 - ShutterSpeedValue (скорость затвора - величина выдержки в представлении APEX)
$E37378 - ApertureValue (диафрагма в представлении APEX)
$E37379 - BrightnessValue (яркость сюжета в APEX)
$E37380 - ExposureBiasValue (компенсация экспозиции в единицах EV APEX)
$E37381 - MaxApertureValue (максимальная апертура объектива в представлении APEX)
$E37382 - SubjectDistance (дистанция фокусировки)
$E37383 - MeteringMode (режим экспозамера)
$E37384 - LightSource (источник света)
$E37385 - Flash (вспышка)
$E37386 - FocalLength (фокусное расстояние объектива)
$E37510 - UserComment (комментарий пользователя)
$E37520 - SubsecTime (время снимка, доли секунды)
$E37521 - SubsecTimeOriginal (время съемки, доли секунды)
$E37522 - SubsecTimeDigitized (время оцифровки, доли секунды)
$E40091 - XP Title (заголовок - дополнительный тег, используемый Проводником Windows)
$E40092 - XP Comment (комментарий - дополнительный тег, используемый Проводником Windows)
$E40093 - XP Author (автор - дополнительный тег, используемый Проводником Windows)
$E40094 - XP Keywords (ключевые слова - дополнительный тег, используемый Проводником Windows)
$E40095 - XP Subject (тема - дополнительный тег, используемый Проводником Windows)
$E40960 - FlashPixVersion (совместимость с форматом FlashPix)
$E40961 - ColorSpace (цветовое пространство файла)
$E40962 - ExifImageWidth (ширина изображения)
$E40963 - ExifImageHeight (высота изображения)
$E41483 - FlashEnergy (энергия вспышки)
$E41486 - FocalPlaneXResolution (разрешение по X в фокальной плоскости)
$E41487 - FocalPlaneYResolution (разрешение по Y в фокальной плоскости)
$E41488 - FocalPlaneResolutionUnit (единицы измерения разрешения в фокальной плоскости)
$E41492 - SubjectLocation (положение объекта)
$E41493 - ExposureIndex (№ выдержки)
$E41495 - SensingMethod (тип сенсора)
$E41728 - FileSource (источник изображения)
$E41729 - SceneType (тип сцены)
$E41985 - CustomRendered (обработка изображения)
$E41986 - ExposureMode (режим экспоавтоматики)
$E41987 - WhiteBalance (баланс белого)
$E41988 - DigitalZoomRatio (цифровой масштаб)
$E41989 - FocalLengthIn35mmFilm (фокусное расстояние в эквиваленте 35-мм пленки)
$E41990 - SceneCaptureType (сюжетная программа)
$E41991 - GainControl (управление уровнем)
$E41992 - Contrast (контрастность)
$E41993 - Saturation (насыщенность)
$E41994 - Sharpness (резкость)
$E41995 - DeviceSettingDescription (описание настроек камеры)
$E41996 - SubjectDistanceRange (диапазон расстояния до объекта)
$E42032 - Owner Name (имя владельца)
$E42033 - Camera Serial Number (заводской № фотокамеры)
$E400 - GPSVersionID (версия данных GPS)
$E401 - GPSLatitudeRef (знак широты от GPS)
$E402 - GPSLatitude (широта от GPS)
$E403 - GPSLongitudeRef (знак долготы от GPS)
$E404 - GPSLongitude (долгота от GPS)
$E405 - GPSAltitudeRef (знак высоты от GPS)
$E406 - GPSAltitude (высота от GPS)
$E407 - GPSTimeStamp (точное время от GPS)
$E416 - GPSImgDirectionRef (тип азимута изображения от GPS)
$E417 - GPSImgDirection (азимут изображения от GPS)
$E429 - GPSDateStamp (дата от GPS)
$E499 - выдает значения GPSLatitude и GPSLongitude одной строкой, годится, например, для экспорта в HTML из Google Maps

Примечание: Можно использовать также специальные теги EXIF согласно спецификаций производителей фотокамер (Nikon, Canon, Fuji, Casio, Olympus).

Список тегов для фотокамер Nikon (разных моделей):

Шаблон Тег или функция (описание)

$E1 - Data Version (версия данных)
$E2 - ISO Setting (установка светочувствительности)
$E3 - Color Mode (режим цветности)
$E4 - Image Quality (качество изображения)
$E5 - White Balance (баланс белого)
$E6 - Image Sharpening (резкость изображения)
$E7 - Focus Mode (режим фокусировки)
$E8 - Flash Setting (настройка вспышки)
$E9 - Flash Mode (режим вспышки)
$E11 - White Balance Adjustment (настройка баланса белого)
$E14 - Exposure Adjustment (настройка выдержки)
$E15 - ISO Selection (выбор светочувствительности)
$E18 - Flash Compensation (компенсация вспышки)
$E19 - ISO 2 (светочувствительность 2)
$E128 - Image Adjustment (подстройка изображения)
$E129 - Tone Compensation (компенсация тона)
$E130 - Auxiliary Lens (вспомогательная линза)
$E131 - Lens Type (тип линзы)
$E132 - Lens (линза)
$E133 - Manual Focus Distance (дистанция при ручной фокусировке)
$E134 - Digital Zoom (цифровой масштаб)
$E135 - Flash Used (используемая вспышка)
$E136 - AF Focus Position (положение автофокуса)
$E137 - Bracketing (брекетинг)
$E141 - Color Mode (режим цветности)
$E144 - Light Type (тип освещения)
$E146 - Hue Adjustment (настройка цветности)
$E148 - Saturation Adjustment (настройка насыщенности)
$E149 - Noise Reduction (шумоподавление)
$E167 - Total Pictures (всего фотографий)

Список тегов для фотокамер Canon (разных моделей):

Шаблон Тег или функция (описание)

$E1 - Macro mode (режим макросъемки)
$E2 - Self timer (таймер съемки)
$E3 - Quality (качество)
$E4 - Flash mode (режим вспышки)
$E5 - Sequence mode (режим серии)
$E7 - Focus mode (режим фокусировки)
$E10 - Image size (размер изображения)
$E11 - Easy shooting mode (упрощенный режим съемки)
$E12 - Digital zoom (цифровой масштаб)
$E13 - Contrast (контрастность)
$E14 - Saturation (насыщенность)
$E15 - Sharpness (резкость)
$E16 - ISO Value (значение светочувствительности)
$E17 - Metering mode (режим экспозамера)
$E18 - Focus type (тип фокусировки)
$E19 - AF point selected (выбранная точка автофокусировки)
$E20 - Exposure mode (режим выдержки)
$E25 - Focal length (фокусное расстояние)
$E28 - Flash activity (использование вспышки)
$E29 - Flash details (подробно о вспышке)
$E32 - Focus mode 2 (режим фокусировки 2)
$E40 - White Balance (баланс белого)
$E41 - Sequence number (№ серии)
$E42 - AF point used (использованная точка автофокусировки)
$E43 - Flash bias (экспокоррекция вспышки в EV APEX)
$E44 - Subject Distance (дистанция фокусировки)
$E47 - Camera Temperature (температура фотокамеры)
$E60 - Image Type (тип изображения)
$E70 - Firmware Version (версия прошивки камеры)
$E80 - Image Number (№ фотографии)
$E90 - Owner Name (имя владельца)
$E93 - File Number (№ файла)
$E120 - Camera Serial Number (заводской № фотокамеры)

Приложение A

По умолчанию все шаблоны датировки заменяются полной датой, включающей и время. Для выделения из неё лишь отдельных значений можно использовать в шаблоне дополнительные параметры (функция strftime ANSI C):

%Y - год, 4 цифры
%y - год, 2 цифры (00-99)
%m - № месяца
%d - день месяца
%H - часы
%M - минуты
%S - секунды
%a - день недели сокращенно
%A - день недели полностью
%b - название месяца сокращенно
%B - название месяца полностью

Примеры для файла с датировкой (EXIF или системной): год - 2005, месяц - 11, число - 29

Шаблон Получится текст

$T(%d.%m.%Y) 29.11.2005
$T(%Y%m%d) 20051129
$T(%d%m%y) 291105
$E36868(%Y_%m_%d) 2005_11_29
$T(%d_%m_%Y) 29_11_2005
$T(число:%d, месяц:%m, год: %Y) число: 29, месяц: 11, год: 2005


Настройки программы, Видео и аудио

В этом окне настраивается воспроизведение видео и звука. Видео и звук можно воспроизводить в главном окне (по умолчанию) или в отдельном окне с помощью плагина IV_Player. Воспроизведение видео и звука невозможно без плагина VIDEO, который устанавливается вместе с программой.

"С помощью DirectShow": - позволяет воспроизводить (если установлены кодеки!) большинство форматов видео.

Поставив эту галочку, можно будет управлять просмотром клавишами "Pause" (приостановить-продолжить) и стрелками вправо-влево (перемотка), см. страницу "клавиатурные команды".

В окне проигрывателя есть несколько дополнительных функций (масштаб, громкость, копирование кадра) => см. в контекстном меню (вызывается щелчком правой кнопки мыши).

"Пытаться воспроизводить Flash-видео в главном окне": позволяет просматривать (если установлены нужные кодеки Directshow!) файлы FLV в главном окне, а не в дополнительном окне проигрывателя Flash.

Настройка Apple QuickTime :

В IrfanView есть поддержка QuickTime! Она позволяет IrfanView читать форматы MOV, QTIF, Mac PICT FLI/FLC, если установлены плагин Quicktime и программа Apple QuickTime. Её можно включить или отключить.


Настройки программы, Операции с файлами

В первом разделе можно задать папку, в которую по умолчанию будут копироваться файлы. Можно ввести имя папки или нажать кнопку "Обзор" и выбрать ее. Если ниже выбрано "Перед копированием показывать диалоговое окно с настройками", IrfanView перед копированием откроет окно выбора папки.

Во втором разделе можно задать папку, в которую по умолчанию будут перемещаться файлы. Поставьте галочку "Перед перемещением показывать диалоговое окно с настройками", чтобы IrfanView перед перемещением открывала окно выбора папки.

В третьем разделе есть несколько галочек, относящихся к операциям удаления.

Можно выбрать:

"Запрос перед удалением файлов", чтобы не удалить файл случайно.

"Удалять в Корзину", чтобы файлы при удалении попадали в Корзину Windows.

"Переходить на следующий файл после удаления/перемещения", чтобы после этих действий сразу открывался следующий файл.

"Закрывать IrfanView после удаления файла", чтобы после удаления сразу выйти из IrfanView.

Здесь есть параметр для специалистов "Удалять сопутствующие файлы". Если его включить, IrfanView вместе с файлом удалит и файлы с тем же именем, но со всеми другими расширениями.

"Показывать диалоговое окно сохранения для команды 'Файл à Сохранить'": Если галочка стоит, команда "Сохранить" открывает стандартное окно выбора папки, куда нужно сохранить изображение. Снимите ее, и "Сохранить" будет сохранять изображение в его исходную папку. Заметьте, что это относится только к "Сохранить"; по команде "Сохранить как" диалоговое окно открывается всегда.

"Запрос на перезапись файла для команд 'Сохранить' и 'Сохранить как'": Заставляет программу запрашивать разрешение перед уничтожением старого файла ради записи нового.

"Предлагать переименовать файл при неверном расширении": Открывая файл с неверным расширением, IrfanView будет запрашивать разрешение исправить его. Если снять галочку, программа ничего исправлять не будет.

Если стоит галочка "При переименовании файла не изменять его порядковый номер в папке", то текущий порядковый номер в папке файла не изменяется при его переименовании, иначе изменится его место в списке файлов.


Настройки программы, Язык

Это окно позволяет "на лету" сменить язык IrfanView.

"Загружать плагин поодержки юникода": плагин юникода позволяет IrfanView открывать имена файлов, содержащие символы юникода, например, японские, китайские, арабские, еврейские, восточноевропейские и т.п.

Примечание: если выбран русский язык, то этот плагин лучше не использовать - часть сообщений будет на "птичьем" языке.

Этот плагин заработает после перезапуска IrfanView.

Языковые DLL находятся в подпапке "Languages" папки IrfanView (их нужно устанавливать отдельно). Выберите язык из списка и нажмите "OK" для перехода на него.

Дополнительные языки и инструментарий для переводчиков см. на сайте:

http://www.irfanview.com/languages.htm


Настройки программы, PlugIns (модули)

Здесь есть некоторые настройки просмотра "сырых" (RAW) форматов цифровых фотоаппаратов. Если хотите для просмотра CRW/CR2 использовать библиотеки DLL от Canon, прочтите файл "i_plugins.txt", в нем есть актуальная информация и ссылки.

Текст, отображаемый при просмотре файлов TTF (шрифтов) позволяет задать текст, который используется для демонстрации шрифтов true type. Можно ввести текст, наиболее подходящий для сравнения шрифтов и проверки, есть ли в шрифте нужные символы.

Путь к плагинам Adobe 8BF позволяет указать путь к плагинам фильтров Adobe 8BF, которые будут показаны в меню "Изображение à Фильтры Adobe 8BF" (в третьей подгруппе). По умолчанию (если поле пути к плагинам Adobe 8BF пустое) это - папка "IrfanView\PlugIns\Adobe 8BF\".


Настройки программы, Разное

"Открывать диалоговое окно слайдшоу в последней папке": Запоминать папку слайдшоу или отрывать текущую.

"Открывать диалоговое окно групповых операций в последней папке": Запоминать папку групповых операций или отрывать текущую.

"Показывать недавние файлы в меню 'Файл'": Показывать ли последние открывавшиеся файлы (до 15) в меню "Файл".

"Показывать недавние папки в окне открытия/сохранения": Показывать ли последние использовавшиеся папки (до 20) в этих диалоговых окнах.

"Очистить список недавних папок": Эта кнопка удаляет имена папок, в которых недавно открывались или сохранялись файлы; это можно сделать в любой момент.

"Создать ярлык к IrfanView на рабочем столе": Помещает на рабочий стол Windows значок IrfanView. Теперь запускать программу можно будет двойным щелчком по нему или сочетанием клавиш Ctrl+Shift+I.

В разделе "Внешние редакторы", можно задать до 3 редакторов. Введите сюда полные пути к графическим редакторам. Или нажмите "Обзор" и укажите их. Теперь командой "Открыть во внешнем редакторе" в меню "Файл" или окне миниатюр будет запущен выбранный внешний редактор, и в нем откроется это изображение.

Галочка "Передавать редактору короткое имя файла" нужна для передачи выбранному редактору имени файла и пути к нему в формате 8.3. Это нужно старым 16-битным программам.

Пример:

"C:\Documents and Settings\User\My Documents\My Pictures\My Image.jpeg"

преобразуется в

"C:\DOCUME~1\USER\MYDOCU~1\MYPICT~1\MYIMAG~1.JPE".

Совет: Можно передать внешнему редактору дополнительные параметры запуска.

По умолчанию IrfanView передает редактору только имя файла. Чтобы передать больше параметров, используются кавычки, а имя файла заменяется на "%1".

Несколько примеров для IrfanView и Total Commander:

path\i_view32.exe

=> это обычный синтаксис, так открывается файл в еще одной IrfanView или редакторе.

path\i_view32.exe "%1"

=> то же, что обычный синтаксис, имя файла передается редактору как первый и единственный параметр.

path\i_view32.exe ""%1" /fs"

=> передается имя файла и ключ "/fs" - открыть в полноэкранном режиме.

path\i_view32.exe ""%1" /resize=(100,100) /aspectratio /resample /convert=d:\temp\thumb.jpg"

=> изменить размер изображения и сохранить его в указанной папке.

path\i_view32.exe ""%1" /convert=d:\temp\$N.jpg"

=> преобразовать изображение в формат JPG сохранить его в указанной папке.

path\totalcmd.exe "/O /T /R="%1""

=> в Total Commander передается имя файла и команда открыть папку в новой закладке правой панели.

Совет: Как открыть такущую папку в Проводнике Window и выделить текущий файл:

explorer "/n,/select,"%1


Медиапроигрыватель

Примечание: Медиапроигрыватель реализован в плагине IV_Player, который нужно скачать и установить:

http://www.irfanview.com/plugins.htm

В меню "Сервис" выберите "Медиапроигрыватель".

Медиапроигрыватель позволяет IrfanView воспроизводить аудио-CD, звук и видео в форматах:

AVI, ASF, CDA, MP3, MPG/MPEG, MOV, MID/RMI, WAV, WMA , WMV и т.п.

Проигрыватель работает с этими форматами через интерфейс MCI или интерфейс проигрывателя Windows Media (рекомендуется).

Этот проигрыватель может извлекать кадры из видеозаписей AVI и имеет встроенный проигрыватель аудио-CD.

Закрыть проигрыватель можно клавишей Esc.


Остановить анимацию

Для остановки анимации в меню "Сервис" выберите "Остановить анимацию".

Эта команда "замораживает" анимированные GIF, курсоры ANI и анимацию MNG. Движение замирает, и GIF(ANI) становится обычной картинкой. Его можно сохранить как неподвижное изображение.

Для сохранения всех кадров используется команда "Извлечь все кадры".


Извлечь все кадры

В меню "Сервис" выберите "Извлечь все кадры". Откроется окно для выбора папки, куда будут сохранены все кадры. Выберите папку и нажмите "OK" для сохранения в ней кадров. Эта команда применима к анимированным GIF, "живым" курсорам (ANI) и поддерживаемым видеофайлам.

Кадры из файла сохраняются в папке под именами вида:

imagename_frame_000.bmp

где imagename - имя исходного файла, а 000 - номер кадра.

Для выхода без извлечения кадров нажмите "Отмена".


Многостраничные изображения

В меню "Сервис" выберите "Многостраничные изображения". Появится подменю с несколькими командами.

Вот эти команды:

Создать многостраничный файл TIF

Этой командой создаются многостраничные изображения TIF из одно- и многостраничных изображений. Каждую страницу можно сохранить со своим типом сжатия TIF. Для однотипного сжатия всех страниц задайте тип сжатия прежде, чем открывать исходные изображения.

Создать многостраничный файл PDF

Этой командой создаются многостраничные изображения PDF из одно- и многостраничных изображений.

Примечание: Формат PDF реализован в плагине, который нужно скачать и установить:

http://www.irfanview.com/plugins.htm

Создать многостраничный файл JPM

Этой командой создаются многостраничные изображения JPM. Можно добавлять и убирать изображения из списка cnhfybw и задать параметры сохранения JPM для каждой страницы (картинки). Для однотипного сжатия всех страниц задайте тип сжатия прежде, чем открывать исходные изображения. Задайте папку и имя создаваемого файла и нажмите кнопку "Создать файл JPM" для записи файла или "Выход" для отмены.

Примечание: Формат JPM реализован в плагине, который нужно скачать и установить:

http://www.irfanview.com/plugins.htm

Изменить многостраничный файл TIF

Этой командой редактируются (сортируются, удаляются и добавляются) страницы-картинки в открытом многостраничном файле TIF. Изменения можно применить к исходному файлу или создать новый файл TIF (рекомендуется).

Добавить текущее изображение к TIF

Этой командой открытое изображение добавляется как страница в файл TIF. К этой странице применяются действующие параметры сохранения TIF (из окна сохранения).

Распечатать все страницы

По этой команде откроется окно печати, позволяющее выдать все страницы текущего изображения на печать.

Извлечь все страницы

По этой команде откроется окно выбора папки, куда будут сохранены все страницы.

Извлекаемые страницы сохраняются в папке под именами вида:

filename_irfanview_extract_000.bmp

где filename - имя исходного изображения, а 000- номер страницы. Страницы сохраняются в формате BMP.


Отправить файл по электронной почте

Примечание: Работа с электронной почтой реализована в плагине EMail , который нужно скачать и установить:

http://www.irfanview.com/plugins.htm

В меню "Сервис" выберите "Отправить файл по электронной почте".

Примечание: По умолчанию используется интерфейс MAPI, запускающий вашу почтовую программу. Можно оставить все поля сообщения пустыми, а ввести все в своей почтовой программе из адресной книги и т.п.

SMTP: уточните настройки SMTP для своей почтовой программы у своего провайдера Интернета.

Для адресов друзей есть простая адресная книга.

Для отправки картинки нажмите "Отправить", для отмены отправки - "Выход".


Операции с JPG без потерь

Поворот JPG без потерь

Примечание: операции с JPG без потерь реализованы в плагине JPG_Transform, который нужно скачать и установить:

http://www.irfanview.com/plugins.htm

Примечание: Эта команда работает только если открыт файл JPG.

В меню "Сервис" выберите "Поворот JPG без потерь". Откроется окно для поворота, переворота, оптимизации или чистки файлов JPG.

Примечание: Можно обработать несколько файлов сразу, если открыть окно миниатюр и выбрать несколько JPG до запуска этой команды.

Примечание: Операции с JPG без потерь, такие как переворот и поворот, работают только если высота изображения кратна 16 (специфика JPG). В противном случае лишние строки изображения будут отсечены.

Примечание: Исходный файл JPG будет изменен (заменен)!

Нажмите "Выполнить" для преобразования открытого JPG или "Отмена" для отмены.


Обрезка JPG без потерь

Обрезка JPG без потерь, Операции с JPG без потерь

Примечание: обрезка JPG без потерь реализована в плагине JPG_Transform, который нужно скачать и установить:

http://www.irfanview.com/plugins.htm

Примечание: Эта команда работает только если открыт файл JPG и выделен фрагмент изображения.

В меню "Сервис" выберите "Обрезка JPG без потерь". Откроется окно для выбора, куда сохранить полученную обрезанную картинку.

Примечание: Можно обработать несколько файлов сразу, если открыть окно миниатюр и выбрать несколько JPG до запуска этой команды.

Примечание: Обрезка JPG без потерь работает только если координаты начала (X и Y) попадают в начало блока JPG. Размеры блока могут быть 8x8, 16x8 или 16x16 пикселов, в зависимости от того, как был сжат JPG. Если включено Подгонять X/Y координаты, то всё выделение целиком будет сдвинуто к ближайшему началу блока, в противном случае лишь начало выделения будет смещено к началу текущего блока.

Пример: задан обрезаемый прямоугольник: X = 43, Y = 32, ширина = 100 и высота = 100; размеры блока JPG - 16x16 пикселов.

Если Подгонять X/Y ВКЛЮЧЕНО, то X станет = 48 (ближе - вправо), а размеры обрезанного изображения останутся 100x100 пикселов.

Если Подгонять X/Y ВЫКЛЮЧЕНО, то X станет = 32 (всегда влево, в начало текущего блока), а размеры обрезанного изображения будут 111x100 пикселов (111 = (43-32) + 100).

Нажмите "Выполнить" для обрезки открытого JPG или "Отмена" для отмены.


Захват (снимок) экрана

В меню "Сервис" выберите "Захват (снимок) экрана". Откроется окно для настройки захвата фрагментов экрана.

Область захвата:

Переключателем выберите область захвата: "Весь экран - все мониторы", "Рабочий стол - текущий монитор" (на котором находится курсор мыши !!!), "Активное окно", "Активное окно (только содержимое)" (без заголовка, меню и строки состояния), "Прямоугольный участок" (выбранный мышью после нажатия кнопки "Старт" или сочетания клавиш Ctrl + Print), "Объект, выбранный мышью" (например, кнопка, окно), или Заданный прямоугольник экрана.

Примечание: при захвате прямоугольного участка и объекта, выбранного мышью, таймер не запускается.

Примечание: при захвате объекта, выбранного мышью, объект под курсором мыши выделяется прямоугольной рамкой. Нажмите левую кнопку мыши для его захвата или Esc для прекращения захвата. Захват можно запустить снова заданной горячей клавишей. Правой кнопкой мыши можно сделать фоновое окно (перекрытое другими) активным.

Примечание: при захвате объекта, выбранного мышью, галочка "Прокручивать окно..." срабатывает не на всех объектах (окнах), например, на окнах обозревателя Интернета, Acrobat Reader, Word и т.п., но в большинстве стандартных системных окон она работает отлично.

Способ захвата:

Захват можно делать заданной горячей клавишей или автоматически. Для автоматического захвата задается интервал в секундах (он может быть дробным), с которым программа будет делать снимки экрана или окна. Горячая клавиша действует до выхода из IrfanView.

Дополнительные параметры:

Если хотите видеть на снимке экрана курсор мыши, поставьте галочку "Вместе с курсором мыши". Галочку "Прокручивать окно..." можно применять на многих объектах (окнах), но не на всех она срабатывает.

Можно включить таймер на заданное число снимков, а после него остановить таймер/захват.

Действие после захвата:

Каждое захваченное изображение можно показать в IrfanView, отправить в буфер обмена, на принтер или сразу сохранить на диске.

Если выбрано "Сохранить изображение как файл", можно задать:

• Имя файла снимка. Оно может быть фиксированным или включать переменную часть, задаваемую шаблонами. По умолчанию оно: capture_###_$U(%d%m%Y_%H%M%S). Так задается имя файла с указанием номера снимка и системного времени, вот такое "capture_001_29112005_123620".

(%d = день (day), %m = месяц (month), %Y = год (year), %H = час (hour), %M = минута (minute), %S = секунда (second) )

В нем можно использовать следующие шаблоны:

# = номер текущего снимка, число цифр в котором задается числом символов #

$W, $H, $B, $p и $U

Примечание: при использовании в имени файла шаблона секунд (%S) и задании дробных значений таймера вида: x.y где y <> 0, в имена файлов войдут и миллисекунды. Это относится к захвату горячей клавишей и по таймеру.

• Папку назначения для снимков. Введите путь к ней или нажмите кнопку "Обзор" и выберите нужную папку.

• Поле "Сохранить как" позволяет выбрать формат, в котором снимки будут записываться на диск. Щелкните по стрелке и выберите один из форматов, если исходный JPG не подходит. Кнопка "Параметры" открывает дополнительное окно для выбора особых параметров сохранения в различных форматах. (Совет: для большинства снимков экрана очень хорош формат PNG.)

Нажмите "Старт" для запуска захвата или "Отмена" для выхода.

После запуска окно IrfanView свернется. Теперь можно заданной горячей клавишей (если выбран захват по горячей клавише) делать снимки выбранного объекта. Так можно сделать несколько снимков.

Примечание: Еще раз выберите в меню "Сервис" команду "Захват (снимок) экрана", чтобы остановить таймер захвата (случайно запущенный).


Оптическое распознавание символов

Примечание: оптическое распознавание символов (OCR) реализовано в плагине, который нужно скачать и установить:

http://www.irfanview.info/plugins/kadmos/

Примечание: Распознать текст можно во фрагменте (выделенном прямоугольнике) изображения или во всем изображении целиком.

В меню "Сервис" выберите "Оптическое распознавание символов". Откроется окно OCR для преобразования изображения в текст, который копируется в буфер обмена или сохраняется в файле.


Сортировка файлов в папке

В меню "Сервис" выберите "Сортировка файлов в папке". Появится подменю с вариантами "по имени", "по имени (естественный порядок)", "по дате", "по размеру файла" и "по расширению". Для каждого возможна сортировка в прямом и обратном порядке. И последний вариант - "не сортировать". Выберите нужный.

Естественный порядок сортировки по имени отличается интерпретацией чисел в именах файлов. При сортировке по имени File10.jpg будет перед File1.jpg. В естественном порядке File1.jpg будет перед File10.jpg.

Везде, где можно листать картинки клавишами "пробел" вперед и "забой" назад, например, в полноэкранном режиме или в миниатюрах, они сортируются выбранным способом.

Совет: В окне миниатюр есть дополнительные способы сортировки: по дате съемки в EXIF, по высоте или ширине изображения, сортировка вручную - перетаскиванием и т.п.


Создать фоновый рисунок рабочего стола

В меню "Сервис" выберите "Создать фоновый рисунок рабочего стола". Появится подменю с вариантами "По центру", "Замостить", "Растянуть" и "Вернуть предыдущий рисунок". Выберите нужный, чтобы сделать текущую картинку фоном рабочего стола Windows .

По центру - появится одна картинка в центре экрана.

Замостить - копии картинки заполнят весь экран (а значки будут поверх них).

Растянуть - одна картинка в центре экрана, но растянутая так, чтобы занять его целиком (непропорционально).

Растянуть пропорционально - одна картинка по размеру экрана, но она масштабируется с сохранением пропорций.

Вернуть предыдущий рисунок - на экран вернется прежняя картинка, которая была до этой операции.

IrfanView сохранит файл BMP с именем IrfanView_Wallpaper.bmp в папке настроек пользователя (Documents and settings\User\Application data\IrfanView\) и сделает его обоями.


Свернуть окно

В меню "Сервис" выберите "Свернуть окно", чтобы свернуть программу в панель задач Windows (кнопка "шеф идет" ;-) ).

Чтобы вернуть программу на экран, щелкните по кнопке IrfanView в панели задач.

Другой способ свернуть окно программы - щелкнуть по кнопке "свернуть" в верхнем правом углу ее окна. На ней изображен символ подчеркивания ( _ ).


Всегда поверх других окон

В меню "Сервис" выберите "Всегда поверх других окон".

Окно IrfanView всегда будет на экране поверх всех других открытых окон. Отключается это повторением той же команды.

Примечание: Эта команда запоминается и продолжает действовать после перезапуска IrfanView.


Строка состояния

Строка состояния отображает некоторую информацию о текущем изображении в нижней рамке главного окна. Подробнее ее можно увидеть в окне "Изображение à Свойства изображения".

Строка состояния включается в меню "Вид" командой "Строка состояния". Отключается повторением той же команды.

Можно задать текст, отображаемый в правом поле.

Если картинка (файл) отмечен (клавишей "X"), в конце правого поля отображается "(X)".


Заголовок окна

В заголовке главного окна программы отображаются некоторые сведения о текущем изображении.

Это:

· Имя открытого файла (полный путь или только имя)
· Координаты пиксела, значение цвета и номер в палитре - при щелчке по изображению
· Координаты, размер и пропорции выделенного прямоугольника - если есть выделение
· Размеры изображения в масштабе - при масштабировании

Заголовок окна включается в меню "Вид" командой "Заголовок окна". Отключается повторением той же команды.


Счетчик файлов

Находится на панели инструментов, показывает число изображений в текущей папке и номер текущего изображения. "1/5" означает, что открыто первое из пяти изображений в папке.

Для выбора нужного изображения введите число в окошко счетчика. Откроется картинка с заданным номером.

Для многостраничных изображений счетчик показывает номер текущей страницы и общее число страниц. "1/5" означает первую страницу из пяти.

Для входа в счетчик используйте мышь или клавиши Shift+T.

Введите текст и нажмите "Ввод" (Enter) для выполнения действия. Можно вводить:

· X или X/Y = открыть файл № X из текущей папки
· page X или page X/Y =открыть страницу № X многостраничного изображения
· Текст(шаблон): выбор файлов из текущей папки по шаблону.

Примеры:

*.jpg = выбрать(подсчитать) только JPG
cat*.jpg = выбрать(подсчитать) JPG, начинающиеся с "cat"
cat* = выбрать(подсчитать) все файлы, начинающиеся с "cat"

Использовав шаблон, нажмите F5 или U (update = обновить) для возврата к исходному счетчику (без отбора).


Полноэкранный режим

В меню "Вид" выберите "Полноэкранный режим". Изображение будет показано в центре пустого экрана на черном фоне. Листать картинки в текущей папке вперед можно клавишей "пробел" или правой кнопкой мыши, а назад - клавишей "забой" (backspace) или левой кнопкой мыши.

Для выхода из полноэкранного режима нажмите "Ввод" (Enter) или Esc. Это же можно сделать и щелчком левой кнопки мыши в верхнем левом или правом углу.

Текущий режим отображения в любой момент можно временно изменить клавишами "1", "2", "3", "4", "5" и "6".

Все параметры полноэкранного режима можно настроить в меню "Сервис à Настройки программы" в закладке "Полноэкранный режим/Слайдшоу".


Параметры оконного режима

Примечание: Действует только один из этих вариантов. Помните об этом, изменяя режим отображения, верните прежний в случае "проблем"!

Подгонять окно под размер изображения

Окно принимает размеры картинки. Это удобно для просмотра изображения 1:1, без масштабирования

Подгонять все изображения под размер окна

Картинка принимает размеры окна.

Уменьшать большие изображения до размера окна

Слишком большие картинки уменьшаются до размера, при котором они поместятся в окне целиком. Картинки, которые помещаются в окне, не изменяются.

Подгонять все изображения под ширину (высоту) окна

Масштаб картинки подгоняется под ширину (высоту) окна.

Подгонять изображения по меньшей стороне под размер окна

Масштаб картинки пропорционально изменяется так, чтобы меньшая её сторона соответствовала размеру окна.

Подгонять все изображения под размер рабочего стола

Размер окна и картинки подгоняется пропорционально под размер экрана.

Уменьшать большие изображения до размера рабочего стола (исходный режим)

Слишком большие картинки уменьшаются до размера, при котором они поместятся на экране целиком. Картинки, которые помещаются на экране, не изменяются.

Подгонять все изображения под ширину (высоту) рабочего стола

Размер окна и картинки подгоняется пропорционально под ширину (высоту) экрана.

Подгонять изображения по меньшей стороне под размер рабочего стола

Масштаб картинки пропорционально изменяется так, чтобы меньшая её сторона соответствовала размеру рабочего стола.

Не подгонять ничего

При показе новой картинки размер и положение окна не меняются.

Использовать ресэмплирование при подгонке

Улучшается качество отображения картинок, подгоняемых под размер окна или экрана.

Использовать ресэмплирование при изменении масштаба вручную

Улучшается качество отображения масштабируемых картинок.

Повышать резкость после ресэмплирования

При ресэмплировании картинка обычно несколько размывается. Для уменьшения размытия можно после ресэмплирования применить повышение резкости.

Центрировать изображение в окне

Изображение будет в либо центре окна, либо в его верхнем левом углу.


Следующий/предыдущий файл в папке

В меню "Вид" выберите "Следующий файл в папке" (или нажмите на одноименную кнопку панели инструментов). Откроется следующий файл (из поддерживаемых) в текущей папке.

Для перехода к следующему файлу можно использовать и клавишу "пробел". Если в окне с картинкой нет вертикальной полосы прокрутки (у его правого края), или если включена соответствующая настройка в меню "Обзор и редактирование", то перейти к следующему файлу можно также клавишей "Page Down" или вращением ролика мыши.

----

В меню "Вид" выберите "Предыдущий файл в папке" (или нажмите на одноименную кнопку панели инструментов). Откроется предыдущий файл (из поддерживаемых) в текущей папке.

Для перехода к предыдущему файлу можно использовать и клавишу "Backspace" ("эабой"). Если в окне с картинкой нет вертикальной полосы прокрутки (у его правого края), или если включена соответствующая настройка в меню "Обзор и редактирование", то перейти к предыдущему файлу можно также клавишей "Page Up" или вращением ролика мыши.


Первый/последний/случайный файл в папке

В меню "Вид" выберите "Первый файл в папке". Откроется первый файл (из поддерживаемых) в текущей папке.

В меню "Вид" выберите "Последний файл в папке". Откроется последний файл (из поддерживаемых) в текущей папке.

В меню "Вид" выберите "Случайный файл в папке". Откроется выбранный случайным образом файл (из поддерживаемых) в текущей папке.


Обновить экран

В меню "Вид" выберите "Обновить экран". Обновится изображение на экране.

Кроме того, будет перечитана текущая папка и обновлен счетчик файлов.

Если на изображении выделена область для редактирования, команда "Обновить экран" сбросит выделение.


Автоматический просмотр - старт/стоп

В меню "Вид" выберите "Автоматический просмотр - старт/стоп".

Будет запущен автоматический просмотр картинок из текущей папки в окне с интервалом, заданным для авто- слайдшоу.

Для остановки автоматического просмотра повторите команду.


Увеличить

Увеличить, Уменьшить

В меню "Вид" выберите "Увеличить" или "Уменьшить" (или нажмите на одноименную кнопку панели инструментов).

Размер изображения увеличится или уменьшится. Чтобы еще увеличить (уменьшить) размер, повторите команду.

Степень каждого увеличения (уменьшения) задается параметром "Шаг масштабирования" в меню "Сервис à Настройки программы" à закладка "Просмотр". Изначально шаг = 10% от предыдущего размера.

Примечание: Изменяется только вид изображения, но не его размер! Изменить размер можно через меню "Изображение à Изменить размер изображения".


Заблокировать масштаб

В меню "Вид" выберите "Заблокировать масштаб".

При включенной блокировке текущий масштаб запоминается и при смене просматриваемого файла не будет изменяться.

Эта настройка действует только до выхода из программы.

Для ее отключения повторите команду (или нажмите Shift + L).


Заблокировать точку прокрутки

В меню "Вид" выберите "Заблокировать точку прокрутки".

При включенной блокировке положение полос прокрутки (если они видны) при смене просматриваемого файла не будет сбрасываться.

Эта настройка действует только до выхода из программы.

Для её отключения повторите команду.


Исходный размер

В меню "Вид" выберите "Исходный размер".

Отменяется увеличение или уменьшение изображения, возвращается его исходный размер.


Просмотр в шестнадцатеричном режиме

В меню "Вид" выберите "Просмотр в шестнадцатеричном режиме".

Откроется окно с шестнадцатеричным представлением ("HEXView") текущего изображения.

В нем каждый байт открытого файла показан в шестнадцатеричном ("HEX") и текстовом ("ASCII") виде.

Это может быть полезно опытным пользователям.


Многостраничные изображения

В меню "Вид" выберите "Многостраничные изображения". Появится подменю из нескольких пунктов.

Эти пункты:

Примечание: Их можно выбрать только если открыт рисунок с несколькими страницами (некоторые файлы DCX,TIF,ICO,JPM,PDF).

Следующая страница

Выберите "Следующая страница" (или нажмите на одноименную кнопку панели инструментов). Будет показана следующая страница из текущего файла.

Предыдущая страница

Выберите "Предыдущая страница" (или нажмите на одноименную кнопку панели инструментов). Будет показана предыдущая страница из текущего файла.

Первая страница

Выберите "Первая страница". Будет показана первая страница из текущего файла.

Последняя страница

Выберите "Последняя страница". Будет показана последняя страница из текущего файла.

Открыть страницу № ...

Эта команда открывает окно для ввода номера страницы из текущего файла, которую нужно показать.

Показать миниатюры страниц ...

Эта команда открывает окно с миниатюрами-эскизами страниц. Выбранная страница открывается в главном окне двойным щелчком мыши или клавишами "пробел" или "ввод".

Здесь используются настройки эскизов из окна миниатюр. Для перехода в главное окно нажмите "TAB".

Автопоказ миниатюр страниц

Этой командой включается автоматический показ окна с миниатюрами страниц при открытии многостраничного изображения. Отключается повторением той же команды

Запустить анимацию

Выберите эту команду и задайте интервал времени между сменой страниц. Запустится анимация.

Остановить анимацию

Этой командой останавливается анимация.


Справка

В меню "?" выберите "Справка". Откроется этот файл справки (который вы сейчас читаете).

Первую версию этой справки написал Steve Clark, изменения для IrfanView 3.02 внес Irfan.

Версию 3.97 обновил Michael Ofner.

Очень очень благодарен Steve и Michael!

Версии 4.28 - 4.35 перевел Игорь Федоренко (igor_fedorenko@mail.ru) при поддержке Дмитрия Ерохина (erodim@mail.ru).


Установленные плагины

В меню "?" выберите "Установленные плагины".

Откроется окно со списком правильно установленных плагинов к IrfanView.

Прочитав список, нажмите "OK".


Благодарности

В меню "?" выберите "Пользователям от автора".

Увидите благодарности от меня, Irfan Skiljan, всем пользователям IrfanView.

Прочитав их, нажмите "OK".


Регистрация

В меню "?" выберите "Регистрация". Откроется окно для ввода имени пользователя и регистрационного кода.

Хотя IrfanView бесплатна для некоммерческого использования, лучше все-таки ее зарегистрировать. Небольшое вознаграждение поможет автору продолжать развивать эту программу, одну из лучших в Интернете.

Зарегистрировавшись, нажмите "OK".


Проверить наличие обновлений

В обозревателе Интернета откроется домашняя страница IrfanView со сведениями о текущей и о вашей версии программы.


Информация об использовании

В меню "?" выберите "Информация об использовании". Откроется окно с разъяснением, кому разрешено использовать IrfanView бесплатно, и куда отправлять оплату за регистрацию.

Здесь же указано, куда отправлять отчеты об ошибках и другие сообщения автору. Есть здесь и адрес сайта IrfanView.

А именно:

IrfanView БЕСПЛАТНА, но только для частного, некоммерческого использования (то есть дома).
IrfanView бесплатна в учебных (школах и университетах), лечебных учреждениях и гуманитарных организациях.
Я хочу продолжать работу над этой программой, поэтому Ваша регистрация или пожертвование поможет мне улучшить качество программы.
Всегда рад любым предложениям, отзывам и комментариям.
Если Вам понравилась эта программа, зарегистрируйтесь (пожертвуйте) через PayPal (по указанному ниже адресу) или прислав 10 долларов США или 10 евро (за личную лицензию, только наличными):
Irfan Skiljan
Postfach 48
2700 Wiener Neustadt
Austria, Europe
Коммерческие пользователи: уточните у меня по электронной почте цены и скидки.
Вы поддержите продолжение разработки, обеспечите себя новыми версиями IrfanView и получите регистрационный код. В случае глюков и проблем с любым из поддерживаемых форматов пишите по адресу:
irfanview@gmx.net
опишите проблему и сообщите свой обратный адрес.
IrfanView в Интернете:
Основной сайт: http://www.irfanview.com/
Зеркало: http://www.irfanview.net/

Прочитав это, нажмите "OK".


О программе

В меню "?" выберите "О программе" (или нажмите на одноименную кнопку панели инструментов).

Увидите номер версии IrfanView, адрес электронной почты автора и фото его живописного родного города (стоит взглянуть хотя бы на него).

Насмотревшись вдоволь, нажмите на кнопку "Click".


Связь с автором и обновление

Актуальную версию IrfanView можно скачать из Интернета:

http://www.irfanview.com

http://www.irfanview.net

http://www.irfanview.info

http://www.irfanview.at

или с

http://irfanview.tuwien.ac.at

Автору программы, Irfan Skiljan, можно написать по адресу:

irfanview@gmx.net

Если Вы хотите зарегистрировать программу у него (всего 12 долларов США или 10 евро)

отправьте платёж наличными на:

Irfan Skiljan

Postfach 48

2700 Wiener Neustadt

Austria, Europe

или сделайте пожертвование через PayPal (https://www.paypal.com) на почтовый адрес: irfanview@gmx.net

Большое спасибо!

Коммерческим пользователям: о ценах и скидках можно узнать, написав автору по электронной почте.


Glossary

Глоссарий

 В начало

A

ACR

AIF

ANI

AU

AVI

B

BMP

C

CAM

CLP

CPT

CUR

D

DAT

DCM

DCX

DIB

DJVU

DLL

E

EMF

EPS

EXE

F

FLC

FLI

FPX

FSH

G

G3

GIF

I

ICL

ICO

IFF

IMA

IMG

J

JP2

JPEG

JPEG2000

JPG

K

KDC

L

LBM

LDF

LWF

M

Mac PICT

MED

MID

MOV

MP3

MPEG

MPG

P

PBM

PCD

PCX

PGM

Photo CD

PNG

PPM

PSD

PSP

Q

QTIF

R

RAS

RealAudio

RGB

RLE

RMI

S

SFF

SFW

SGI

SND

SUN

SWF

T

TGA

TIF

TIFF

W

WAV

WBMP

WMF

X

XBM

XPM

А

альбомная ориентация

Б

буфер обмена

В

выделение

Г

галочка

Д

диалоговое окно

З

закладки

захват

И

изображение

К

картинка

книжная ориентация

М

миниатюра

минимизировать

О

окно

оттенки серого

П

панель задач

переключатель

пиксел

подменю

ползунок

провести

прогрессивный

прозрачный цвет

Р

развернуть

расширение

регулятор-ползунок

С

свернуть

Ф

фильтр

фильтры Filter Factory

Ц

цвет заливки

Ч

чересстрочный

Э

эскиз