От меня

Навигация: »Нет темы выше этого уровня«

От меня

 В начало раздела

Справка абсолютно не интересна для профессионалов (именно справка, а не сама утилита), и переведена мной, довольно давно, в целях собственного самообразования. Сейчас, просто, мне попались сайты, на которых за размещения собственных работ присваивают звания. А плох тот солдат, который не мечтает...

На этих сайтах можно абсолютно бесплатно скачать множество русифицированных программ и документации к ним. Вот ссылки на эти сайты:

Русские справки

Русификация программ, помощь и обучение

Справка, скорее предназначена для любителей поковыряться в компьютере.

Утилита Process Explorer, несмотря на небольшой размер, действительно очень мощное средство. Она может помочь понять внутренее устройство Windows, разобраться, какие процессы работают в системе, не смотря на то, что Вы не запускали ни одного приложения и даже обнаружить и уничтожить "жучка", подсаженного Вам начинающим вредителем. Чтобы разобраться с "вирусом", который создал профессионал, утилиты может быть и достаточно, а вот знаний... Здесь нужен уже уровень профессионалов, которые читать эту справку не будут.

Справка состоит из двух разделов:

Process Explorer, это практически построчный перевод родной справки.

От меня, В этом разделе, я как бы систематизировал информацию и добавил немножко от себя. Если точнее, то информацию почерпнутую из других источников. К сожалению я уже не могу сказать, где и какую. Просто говорю огромное спасибо тем, кто вдруг признает ее своей. На информацию, источник которой известен - добавлены ссылки. Основной источник - это книга "Внутреннее устройство Windows" авторов - М. Руссинович, Д. Соломон. Вообще, при изучении Windows, эта книга должна быть настольной и в печатном варианте, во первых удобней читать информацию, ну и... при чтении на сон грядущий, очень даже помогает засыпать.

Кроме того, я заметил, что даже на английском языке, одно и тоже понятие может иметь несколько терминов. Ну, а при переводе на русский - сколько переводчиков - столько и терминов. Как тут не вспомнить СССР, когда на все был свой Гост или, по крайней мере, стандарт. Например, paging files - это - файл подкачки; свопинг-файл; свопинговый файл; страничный файл. Потому добавлен раздел, далеко не полный, в котором описаны встречающиеся термины и другая дополнительная информация.

В Интернете можно найти несколько вариантов русификации утилиты, есть даже и мой собственный, но я рекомендую скачать, для использования вместе с этой справкой именно этот файл. Интерфейс этой локализации я использовал при окончательной подготовке справки.

При обнаружении грубых (и не очень) ошибок (не только и не столько орфографических), сообщите мне по адресу: nikolaj.kononoff@yandex.ru Я с благодарностью и с удовольствием исправлю.


Краткий обзор

Навигация: »Нет темы выше этого уровня«

Process Explorer

Все права © 1996-2010 Mark Russinovich

Sysinternals - www.sysinternals.com

Process Explorer это расширенная утилита служащая для управления запущенными в системе процессами, превосходящая по своим параметрам утилиту Windows - Диспетчер задач. Утилита отображает в своем окне подробную информацию о процессе, включая его иконку, командную строку, полный путь, статистику использования памяти, учетную запись пользователя, атрибуты безопасности, и прочее. Просматривая конкретный процесс, Вы можете просмотреть список DLL, которые были загружены этим процессом, или дескрипторы ресурсов операционной системы, используемых этим процессом. Опция поиск - предоставляет возможность поиска процесса использующего ресурс, такой как файл, каталог или Ключ реестра, или просмотреть список процессов, использующих ту или иную загруженную DLL.

Окно Process Explorer(а) состоит из двух под-окон. В верхнем окне отображается список активных, в настоящее время, процессов включая названия учетных записей, которым принадлежат эти процессы. В нижнем окне (его можно закрыть) отображается информация зависящая от режима в котором находится Process Explorer:

- если выбран режим дескрипторов (Handles), то будут отображены все открытые дескрипторы выбранного в верхнем окне процесса;

- если Process Explorer находится в режиме DLL, то будут отображены все загруженные процессом динамические библиотеки и отображенные в память файлы

Process Explorer имеет мощную опцию для осуществления поиска, которая быстро подскажет Вам, какие процессы используют тот или иной дескриптор или загруженную DLL. Уникальные возможности Process Explorer(а) позволяют решить различные проблемы связанные с версиями библиотек DLL и утечками дескрипторов, а также помогают лучше понять принципы работы ОС Windows и приложений. .

Вы можете скачать эквивалентные инструментальные средства для работы с командной строки с сайта Sysinternals.

Process Explorer не требует привилегий администратора и работает в системах Windows XP выше (включая IA64) и Windows Server 2003 и выше (включая IA64).


Главное окно

Навигация: Process Explorer >

Главное окно

Вид

Окно Process Explorer(а) по умолчанию состоит из двух под-окон: в верхнем под-окне всегда отображается список текущих процессов, а в нижнем - или отображается список DLL, загруженных в процесс, выбранный в верхнем под-окне, или список дескрипторов ресурсов операционной системы (файлы, Ключи реестра, объекты синхронизации), открытых выделенным в верхнем окне процессом; выбор режима просмотра определяет, какая информация отображается в нижнем окне. Для переключения режима просмотра используйте опцию меню Вид|Отображать в нижнем окне или соответствующий переключатель на панели инструментов, или используйте акселераторы - Ctrl+D (просмотр DLL) и Ctrl-H (Просмотр дескрипторов).

Если Вам нужно только наблюдать за работающими в вашей системе процессами, то Вы можете скрыть нижние под-окно, выбрав опцию меню Вид|Скрыть нижнее окно, или соответствующий переключатель на панели инструментов, или используйте акселератор - Ctrl+L, или перетащите разделитель окон к основанию окна Process Explorer(а). Снова открыть нижние под-окно, можно используя опцию меню Вид|Показывать нижние окно, акселератор - Ctrl+L или снова щелкнуть кнопку на панели инструментов.

Мини окна

Process Explorer содержит в верхней части основного окна панель инструментов, с расположенными на ней кнопками быстрого доступа и не больших графических окошек для графического отображения загрузки CPU, памяти, и, если операционная система - Windows 2000 или выше, то историю Ввода/Вывода (I/O).. Расположение этих графических окошек можно изменять относительно друг друга или перетащить таким образом, что каждое окошко будет находиться на отдельной строке. В графических окошках отображаются хронологии действий операционной системы, и перемещение указателя мыши по этим окошкам, вызывает отображение подсказки о отображаемом процессе. Например, в подсказке для окошка центрального процессора отображается процесс, потребляющий наибольшее время центрального процессора. Щелчок по любому из окошек откроет диалог Системной Информации.

Частота регенерации и подсветка различий

Настроить частоту, с которой Process Explorer обновляет свое окно, можно используя опцию меню Вид|Частота обновления. Можно обновить информацию отображенную в окне вручную, используя опцию меню Вид|Обновить, щелкнув по кнопке Обновить, расположенной на панели инструментов, или нажав клавишу F5. Некоторые проверки, такие как, является ли процесс частью Job объекта или использует .NET runtime, происходят только во время запуска процесса. Нажмите клавишу F5, чтобы Process Explorer перепроверил состояние всех процессов.

Process Explorer использует выделение различий, для наглядного отображения изменений произошедших в период между обновлениями. Элементы, включая процессы, DLL, и дескрипторы, которые были завершены или закрыты, отображаются красным цветом, а те, которые запустились, - зеленым. Если частота регенерации не приостановлена, то время выделения определяется установленным временем в диалоговом окне "Длительность подсветки различий". Которое можно вызвать используя опцию меню Параметры|Длительность выделения различий, по умолчанию - это время равно 1 секунде. В случае, если автоматическое обновление приостановлено, то время подсветки различий будет зависеть от частоты ручного обновления.

Прозрачность Окна

Можно изменить прозрачность окна Process Explorer(а) (в системах поддерживающих эту функцию), выбрав процент прозрачности окна из под-меню Вид|Прозрачность.

Сохранение

Если Вы используете опцию меню Файл|Сохранить то Process Explorer сохранит контент верхнего окна, и нижнего, если оно открыто, в текстовом файле; при форматировании файла, для разграничения колонок, будет использоваться табуляция.

Выключение или выход из системы

Опция меню Файл|Завершение работы позволяет выключить, перезагрузить, заблокировать (lock) или выйти из системы. Меню предоставляет возможность переключить компьютер в ждущий или в спящий режим (если система поддерживает эти функции).

Выполнить

Используя опцию меню Файл|Выполнить, можно запустить другое приложение, вызвав стандартный диалог Windows - Запуск Программы.

Runas

Это вариант команды Выполнить; позволяет вводить дополнительные параметры пользователя для запуска приложения (credentials - мандат (учетная запись с параметрами доступа пользователя, сформированными после его успешной аутентификации)). Process Explorer предоставляет те же самые функциональные возможности Windows, что и команда Windows Runas. Опция меню Runas не доступна в системах Windows 9x.

Запустить с ограничениями пользователя

Это вариант команды Выполнить, запускает приложение, которое Вы выберете находясь в той же учетной записи из которой вы запустили Process Explorer, но без привилегий администратора. Эта опция защищает Вашу систему от приложений, таких как Internet Explorer, которые могут подвергнуться угрозе, получая недостоверные данные.


Столбцы и Набор столбцов

Навигация: Process Explorer >

Столбцы и Набор столбцов

Выбор столбцов

Тип информации отображаемой в верхнем окне Process Explorer(а) может быть полностью перестроен. Можно переупорядочить столбцы, перетащив их в новую позицию. Определить, какие столбцы данных будут отображаться в верхнем окне и в каждой вкладке нижнего окна, а также отображаемую информацию в строке состояния, можно, выбрав опцию меню Вид|Выбрать столбцы или щелкнув правой кнопкой мыши по заголовку столбца и выбрать опцию контекстного меню Выбор столбцов. В результате чего откроется окно редактирования столбцов, в котором Вы и можете определить какие именно столбцы будут отображаться в окнах Process Explorer(а), и какая информация будет отображаться в строке состояния.

Набор столбцов

Вы можете сохранить конфигурацию столбцов и связанные с ней параметры настройки отображения, выбрав опцию Вид|Сохранить набор столбцов. Process Explorer попросит Вас ввести имя набора столбцов. Вы можете загрузить сохраненный набор столбцов, выбрав опцию меню Вид|Загрузить набор столбцов или использовать соответствующую комбинацию клавиш. Чтобы переупорядочить или переименовать существующие наборы столбца используйте диалог "Упорядочение набора столбцов", вызвав его при помощи опции меню Вид|Упорядочить наборы столбцов.


Общие параметры

Навигация: Process Explorer >

Параметры

Использование Командной строки:

Process Explorer имеет две опции изменяющие его поведение:

/e | В случае если система была запущена без прав администратора, будет предложено перезапустить систему для повышения уровня UAC (контроля учетных записей).
/s:<pid> | Выбор процесса, имеющего указанный идентификатор процесса (ID (pid) ) после старта.
/t | Запускать утилиту Process Explorer свернутой в трей.
/p:[r|h|n|l] | Установка приоритета Process Explorer(а): Реальное время (realtime) - r, Высокий (high) - h, Нормальный (normal) n или Низкий (low) - l.

Поверх остальных окон:

Выберите эту опцию, чтобы окно Process Explorer(а) всегда было поверх других открытых окон.

Заменить диспетчер задач Windows:

Выберете опцию меню Параметры|Заменить диспетчер задач, и Process Explorer будет запускаться вместо стандартного Диспетчера задач Windows. Помните, что это глобальная настройка и затронет всех пользователей этого компьютера, вызывающих Диспетчер Задач. После замены Диспетчера задач, пункт меню изменится на Восстановить диспетчер задач Windows, и если выбрать эту опцию, то будет восстановлен стандартный Диспетчер задач Windows.

Сворачивать в область уведомлений:

Выберете эту опцию, и при минимизации, Process Explorer будет работать в трее, отображая текущую загруженность процессора. Если использование центрального процессора составит:

§менее 70%, то верхняя часть графика (граница графика) будет зеленого цвета;

§от 70% до 90% - желтого;

§если выше 90% - красного.

График использования CPU обновляется с частотой, определенной в меню Вид|Частота обновления. Если Вы желаете запустить Process Explorer в свернутом в трей виде, то запустите его с командной строки с параметром /t. Щелчок по иконке в трее, восстановит окно Process Explorer(а).

Только одна копия программы:

Выберете эту опцию меню, чтобы Process Explorer запускался в единственном экземпляре.

Подтверждать уничтожение:

Снимите галочку рядом с этой опцией, если не желаете, чтобы Process Explorer требовал от Вас подтверждения перед завершением процесса, который вы решили "убить".

Значки в области уведомлений:

эта опция переключает график, отображенный в иконке Process Explorer(а) находящейся в трее, между стандартным представлением графика текущего использования центрального процессора и миниатюрной версией графика хронологии центрального процессора.

Проверять цифровую подпись:

Если эта опция включена, то будет осуществляться верификация процесса, и при просмотре свойства процесса в диалоговом окне "Свойства процесса", рядом с полем имени компании будет добавлено слово "Проверен". Что означает, что файл имеет числовую подпись, и числится в центре сертификации, как требующий доверия. В случае, если эта числовая подпись не соответствует требованиям центра сертификации, то будет добавлен тест "Не удалось проверить". Для увеличения производительности отключите эту опцию.

Настройка символов:

для Windows NT и выше, если Вы хотите, чтобы Process Explorer мог сопоставить (resolve) адреса со стартовым адресом потока, и отобразить его в символьном виде на вкладке потоки, диалогового окна свойства процесса, и в окне стека потока, то Вам следует скачать пакет Debugging Tools for Windows (Средства отладки для Windows) с веб-сайта Microsoft и установить его в каталог по умолчанию.

Откройте диалоговое окно Настройка символов и в поле Путь к файлу dbghelp.dll, введите путь к библиотеке dbghelp.dll, находящейся в каталоге (Debugging Tools), а в поле Путь к символам введите адрес сервера символов по требованию, для скачивания символов с сервера на ваш жесткий диск.. Например, чтобы скачать символы в директорию c:\symbols - введите следующую строку:

srv*c:\symbols*http://msdl.microsoft.com/download/symbols

Длительность подсветки различий:

в этом диалоге можно определить продолжительность времени, подсветки отображения новых процессов зеленым цветом и, закрытых - красным. По умолчанию - это значение равно одной секунде. Вы можете изменить цвета подсветки, подбирая их в диалоговом окне Выбор цвета открыв его опцией "Настройка цветов" из меню Параметры.


Информация о системе

Навигация: Process Explorer >

Показать/Скрыть скрытый текст

Информация о системе

В Windows NT и выше опция Информация о системе находится в меню Вид, и ее выбор, также, как и нажатие сочетания клавиш Ctrl+I, вызовет открытие диалогового окна, в котором отображается системная информация, такая же, как и на вкладке - Быстродействие, стандартного диспетчера задач Windows. Информация, отображаемая в этом окне, включает в себя количество выделенной и доступной виртуальной и физической памяти, так же выгружаемой и не выгружаемой подкачиваемой и неподкачиваемой памяти использованной ядром.

Графически отображается хронология использования центрального процессора системы и использование фиксированной той, что на жестком диске виртуальной выгружаемой памяти, а в системах Windows 2000 и выше, графически отображается пропускная способность ввода - вывода и история пропускной способности производительность ввода - вывода. На графике использования центрального процессора, красным цветом отображается использование центрального процессора в привилегированном режиме, а зеленым - сумма выполнения привилегированного режима и непривилегированного режима. Если выгружаемая память Диспетчер задач Windows в системах Windows 2000 и выше обозначает ее, как "Файл подкачки (PF Usage)", а в системах NT 4, как "Используемая (Выделенная) память (Mem Usage)", достигнет предела выгружаемой памяти, то работа приложений и системы становится нестабильной. Предел выгружаемой (Выделяемой) (Commit Limit) памяти - представляет собой сумму большей части физической памяти и файлов подкачки. На графике ввода-вывода ( I/O ) синим цветом отображается полный трафик ввода - вывода, являющейся суммой всего процесса ввода - вывода (чтения и записи), измеренного за время между обновлениями Process Explorer(а), а розовым цветом - отображается только трафик записи.

При перемещении указателя мыши по окошку отображения графика использования Ц.П., отобразится всплывающая подсказка, с информацией о использовании центрального процессора, имени процесса, потребляющего наибольшее время Ц.П. и время, в которое было произведено измерение. Такая же информация отображается в подсказке к графику, отображающего хронологию использования файла подкачки. В подсказке, всплывающей при перемещении указателя мыши по графическому отображению хронологии трафика ввода вывода, отображается процесс, потребляющий большую часть трафика, время измерения, и количество переданных в обе стороны байт (килобайт) данных. Данные в подсказке изменяются по мере перемещения графика под указателем мыши или перемещения указателя мыши по графику, но, удерживая нажатой левую кнопку мыши, Вы можете приостановить обновление данных в подсказке.

В системах, с несколькими центральными процессорами, в окне отображения системной информации, активен переключатель Свой график для каждого ЦП. При включенном переключателе график отображается для каждого процессора отдельно. Если в системе установлены процессоры многопоточной обработки (SMT), совместно использующие одно и тоже ядро или процессоры с архитектурой неоднородного доступа к памяти (NUMA), то в подсказке отображается этот процессор и количество узлов или ядер. Обратите внимание на то, что в подсказке для графика использования процессора, отображается имя процесса потребляющего наибольшее время всех процессоров, имеющихся в системе, а не процесс, использующий наибольшее время конкретного процессора.


Просмотр процессов

Навигация: Process Explorer >

Сортировка и дерево процессов

По умолчанию, Process Explorer отображает процессы в виде дерева системных процессов. Дерево процессов отражает родительско-дочерние отношения между процессами, дочернии процессы отображаются ниже родительских с отступом вправо. Процессы, выровненные по левому краю - это сироты (висящие) (orphans), их родители завершили работу и закрылись. Для изменения порядка сортировки, просто щелкните по заголовку столбца, и процессы будут отсортированы по содержимому выбранного столбца. Чтобы вернуться к сортировке по дереву процессов нужно выбрать пункт меню Вид|Показывать дерево процессов, или щелкнуть одноименную кнопку на панели инструментов, или нажать комбинацию клавиш - Ctrl+T.


Прерывания и DPC

Навигация: Process Explorer > The Process View >

Прерывания и DPC

В системах, основанных на Windows NT, Process Explorer отображает два искусственных процесса: Прерывания и отложенные вызовы процедуры (DPCs). Эти процессы отражают количество времени, которое система тратит на обслуживание аппаратных прерываний и на отложенные вызовы процедуры (DPC). Большое потребление времени центрального процессора этими процессами, может указывать на аппаратную проблему или ошибку драйвера устройства. Для отображения общего количества прерываний и отложенных вызовов процедур (DPC), выполненных с начала загрузки системы, следует добавить столбец - переключение контекста. Другой, иногда полезный показатель, это количество прерываний и DPCs, сгенерированных в интервале между обновлениями, для отображения которого нужно добавить столбец - Δ переключений контекста.


Поиск процесса окна запущенного приложения

Навигация: Process Explorer > The Process View >

Поиск процесса окна запущенного приложения

Можно найти процесс, который принадлежит окну запущенного приложения, перетащив при помощи мыши кнопку, расположенную на панели инструментов Process Explorer(а), в окно открытого приложения. Process Explorer выделит соответствующий процесс в окне просмотра процессов.


Параметры

Навигация: Process Explorer > The Process View >

Опции отображения Процесса

Некоторые опции меню Параметры и Вид касаются методов отображения процессов:

Настройка цветов: Выберете эту опцию из меню Параметры: для открытия диалогового окна, в котором Вы можете определить цвет выделения процессов и DLL.

Подсветка Служб : В системах Windows NT и выше Process Explorer, выделяет цветом запущенные службы Win32. На вкладке Службы диалогового окна Свойства отображаются службы запущенные этим процессом.

Подсветка Заданий: В системах Windows 2000 и выше, Process Explorer выделяет цветом процессы, которые являются частью Задания Win32. Задания собирают в группу процессы, так, чтобы ими можно было управлять как отдельным элементом и, например, использовать командой Runas. На вкладке Задания диалогового окна Свойства, можно увидеть задания связанные с этим процессом.

Подсветка процессов .NET: эта опция активна в системах основанных на Windows NT, в которых установлено приложение .NET Framework. Если опция включена, то управляемые приложения (приложения использующие .NET Framework) подсвечиваются цветом процесса .NET.

Подсветка собственных процессов: В системах Windows NT и выше, Process Explorer выделяет цветом собственные процессы. Это те процессы, которые запущены от имени того же пользователя, от имени которого запущен и Process Explorer.

Подсветка сжатых образов: Вредоносное ПО, включая вирусы, программ шпионов, и бесплатные программные продукты с размещенной в них рекламой часто сохраняется на диске в упакованной зашифрованной форме, для сокрытия своего кода от антишпионящего ПО и антивируса.

Отображать точную загрузку ЦП: Если включить эту опцию, то Process Explorer будет подсчитывать процент использования центрального процессора с точностью до сотой процента. Эту опцию следует включить, для подсчета процента использования Ц.П. процессом, который работает в фоновом режиме, и при выключенной опции - может округляться до нуля процентов.

Выделять новые процессы: Если эта опция включена, то Process Explorer будет перелистовать (scrolls) содержимое окна отображения процессов, так, чтобы новый процесс был виден в окне.


Меню "Процесс"

Навигация: Process Explorer > The Process View >

Меню "Процесс"

Если в окне процессов выделить процесс, то станет доступным меню Процесс.

Контекстное меню, содержащие такие же опции, можно вызвать, щелкнув правой кнопкой мыши по выделенному процессу.

Ниже, рассмотрим возможности опций этого меню:

На передний план: Выберете эту опцию, что бы перенести соответствующее процессу окно на передний план (передать окну фокус ввода).

Установить приоритет: При помощи этой опции вы можете изменить базовый приоритет процесса. При изменении базового приоритета процесса, система корректирует приоритеты потоков в пределах процесса так, чтобы их относительный приоритет не изменился, относительно нового базового приоритета.

Задать соответствие: в системах со множественными центральными процессорами эта опция меню позволяет Вам связывать потоки процесса к конкретным центральным процессором. (Affinity - родственность (процессов или под процессов в многопроцессорной системе)).

Отладка : Запускает отладчик зарегистрированный в реестре в разделе HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\AeDebug с загруженным в него выделенным процессом, в качестве параметра командной строки.

Запустить Depends: Если Process Explorer найдет, установленную на Вашем компьютере утилиту Dependency Walker, то запустит ее, с выбранным процессом в качестве параметра (см. http://www.dependencywalker.com). Инструмент Dependency Walker показывает статистику зависимости DLL.

Завершить процесс: эта опция прерывает исполнение процесса. Учтите, что процесс завершенный при помощи этой опции, не знает об этом, и поэтому не сохраняет свои данные.

Завершить дерево процессов: если окно отображения процесса находится в режиме сортировки процессов (если нет - нажмите соответствующую кнопку на панели инструментов, или CTRL+I), то доступна опция меню - Завершить дерево процессов, при помощи которой можно уничтожить процесс и всех его потомков.

Приостановить: если Вы хотите временно приостановить процесс, для предоставления ресурсов(таких как Ц.П, или жесткий диск) другим процессам, то воспользуйтесь этой опцией. Приостановленные процессы отображаются темным серым цветом. Для возобновления приостановленного процесса, используйте опцию - Возобновить (Resume).

Перезапустить: эта опция закроет выделенный процесс, и запустит его снова, используя те же параметры командной строки, что и при запуске образа Следует учитывать, что вновь запущенный процесс может оказаться неработоспособным или вести себя не адекватно, если оригинальный процесс работал в другой учетной записи пользователя или имел другую среду.

Свойства: выбор этой опции, вызовет открытие диалогового окна - "Свойства", в котором будет отображена подробная информация о процессе.

Найти в интернете: выбор этой опции, приведет к запуску Интернет-браузера, и инициализации поиска в Интернете имени выбранного процесса.


Свойства процесса

Навигация: Process Explorer > The Process View >

Показать/Скрыть скрытый текст

Свойства процесса

Для просмотра дополнительной информации о процессе следует дважды щелкнуть на нему мышью или, предварительно выделив его, выбрать опцию меню Процесс|Свойства или щелкнуть кнопку на панели инструментов. В системах Windows 9x в диалоговом окне отобразится информация о версии образа процесса, полного пути к файлу образа процесса, и командной строке, от которой обычно запускается этот процесс. В Windows NT и выше, диалоговое окно содержит несколько вкладок, описанных ниже. Все динамические данные, такие как информация о производительности, обновляются по мере определенного в Process Explorer(е) времени обновления. Можно вручную обновить динамическую информацию, нажав клавишу F5.

Объект:

(На самом деле Image - Образ) На этой вкладке отображается информация о версии, извлеченной из образа файла процесса, полного пути к файлу образа и командной строки, от которой запускается процесс. Здесь также указывается текущий каталог процесса, учетная запись пользователя, в которой запущен процесс, имя родительского процесса, и время, в которое был запущен процесс на выполнение.

Process Explorer проверяет, имеет ли образ цифровую подпись, и если компьютер ей доверяет то отмечает образ процесса как "Доверенный (Trusted)" (подписанный (signed)), если нет цифровой подписи, то - "Без Подписи (Unsigned)", или, если подпись есть, но она не проверена, то - "Не проверена (Not Verified)". Можно нажать кнопку Проверить для того, чтобы Process Explorer проверил сигнатуру образов, которые ранее не были проверены. Учтите, что операция проверки может заставить Process Explorer войти в контакт с вебсайтами, для верификации числовой подписи. Смотри опцию Проверить цифровую подпись.

Введите комментарий для процесса в поле Комментарий. Комментарии отображаются в окне просмотра процессов в столбце Комментарий), если вы его выбрали для отображения. Комментарии добавляются ко всем процессам, имеющим одинаковый путь, и запоминаются от выполнения до выполнения.

В системах, которые поддерживают Защиту выполнения данных (Data Execution Protection (DEP)), Process Explorer отображает состояние DEP выбранного процесса "Включена (on)" или "Отключена (off)". Программное обеспечение DEP в настоящее время поддерживается системой Windows XP SP2 и выше в 32-разрядных x86, а аппаратное DEP доступно только в 64-разрядных версиях Windows. Можно увидеть статус DEP, добавив столбец Статус DEP в окно просмотра процессов.

Вредоносное П.О., включая вирусы, программы шпионы, и бесплатные программные продукты с размещенной в них рекламой, часто сохраняется в упакованной зашифрованной (packed encrypted) форме на диске, пытаясь скрыть свой код от анти шпионящего ПО и антивирусов. Process Explorer использует метод эвристики, чтобы определить, упакован ли образ, и если это так, то выше поля отображения полного пути (full path) отображает следующий текст -"(Образ вероятно упакован)".

Производительность :

На этой странице отображаются данные о производительности, такие как использование физической и виртуальной памяти, и использование центрального процессора. Эти данные обновляются с тем же периодом, что и в основном окне.

График Производительности:

Хронология использования процессом Ц.П. и хронология распределения неразделяемых байт память формально недоступная другим процессам. По сути это любая память, кроме проекций файлов (PE образов, файлов данных, разделяемых областей с подкачкой из страничного файла), в подавляющем большинстве приложений это куча/кучи процесса. Поэтому этот показатель важен для мониторинга утечек (private bytes allocation) отображается так же, как и другие подобные графики Process Explorer(а). На графике использования центрального процессора, красным цветом отображается использование центрального процессора в привилегированном режиме, а зеленым - сумма выполнения привилегированного режима и непривилегированного режима. Неразделяемые байты - это количество неразделяемой (выделенной только этому процессу) виртуальной памяти, повышение которого, может означать утечку памяти. Примечание, если Process Explorer свернут в трей, то хронология информации о системе обновляется, а эти графики - нет. График хронологии выделения неразделяемых байт масштабирован относительно пикового количества выделенных неразделяемых байт; если пик растет, то график повторно вычисляет свой масштаб. На графике ввода-вывода ( I/O ) синим цветом отображается полный трафик ввода - вывода, являющейся суммой всех процессов ввода - вывода (чтения и записи), измеренного за время между обновлениями Process Explorer(а), а розовым цветом - отображается только трафик записи. График I/O расположен рядом с трафиком пикового использования I/O, который процесс сгенерировал за время мониторинга

Перемещение указателя мыши по графику, вызывает появление подсказки с информацией, отображаемой этим графиком, во время, соответствующему точке нахождения указателя мыши.

Потоки:

На этой вкладке отображается список потоков, запущенных в этом процессе. В списке потоков отображается информация о начальном адресе, которая обеспечивается механизмом Windows symbol engine. Если Вам нужно знать точные имена начальных адресов, то следуйте указаниям по конфигурированию символов.

Кнопка Модуль расположенная на вкладке "потоки", открывает стандартное диалоговое окно проводника Windows - "Свойство файла", в котором указан начальный адрес выделенного потока. Кнопка Стек, открывает окошко, с отображенным в нем текущим стеком выбранного потока. Информация, отображаемая в окне стека, ненадежна, если файлы символов не доступны для процессов и DLL, на которые указаны ссылки в окне стека.

Кнопка Завершить, используется для завершения потока. Учтите, что поток завершится аварийно, и это может вызвать неполадки в работе всего процесса.

Кнопка Приостановить, используется для приостановки потока. Учтите, эта операция может привести к прекращению работы процесса.

TCP/IP:

На этой странице отображаются все открытые TCP и UDP принадлежащие этому процессу..

В системах XP SP2 и выше, на этой странице есть кнопка Стек, при нажатии на которую открывается диалоговое окно, в котором отображается стек потока, открывшего выделенную конечную точку (endpoint) открытую в настоящее время. Это нужно для идентификации назначения (цели)(purpose) конечных точек в системном процессе и в процессе Svchost, потому, что стек будет включать имя драйвера или сервиса ответственного за эту конечную точку.

Безопасность:

На этой странице Process Explorer отображает список групп и привилегий. Недоступные привилегии отображаются серым цветом. Нажатие на кнопку "Разрешения" вызовет диалоговое окно "Разрешения", в котором отображены разрешения для этого процесса.

Задание:

Эта вкладка присутствует только для процессов, которые являются частью Задания Win32. На странице отображается список процессов, которые являются частью этого задания.

.NET Assemblies:

Эта вкладка присутствует в системах Windows Vista и выше, и только для процессов, которыми управляют приложения использующие .NET Framework, данные на странице отображаются, только, если Process Explorer запущен от имени администратора. Загруженные AppDomains и assemblies, отображаются в древовидной структуре.

.NET Performance:

Эта вкладка присутствует только для процессов, которыми управляют приложения использующие .NET Framework. The AppDomains present in the process show, as well the available .NET performance counter objects. Select a .NET performance object to see the values of the object's counters. The counters update at the currently selected refresh interval and you can type F5 to manually refresh.

Службы:

Эта страница присутствует только для процессов, запускающих службы Win32, и на ней отображается список служб, работающих в пределах этого процесса. Process Explorer показывает внутренние и отображаемое имя службы, и в системах Windows 2000 и выше, если доступно, то отображает и описание службы. Нажатие на кнопку "Разрешения" вызовет диалоговое окно "Разрешения", в котором отображены разрешения для этой службы.

Переменные среды:

На этой странице отображаются Переменные среды (Окружения), связанные с этим процессом.

Строки:

На этой странице отображаются все пригодные для печати строки (имеющие хотя бы три символа). Строки из образа, считываются из файла образа процесса расположенного на диске, тогда как строки из Памяти, считываются из отображения процесса в оперативной памяти. Строки из образа и памяти могут отличаться друг от друга, так как в образе они могут быть упакованы или зашифрованы, а при загрузке файла в оперативную память, он распаковывается и дешифруется.


Просмотр DLL

Навигация: Process Explorer >

Просмотр DLL

Меню "DLL"

В окне просмотра DLL отображаются образа файлов, DLL, и файлов данных, отображенных в адресное пространство выбранного процесса. Если Вы, при выделенном процессе в окне просмотра DLL, щелкните по кнопке Свойства расположенную на панели инструментов, или выберете одноименную опцию из меню DLL, то Process Explorer откроет диалоговое окно - Свойства DLL, содержащее две вкладки:

Объект:

На этой странице отображается информация о версии образа файла, и полного пути к нему.

Process Explorer проверяет, имеет ли образ цифровую подпись, и если компьютер ей доверяет то отмечает образ процесса как "Доверенный (Trusted)" (подписанный (signed)), если нет цифровой подписи, то - "Без Подписи (Unsigned)", или, если подпись есть, но она не проверена, то - "Не проверена (Not Verified)". Можно нажать кнопку Проверить для того, чтобы Process Explorer проверил сигнатуру образов, которые ранее не были проверены. Учтите, что операция проверки может заставить Process Explorer войти в контакт с вебсайтами, для верификации числовой подписи. Смотри опцию Проверить цифровую подпись.

Вредоносное П.О., включая вирусы, программы шпионы, и бесплатные программные продукты с размещенной в них рекламой, часто сохраняется в упакованной зашифрованной (packed encrypted) форме на диске, пытаясь скрыть свой код от анти шпионящего ПО и антивирусов. Process Explorer использует метод эвристики, чтобы определить, упакован ли образ, и если это так, то выше поля отображения полного пути (full path) отображает следующий текст: "(Образ вероятно упакован)".

Строки:

На этой странице отображаются все пригодные для печати строки (имеющие хотя бы три символа). Строки из образа, считываются из файла образа процесса расположенного на диске, тогда как строки из Памяти, считываются из отображения процесса в оперативной памяти. Строки из образа и памяти могут отличаться друг от друга, так как в образе они могут быть упакованы или зашифрованы, а при загрузке файла в оперативную память, он распаковывается и дешифруется.

Подсветка перемещенных DLL

Если включить подсветку Перемещенных DLL в диалоговом окне, вызываемом из меню Опции|Настройка цветов то библиотеки, загруженные системой не по их базовому адресу, подсветятся желтым цветом. DLL, которые не могут быть загружены по их базовым адресам (потому, что другие файлы уже были отображены по этим адресам), перемещаются загрузчиком на другой адрес.

Поиск в Интернете

Выбор этой опции, приведет к запуску Интернет-браузера и инициализации поиска в Интернете имени выбранной DLL.


Просмотр дескрипторов

Навигация: Process Explorer >

Просмотр дескрипторов

Меню "Дескриптор"

Меню "Дескриптор" и, вызываемое щелчком правой кнопки мыши контекстное меню "Дескриптор", имеет две опции:

Закрыть дескриптор: выберите эту опцию, что бы закрыть Дескриптор. При этом Вы рискуете: потому, что процесс, которому принадлежит дескриптор, не знает о том, что его дескриптор был закрыт, что может привести к аварийному отказу работы приложения или к нарушению целостности данных; закрытие дескриптора в Системном процессе может привести к сбою системы.

Свойства: При выборе этой опции, Process Explorer откроет диалоговое окно "Свойства", в котором отображено общее количество дескрипторов, открытых для объекта, как ссылок ядра на объект (as well as kernel references to the object). Здесь также отображается информация, определенная для типа рассматриваемого Вами объекта. Например, когда Вы просматриваете свойства объекта типа mutant, Process Explorer сообщит, захвачен mutant или нет, и если да, то каким потоком.

Безопасность На этой вкладке диалогового окна "Свойства" отображается справочная информация по обеспечению защиты выделенного дескриптора.

Показывать безымянные дескрипторы

По умолчанию, Process Explorer отображает дескрипторы только для объектов имеющих имена. Выберете опцию Показывать безымянные дескрипторы из меню Вид , чтобы Process Explorer отображал все дескрипторы открытые выбранным процессом, и, в том числе, дескрипторы для неименованных объектов. Учтите, что Process Explorer требует значительно больше ресурсов центрального процессора, если включена эта опция.


Меню пользователи

Навигация: Process Explorer >

Меню "Пользователи"

В системах, включающих в себя службу терминалов (Terminal Services), в Process Explorer доступно меню Пользователи, в котором перечисляются подключенные в настоящее время сеансы. Process Explorer создает пункт меню для каждого сеанса, в которое включен сам сеанс, идентификатор сеанса и пользователя, зарегистрированного в сеансе. Каждый пункт меню имеет подменю, с опциями - подключить, выйти из системы, и отправить сообщение пользователю сеанса. Кроме того, пункт подменю Свойства открывает диалоговое окно, в котором отображается подробная информация о сеансе, включая адрес IP и имя клиента.

Информационные наполнения меню Пользователи обновляется при каждом его открытии.


Поиск

Навигация: Process Explorer >

Поиск

Одной из проблем, которую Process Explorer легко решает, является вопрос: какой файл запустил этот процесс, или какие процессы используют конкретную DLL?

Вы можете найти дескриптор или DLL, выбрав опцию меню Найти| Найти Дескриптор или DLL или используя сочетание клавиш - Ctrl+F. Поиск не чувствителен к регистру, и позволяет найти среди загруженных дескрипторов или DLL нужную, введя их имя в строку поиска. Таким образом, чтобы найти процесс или процессы содержащиеся в открытом файле С:\directory\Нужный_Файл.txt достаточно ввести просто - "Нужный_Файл".

В диалоговом окне "Поиск" будет отображен результат поиска. Щелчок по строке в списке результатов поиска, выделит найденный процесс, DLL или дескриптор в окнах Process Explorer(а).


Сообщение об ошибках

Навигация: Process Explorer >

Сообщение об ошибках

Если во время работы с Process Explorer Вы обнаружили ошибку, то посетите форум Process Explorer Sysinternals и посмотрите, нет ли там готового решения проблемы, и, если нет, то сообщите об этой ошибке:

Sysinternals Process Explorer Forum


Д.П.

Навигация: От меня >

От меня

 В начало раздела

Очень грубо:

При запуске файла на выполнение, система создает в памяти образ файла. Затем создает процесс, делит его на потоки и запускает их. Так как, потоков много, а процессоров мало, потоки выполняются поочередно, с учетом их готовности, приоритета и желания системы. Это переключение и называется - переключение контекста. Памяти тоже всегда нехватает. Система создает для каждого процесса виртуальную память, которая (для каждого процесса) может превышать физическую (установленную), делит ее на страницы и сбрасывает, редко используемые страницы на жесткий диск, потом, по мере необходимости, подкачивает их обратно, отсюда и термин - файл подкачки.

Процесс (Process) - Хотя на первый взгляд кажется, что программа и процесс — понятия практически одинаковые, они фундаментально отличаются друг от друга. Программа представляет собой статический набор команд, а процесс — это контейнер для набора ресурсов, используемых при выполнении экземпляра программы. Ha самом высоком уровне абстракции процесс в Windows включает следующее:

• закрытое виртуальное адресное пространство — диапазон адресов виртуальной памяти, которым может пользоваться процесс;

• исполняемую программу — начальный код и данные, проецируемые на виртуальное адресное пространство процесса;

• список открытых описателей (handles) различных системных ресурсов — семафоров, коммуникационных портов, файлов и других объектов, доступных всем потокам в данном процессе;

• контекст защиты (security context), называемый маркером доступа (access token) и идентифицирующий пользователя, группы безопасности и привилегии, сопоставленные с процессом;

• уникальный идентификатор процесса (во внутрисистемной терминологии называемый идентификатором клиента);

• минимум один поток.

Каждый процесс также указывает на свой родительский процесс (процесс-создатель). Однако, если родитель существует, эта информация не обновляется. Поэтому есть вероятность, что некий процесс указывает на уже несуществующего родителя. Это не создает никакой проблемы, поскольку никто не полагается на наличие такой информации.

Поток (thread) — некая сущность внутри процесса, получающая процессорное время для выполнения. Без потока программа процесса не может выполняться. Поток включает следующие наиболее важные элементы:

• содержимое набора регистров процессора, отражающих состояние процессора;

• два стека, один из которых используется потоком при выполнении в режиме ядра, а другой — в пользовательском режиме;

• закрытую область памяти, называемую локальной памятью потока (thread-local storage, TLS) и используемую подсистемами, библиотеками исполняющих систем (run-time libraries) и DLL;

• уникальный идентификатор потока (во внутрисистемной терминологии также называемый идентификатором клиента: идентификаторы процессов и потоков генерируются из одного пространства имен и никогда не перекрываются);

• иногда потоки обладают своим контекстом защиты, который обычно используется многопоточными серверными приложениями, подменяющими контекст защиты обслуживаемых клиентов.

Переменные регистры, стеки и локальные области памяти называются контекстом потока. Поскольку эта информация различна на каждой аппаратной платформе, на которой может работать Windows, соответствующая структура данных специфична для конкретной платформы.

Предотвращение выполнения данных - (Data execution prevention, DEP) представляет собой совокупность программных и аппаратных решений для выполнения дополнительных проверок памяти, защищающих от выполнения вредоносного кода.

Дополнительная информация

paging files - файл подкачки; свопинг-файл; свопинговый файл; страничный файл - это системный файл, в который помещается программный код или другая информация из памяти, которая при необходимости может быть перенесена обратно в RAM))

Dependency Walker - это бесплатная утилита, которая сканирует исполняемый файл (.exe или .dll) и строит дерево всех модулей, от которых он зависит. Для каждого найденного модуля программа перечисляет все функции, которые он предоставляет и те из них, что реально используются связанными модулями.

Другой режим отображает минимальный набор требуемых файлов, включая подробную информацию о каждом файле: полный путь к файлу, номер версии, тип архитектуры, отладочную информацию и другое.

Размер: 600 Кб

Скачать: http://www.dependencywalker.com/depends22_x86.zip

Веб-сайт: http://www.dependencywalker.com/

Приоритет - Приоритет можно установить в меню Процесс, выбрав одну из под-опций опции Установить приоритет. Или из контекстного меню, вызвав его щелчком правой кнопкой мыши по строке, с интересующим Вас процессом. Укажете назначаемый для данного процесса режим выполнения:

§Реального времени (24) - режим реального времени (все инициируемые процессом запросы выполняются системой по мере поступления);

§Высокий (13) - высочайший приоритет;

§Выше среднего (10) - высокий приоритет;

§Средний (8) - стандартный приоритет;

§Ниже среднего (6) - низкий приоритет;

§Фоновый (4) - низкий приоритет В/В и памяти

§Низкий (4) - наиболее низкий приоритет.

Чем выше приоритет процесса, тем быстрее выполняются инициированные им запросы. Процессам с высоким приоритетом система предоставляет аппаратные и программные ресурсы в первую очередь. При перераспределении приоритетов процессов следует помнить, что если вы установите высокий приоритет какому-либо второстепенному процессу, приоритет одного из жизненно важных для Windows системных процессов может автоматически стать низким, в результате чего скорость работы системы в целом заметно снизится или выполнение этого процесса будет полностью блокировано, что приведет к «зависанию» компьютера. Устанавливать высокий приоритет одному из процессов следует только в том случае, если его выполнение с «нормальным» приоритетом по каким-то причинам затруднено или невозможно.

Приоритет операций ввода-вывода

Несмотря на то, что операционная система Windows всегда поддерживала приоритеты использования ЦП, в ней отсутствовало понятие приоритетов операций ввода-вывода. Без поддержки приоритетов ввода-вывода фоновые операции, например индексация поиска, поиск вирусов и дефрагментация диска могут существенно ухудшать скорость ответа операций переднего плана. Пользователь, запускающий приложение или открывающий документ в то время, как другой процесс выполняет, например, операцию дискового ввода-вывода, сталкивается с задержками, поскольку приложению переднего плана приходится дожидаться доступа к диску. С теми же препятствиями сталкивается воспроизведение с жесткого диска потокового мультимедийного содержимого, например песни.

ОС Windows Vista обеспечивает два новых способа распределения приоритетов для предоставления предпочтения операциям ввода-вывода переднего плана: приоритеты на отдельные операции ввода-вывода и резервирование полосы пропускания ввода-вывода. Система ввода-вывода в ОС Windows Vista обеспечивает внутреннюю поддержку приоритетов операций ввода-вывода, как показано в таблице, но используются только четыре приоритета (возможно, следующие версии ОС Windows будут поддерживать приоритет High (Высокий)).

Критический | Диспетчер памяти
Высокий | Не используется
Нормальный | Приоритет по умолчанию
Низкий | Приоритет задачи по умолчанию
Очень низкий | Фоновые операции

Приоритетом по умолчанию для операций ввода-вывода является Medium (Средний), а диспетчер памяти использует приоритет High (Высокий) для записи на диск содержимого памяти в ситуациях нехватки памяти для освобождения ОЗУ для других данных и кода. Планировщик задач ОС Windows устанавливает приоритет по умолчанию для задач ввода-вывода Low (Низкий), а написанные для ОС Windows Vista приложения, осуществляющие фоновую обработку, указывают приоритет Very Low (Очень низкий). Все фоновые операции в ОС Windows Vista, включая сканирование Windows Defender (Защитник ОС Windows) и индексирование поиска на рабочем столе, используют приоритет ввода-вывода Very Low (Очень низкий).

Драйвер устройства класса системного хранения (%SystemRoot%\System32\Classpnp.sys) обеспечивает приоритеты ввода-вывода, которые автоматически применяются к операциям ввода-вывода, ориентированных на большинство устройств хранения. Этот и другие драйверы хранения помещают в свои очереди операции ввода-вывода с приоритетом Medium (Средний) до операций с приоритетами Low (Низкий) и Very Low (Очень низкий), но при этом выполняют, как минимум, одну операцию с приоритетом Low (Низкий) или Very Low (Очень низкий) в секунду, чтобы не препятствовать выполнению фоновых процессов. Данные, прочитанные операциями с приоритетами Low (Низкий) и Very Low (Очень низкий), также приводят к тому, что диспетчер кэша производит запись изменений на диск незамедлительно, не откладывая, и обходит логику упреждающего чтения для операций чтения, что в противном случае приводило бы к упреждающему чтению из файлов, открытых для чтения. Пример операций с приоритетом Very Low (Очень низкий), выводимых программой Process Monitor, можно увидеть на боковой врезке «Просмотр операций ввода-вывода с приоритетом Very Low (Очень низкий)».

Поддержка резервирования полосы пропускания в ОС Windows Vista удобна для применения приложениями воспроизведения данных мультимедиа, и проигрыватель Windows Media пользуется ею наряду с повышением приоритетов службой MMCSS для почти безошибочного воспроизведения локального содержимого. Приложение проигрывателя мультимедиа запрашивает у системы ввода-вывода гарантии возможности чтения данных на указанной скорости и если устройство может предоставлять данные с указанной скоростью, а существующие ограничения резервирования это позволяют, оно предоставляет приложению данные о допустимой скорости и объеме операций ввода-вывода. Система ввода-вывода станет обслуживать другие операции только в том случае, если возможно удовлетворить требования приложений, зарезервировавших целевое устройство хранения.

В завершение следует упомянуть о еще одном изменении в системе ввода-вывода, относящемся к объему операций ввода-вывода. Со времен первой версии ОС Windows NT диспетчер памяти и система ввода-вывода ограничивали объем данных, обрабатываемых отдельным запросом ввода-вывода для устройства хранения, 64 КБ. Таким образом, даже если запрос ввода-вывода приложения был значительно больше, он разбивался на отдельные запросы, не превышающие 64 КБ. Каждая операция ввода-вывода подразумевала дополнительные затраты ресурсов на переключение в режим ядра и инициирование передачи ввода-вывода на устройство хранения, поэтому в ОС Windows Vista объем операций ввода-вывода больше не ограничивается. Некоторые компоненты пользовательского режима ОС Windows Vista подверглись модификациям для того, чтобы воспользоваться преимуществами большего объема операций ввода-вывода, включая функцию копирования в Проводнике и команду командной строки Copy (Копировать), которые теперь оперируют операциями ввода-вывода объемом 1 МБ.

Источник

Приоритеты памяти

Помимо приоритетов ввода-вывода (которые обсуждались в предыдущем выпуске), в ОС Windows Vista появились также и приоритеты памяти. Чтобы понять, как система использует приоритеты памяти, нужно разобраться, как в диспетчере памяти реализован кэш памяти, называемый списком ожидания (Standby List). Во всех версиях ОС Windows, предшествовавших Windows Vista, физическая страница, затребованная системой у приложения (размер страницы обычно составляет 4 Кбайт), помещалась диспетчером памяти в конец списка ожидания. Если процессу снова требовался доступ к этой странице, диспетчер памяти извлекал ее из списка ожидания и вновь назначал процессу. Если процессу требовалась новая страница физической памяти, но свободной памяти не было, диспетчер памяти отдавал процессу страницу из начала списка ожидания. В такой схеме все страницы в списке ожидания были равнозначны, и порядок страниц определялся только временем их помещения в список.

В ОС Windows Vista каждая страница памяти имеет приоритет от 0 до 7, и диспетчер памяти разделяет список ожидания на 8 списков, в каждом из которых хранятся страницы с соответствующим приоритетом. Если диспетчеру памяти нужно забрать страницу из списка ожидания, первыми будут извлекаться страницы из списков с более низким приоритетом. Приоритет страницы обычно совпадает с приоритетом потока, который первым вызвал выделение этой страницы. (Приоритет страницы с совместным доступом соответствует наивысшему приоритету памяти среди потоков, совместно использующих эту страницу). Поток наследует значение приоритета памяти от процесса, которому он принадлежит. Диспетчер памяти назначает низкий приоритет для страниц, которые он считывает с диска, когда предвидится обращение процесса к памяти.

По умолчанию значение приоритета памяти процессов равняется 5, но приложения и система могут менять значения приоритетов памяти для процессов и потоков. Реальная выгода от использования приоритетов памяти становится понятной, если рассматривать систему относительных приоритетов страниц на более высоком уровне, а именно на уровне функции SuperFetch.

Источник

Переключение контекста

Ядро, стремясь эффективно разделять время процессора, переключается между потоками; эта деятельность называется переключением контекста. Когда поток выполняется в течение продолжительности его кванта времени или когда он блокируется из-за запрашивания ресурса, который в настоящий момент недоступен, ядро находит для запуска другой поток и переключается на его контекст. Система может также прервать текущий выполняющийся поток, чтобы запустить поток в результате асинхронного события, такого, как прерывание от устройства. Хотя оба сценария включают переключение контекста выполнения процессора, переключение между потоками происходит синхронно по отношению к текущему выполняющемуся потоку, тогда как обслуживание прерываний происходит асинхронно по отношению к текущему потоку. Кроме того, переключения контекста между процессами подразделяются на принудительные и добровольные. Добровольное переключение контекста происходит при блокировании процесса, поскольку он запрашивает недоступный ресурс. Принудительное переключение контекста имеет место, когда поток выполняется в течение своего кванта времени или когда система обнаруживает для запуска поток с более высоким приоритетом.

источник

При переключении контекста происходит сохранение и восстановление следующей информации:

§Регистровый контекст регистров общего назначения (в том числе флаговый регистр)

§Контекст состояния сопроцессора с плавающей точкой

§Состояние регистров MMX/SSE (x86)

§Состояние сегментных регистров (x86)

§Состояние некоторых управляющих регистров (например, регистр CR3 отвечающий за страничное отображение памяти процесса) (x86)

В ядре ОС с каждым потоком связаны следующие структуры:

§Общая информация pid, tid, uid, gid, euid, egid,…

§Состояние процесса/потока

§Права доступа

§Используемые потоком ресурсы и блокировки

§Счетчики использования ресурсов (например таймеры использованного процессорного времени)

§Регионы памяти, выделенные процессу

Источник


Файл

Навигация: От меня > Меню >

От меня

 В начало раздела

Файл (File).

vФайл | Выполнить… (File|run…) - можно запустить другое приложение, вызвав стандартный диалог Windows - Запуск Программы.

vФайл | Запуск от имени администратора… (File| Runas …) - Это вариант команды Выполнить (Run) позволяет вводить дополнительные параметры пользователя для запуска приложения (credentials - мандат (учетная запись с параметрами доступа пользователя, сформированными после его успешной аутентификации)). Process Explorer усиливает те же самые функциональные возможности Windows, что и команда Windows Runas. Опция меню Runas не доступна в системах Windows 9x.

vФайл | Выполнить с ограниченными правами… (File| Run as Limited User …) - Это еще один вариант команды Запустить (Run), запускает приложение, которое Вы выберете находясь в той же учетной записи из которой вы запустили Process Explorer, но без привилегий администратора. Эта опция защитит Вашу систему от бесконтрольных действий приложений, таких как Internet Explorer, которые могли бы получить доступ к не доверяемым данным, и тем самым, поставить Вашу систему под угрозу.

vФайл | Показать детали всех процессов (File| Show Detail for All Proceses) - Под-меню отображается, если Process Explorer запущен от имени обычного пользователя. В этом режиме доступны только процессы, которые были запущены в этой учетной записи. Использование этой опции перезапустит программу от имени администратора, если Вы вошли в систему с соответствующими правами, или предложит войти в систему с правами администратора, если прав текущего пользователя недостаточно. После чего, будут доступны процессы, запущенные в других учетных записях.

vФайл|Сохранить (File|Save) - Process Explorer сохранит информационные наполнения верхнего окна, и нижнего, если оно открыто, в текстовом файле. При форматировании файла, для разграничения колонок, будет использоваться табуляция.

vФайл|Сохранить как… (File|Save as…) - Не буду объяснять!

vФайл|Завершение работы (File|Shutdown) – Имеет 5 подопций:

·Выйти из системы (Logoff)

·Выключить Компьютер (Shutdown)

·Ждущий режим (Stand by) - Положить баиньки - переключить компьютер в ждущий или в спящий режим (если система поддерживает эти функции).

·Заблокировать (Lock)

·Перезагрузить (Restart)

vФайл|Выход (File|Exit) - Выход из программы


Параметры

Навигация: От меня > Меню >

От меня

 В начало раздела

Параметры (Options)

vПараметры|Поверх остальных окон (Options|Always on Top) - Если выбрать эту опцию, то окно Process Explorer(а) будет располагаться поверх всех остальных окон открытых программ.

v Параметры| Заменить Диспетчер Зада (Options| Replace Task Manager) - Process Explorer будет запускаться вместо стандартного Диспетчера задач Windows. Помните, что это глобальное действие и поэтому затронет всех пользователей этого компьютера, вызывающих Диспетчер Задач. После замены Менеджера Задач, пункт меню изменится на Восстановить Диспетчер Задач (Restore Task Manager) и если выбрать эту опцию, то будет восстановлен стандартный Диспетчер задач Windows.

vПараметры| Сворачивать в область уведомлений (Options| Hide When Minimized) – Если включить эту опцию, то при минимизации окна Process Explorer(а), значок Process Explorer(а) не будет отображаться на панели задач. (но все равно будет отображаться в области уведомлений (в трее)).

vПараметры| Только одна копия программы (Options| Allow Only One Instance) - Все понятно: - одну, так одну.

vПараметры| Подтверждать уничтожение (Options| Confirm Kill) - Желательно включить эту опцию. Тогда Process Explorer прежде, чем завершить (Убить) процесс, отобразит соответствующее диалоговое окно, в котором Вы должны будете подтвердить осознанность Ваших действий, в противном случае - Process Explorer просто молча убьет процесс и все…

vПараметры| Проверять цифровую подпись (Options| Verify Image Signatures) - Верификация образа Сигнатуры - Если эта опция выбрана, тогда будет осуществлена верификация процесса, и при просмотре свойства процесса в диалоговом окне "свойства процесса"(process properties dialog), рядом с полем имени компании будет добавлен текст "Проверенный (Verified)". Что означает, что файл имеет числовую подпись, и числится в центре сертификации, как требующий доверия. В случае, если эта числовая подпись не соответствует требованиям центра сертификации, то будет добавлен тест "Не проверенный (Unable to Verify)". Для увеличения производительности отключите эту опцию.

vПараметры| Значки в области уведомлений (Options| Tray Icons) - Имеет 4 подопции. Выбор одной из них, приведет к отображению в иконке Process Explorer (а) (находящейся в области уведомлений) соответствующего графика.

§Хронология загрузки Ц.П. (CPU history)

§Хронология Ввода/Вывода (I/O history)

§Хронология переданной памяти (Commit history)

§Хронология физической памяти (Physical Memory history)

vПараметры| Настройка символов… (Options| Configure Symbols) - Конфигурирование Символов - для Windows NT и выше, если Вы хотите, чтобы Process Explorer мог сопоставить (resolve) адреса со стартовым адресом потока, и отобразить его в символьном виде на вкладке потоки (threads), диалогового окна свойства процесса (process properties ), и в окне стека потока (thread stack window ), то Вам следует скачать Debugging Tools for Windows (Средства отладки для Windows) с вебсайта Microsoft и установить его в каталог по умолчанию. Откройте диалоговое окно Настройка Символов (Configure Symbols) и в поле Путь к dbghelp.dll ( Dbghelp.dl pathl) введите путь к библиотеке dbghelp.dll, находящейся в каталоге (Debugging Tools), а в поле Путь к символам (Symbols path) ввести адрес сервера символов по требованию, для скачивания символов с сервера на ваш жесткий диск. Например, чтобы скачать символы в директорию c:\symbols - введите следующую строку: srv*c:\symbols*http://msdl.microsoft.com/download/symbols

vПараметры| Настройка Подсветки… (Options| Configure Highlighting) - При выборе этой опции откроется диалоговое окно – «Настройка Подсветки (Configure Highlighting)», в котором можно определить цвет подсветки:

·Вновь созданных объектов

·Удаленных объектов

·Собственных процессов

·Упакованных образов

·Заданий

·.NET процессов

·Перемещаемых библиотек

vПараметры| Длительность выделения различий… (Options| Difference Highlight Duration) - В диалоговом окне, вызванном при выборе этой опции, можно определить длительность подсветки вновь созданных и удаленных (завершивших свою работу) объектов. По умолчанию, это время равно 1 секунде.

vПараметры| Шрифт… (Options| Font…) - Вызывается стандартный диалог настройки шрифта Window


Вид

Навигация: От меня > Меню >

От меня

 В начало раздела

Вид (View)

vВид| Информация о системе… (View| System Information …) – Отобразится окно с информацией о системе: - графики использования процессора, выделения памяти, байт ввода-вывода, использования физической памяти, и другой информации. Для вызова этого окна можно также щелкнуть по мини графику в главном окне Process Explorer(а) или нажать кнопку на панели инструментов или воспользоваться комбинацией клавиш - Ctrl+I.

vВид| Показывать дерево процессов (View|Show Process Tree) – Если выбрать эту опцию, то в столбце «Процесс» имена процессов отобразятся в древовидной форме. Этого же можно добиться щелкнув по соответствующей кнопке на панели инструментов или щелкнуть по треугольнику в столбце «Процесс». Вернуться к сортировке по конкретному столбцу, можно щелкнув по заголовку нужного столбца.

vВид| Отображать процессы всех пользователей (View|Show Processes From All Users) – Нечего дополнить.

vВид| Отображать точную загрузку Ц.П. (View|Show Fractional CPU) – При выборе этой опции загрузка процессора будет измеряться и отображаться с точностью до сотой процента.

vВид| Форматировать столбцы ввода/вывода (View|Format I/O Butes Columns) – Если включить эту опцию, то данные в столбцах, связанных с вводом/выводом, будут отображаться в байтах или килобайтах, а может быть, и в мегобайтах (не проверял)

vВид| Выделять новые процессы (View|Show New Processes) – Объекты отображаемые в окне Process Explorer(а) автоматически «прокрутятся» так, чтобы при запуске нового процесса, он был виден.

vВид| Отображать безымянные описатели и проекции (View|Show Unnamed Handles and Mappings) – тоже нечего сказать.

vВид| Прозрачность (View| Opacity) – можно настроить прозрачность окна Process Explorer(а).

vВид| Показывать нижнее окно (View| Lower Pane View) – Можно скрыть или вновь отобразить нижнее окно Process Explorer(а), использовав эту опцию меню, или нажав соответствующую кнопку на панели инструментов или нажав Ctrl+L.

vВид| Отображать в нижнем окне (View| Lower Pane View) – Имет две подопции:

·Библиотеки (DLLs) - Ctrl+D – в нижнем окне будут отображаться библиотеки

·Описатели (Handles) - Ctrl+H – будут отображаться Описатели.

vВид| Обновить (View| Refresh) – Принудительное обновление содержимого окон Process Explorer(а). Можно нажать соответствующую кнопку на панели инструментов или использовать акселератор - F5.

vВид| Частота обновления (View| Update Speed) – Здесь можно определить частоту обновления данных или вообще остановить.

vВид| Упорядочить наборы столбцов… (View| Organize Column Sets…) – Откроется окно в котором можно будет упорядочить ранее сохраненные наборы столбцов.

vВид| Сохранить набор столбцов… (View| Save Column Set…) – Откроется диалоговое окно в котором можно дать имя набору столбцов и сохранить его.

vВид| Загрузить набор столбцов… (View| Load Column Set …) – Можно загрузить выбранный набор столбцов, если Вы предварительно его сохранили.

vВид| Выбрать столбцы… (View| Select Columns …) – Откроется диалоговое окно в котором можно выбрать столбцы для отображения их в окнах Process Explorer(а).


Процесс

Навигация: От меня > Меню >

От меня

 В начало раздела

Процесс (Process)

vПроцесс| Окно (Process| Window) – Имеет 5 подопций:

§Перенести поверх остальных (Bring to Front) – Помещает окно выбранного процесса на передний план (если процесс имеет окно)

§Восстановить стандартный размер(Restore) – Восстанавливает окно процесса, если оно было свернуто

§Свернуть (Minimize) – сворачивает окно процесса

§Развернуть (Maximize) – разворачивает окно

§Закрыть (Close) – закрывает окно (по всем правилам, предоставив приложению сохранить данные)

vПроцесс| Задать соответствие… (Process | Set Affinity…) – В появившемся диалоговом окне позволяет определить, какой процессор может использовать процесс (для многопроцессорных систем).

vПроцесс| Установить приоритет (Process |Set Priority) – Позволяет установить приоритет процесса.

vПроцесс| Завершить процесс (Process| Kill Process) – Уничтожает выбранный процесс.

vПроцесс| Завершить дерево процессов (Process| Kill Process Tree) – Уничтожает выбранное дерево процессов. (Столбец «Процесс» должен быть в режиме отображения дерева процессов).

vПроцесс| Перезапустить (Process| Restart) – Перезапускает выбранный процесс.

vПроцесс| Приостановить (Process| Suspend) – Приостанавливает выбранный процесс. После чего этот пункт меню преобразовывается в - Процесс| Возобнавить (Process| Resume).

vПроцесс| Отладка (Process| Debug) – Запускает зарегистрированный в системе отладчик с загруженным в него процессом.

vПроцесс| Свойства… (Process| Properties…) – Открывает окно «Свойства» с подробной информацией о процессе. Для вызова этого окна можно также нажать кнопку на панели инструментов, или выбрать эту опцию из контекстного меню процесса.

vПроцесс| Поиск в сети… (Process| Search Online…) – выбор этой опции приведет к запуску Интернет-браузера, и инициализации поиска в Интернете имени выбранного процесса.


Найти

Навигация: От меня > Меню >

От меня

 В начало раздела

Найти (Find)

Имеет одну опцию – Найти описатель или Dll (Find Handle or DLL). Вызывает диалоговое окно поиска. Это же окно можно вызвать нажав соответствующую кнопку на панели инструментов или используя акселератор - Ctrl+F.


DLL

Навигация: От меня > Меню >

От меня

 В начало раздела

DLL

Это меню отображается в случае если нижнее окно находится в режиме отображения Dll, и имеет две опции:

vDll Свойства… (Dll | Properties …) - Открывает окно «Свойства» с подробной информацией о библиотеке. Для вызова этого окна можно также выбрать эту опцию из контекстного меню библиотеки.

vDll | Поиск в сети… (Dll | Search Online…) - выбор этой опции приведет к запуску Интернет-браузера, и инициализации поиска в Интернете имени выбранной библиотеки.


Описатель

Навигация: От меня > Меню >

От меня

 В начало раздела

Дескриптор (Handle)

Это меню отображается в случае если нижнее окно находится в режиме отображения Описателей, и имеет две опции:

vДескриптор | Закрыть дескриптор (Handle | Close Handle) – Закрывает дескриптор.

vДескриптор | Свойства… (Handle | Properties …) - Открывает окно «Свойства» с подробной информацией о Описателе (дескрипторе). Для вызова этого окна можно также выбрать эту опцию из контекстного меню Описателя.


Пользователи

Навигация: От меня > Меню >

От меня

 В начало раздела

Пользователь (Users)

В этом меню перечисляются подключенные в настоящее время сеансы. Process Explorer создает пункт меню для каждого сеанса, это имя включает в себя сеанс, идентификатор сеанса и пользователя, зарегистрированного в сеансе. Каждый пункт меню имеет подменю, с опциями - разъединить (disconnecting), выйти из системы (logging off), и отправить сообщение пользователю сеанса (send message). Подменю - Свойства (Properties) открывает диалоговое окно, в котором отображается подробная информация о сеансе, включая адрес IP и имя клиента.


Справка

Навигация: От меня > Меню >

От меня

 В начало раздела

Справка (Help)

Два подменю: - вызов Справки и информация о программе.


Объект процесса

Навигация: От меня > Столбцы >

От меня

 В начало раздела
Показать/Скрыть скрытый текст

Столбцы на вкладке "Объект процесса"

vИмя процесса

vИдентификатор процесса - Число, уникально идентифицирующее выполняющийся процесс.

vПользователь - Учетная запись пользователя, в которой выполняется процесс.

vОписание

vНазвание компании

vПроверенный владелец подписи - Для того, чтобы отображались данные в этом столбце, нужно включить опцию Проверять цифровую подпись из меню Параметры.

Дополнительная информация

Если эта опция включена, то будет осуществляться верификация процесса, и при просмотре свойства процесса в диалоговом окне "Свойства процесса", рядом с полем имени компании будет добавлено слово "Проверен". Что означает, что файл имеет числовую подпись, и числится в центре сертификации, как требующий доверия. В случае, если эта числовая подпись не соответствует требованиям центра сертификации, то будет добавлен тест "Не удалось проверить". Для увеличения производительности отключите эту опцию.

vВерсия

vПуть объекта - Расположение процесса на жестком диске.

vЗаголовок окна - В этом столбце отображается заголовок окна, тот который находится в полосе заголовка окна открытого приложения. Если, конечно, процесс имеет окно.

vСостояние окна - Если все нормально, то в этом столбце написано "Выполняется". Если приложение «зависло» и не отвечает на системные запросы, ее состояние будет определено как "Не отвечает"

vСеанс

vКомандная строка - Полная командная строка для создания процесса.

vКомментарий - [image] Дополнительная информация

Введите комментарий для процесса в поле Комментарий. Комментарии отображаются в окне просмотра процессов в столбце Комментарий), если вы его выбрали для отображения. Комментарии добавляются ко всем процессам, имеющим одинаковый путь, и запоминаются от выполнения до выполнения.

vМестоположение автозапуска - Если процесс автоматически запускается во время или после загрузки системы, то в этом столбце указывается место, откуда дается команда на запуск. Более удобная и функциональная утилита, специально разработанная для настройки автозапуска, это утилита этого же автора - autoruns.

vСостояние DEP - Предотвращение выполнения данных.

Дополнительная информация

Состояние DEP (Status DEP) - Предотвращение выполнения данных (Data execution prevention, DEP) представляет собой совокупность программных и аппаратных решений для выполнения дополнительных проверок памяти, защищающих от выполнения вредоносного кода.

Информация с сайта: http://technet.microsoft.com/ru-ru/library/cc738483(v=ws.10).aspx

v Уровень целостности - Дополнительный механизм защиты данных

Дополнительная информация

Уровень целостности (integrity level) - В Windows Vista появился дополнительный механизм защиты – Integrity Levels. В зависимости от его уровня различаются и возможности приложения по работе с защищенными ресурсами системы. Поэтому актуальной задачей является определение значения Integrity Level процесса.

http://msdn.microsoft.com/ru-ru/library/bb625957.aspx

vВиртуализация - Определяет состояние виртуализации контроля учетных записей пользователей. Виртуализация контроля учетных записей пользователей перенаправляет сбои записи файлов и реестра в расположения пользователей.

vТехнология ASLR - [image] Дополнительная информация

Технология ASLR (ASLR Enabled) - Address space layout randomization (ASLR) — технология, применяемая в операционных системах, при использовании которой случайным образом изменяется расположение в адресном пространстве процесса важных структур, а именно: образа исполняемого файла, подгружаемых библиотек, кучи и стека.Технология ASLR значительно усложняет успешную эксплуатацию нескольких типов уязвимостей. Например, даже если при помощи переполнения буфера или другим методом атакующий получит возможность передать управление по произвольному адресу, ему нужно будет угадать, где же именно расположен стек или куча или другие места в памяти, в которые он может поместить шелл-код. Сходные проблемы возникнут и при атаке типа Возврат в библиотеку (return-to-libc), так как атакующий не знает адреса, по которому загружена библиотека. В данных примерах от нападающего скрыты конкретные адреса. Если ему не удастся угадать правильный адрес, приложение скорее всего аварийно завершится, тем самым лишив атакующего возможности повторной атаки и привлекая внимание системного администратор

http://ru.wikipedia.org/wiki/ASLR


Производительность процесса

Навигация: От меня > Столбцы >

От меня

 В начало раздела
Показать/Скрыть скрытый текст

Производительность процесса

vЗагрузка ЦП - Процент времени, в течение которого процессом использовался ЦП со времени последнего обновления (отображается как ЦП в заголовке столбца).

vИстория ЦП - Отображаются небольшие окошки с графиком использования процессом времени ЦП

vВремя запуска - Время в которое был запущен процесс.

vХронология процесса - Отображаются небольшие окрашенные окошки, дающие наглядное представление времени работы процесса в текущем сеансе работы системы. Полностью окрашенное окошко, говорит о том, что процесс запущен одновременно с системой.

vПотоки - Количество потоков в процессе.

vЦиклы ЦП - Количество циклов, которые ЦП затратил на обработку процесса, начиная с запуска процесса.

vΔ Циклов ЦП - Количество циклов, которые ЦП затратил на обработку процесса, в промежуток между обновлениями.

vДерево загрузки ЦП - Непонятно, в столбце отображаются те же значения, что и в столбце "Загрузка ЦП", но с некоторой задержкой.

vВремя ЦП - Общее время процессора, с точностью до тысячных долей секунд, выделенное процессу с начала его работы.

vБазовый приоритет - В столбце отображается текущий приоритет процесса.

Дополнительная информация

Приоритет можно установить в меню Процесс, выбрав одну из под-опций опции Установить приоритет. Или из контекстного меню, вызвав его щелчком правой кнопкой мыши по строке, с интересующим Вас процессом. Укажете назначаемый для данного процесса режим выполнения:

§Реального времени (24) - режим реального времени (все инициируемые процессом запросы выполняются системой по мере поступления);

§Высокий (13) - высочайший приоритет;

§Выше среднего (10) - высокий приоритет;

§Средний (8) - стандартный приоритет;

§Ниже среднего (6) - низкий приоритет;

§Фоновый (4) - низкий приоритет В/В и памяти

§Низкий (4) - наиболее низкий приоритет.

Чем выше приоритет процесса, тем быстрее выполняются инициированные им запросы. Процессам с высоким приоритетом система предоставляет аппаратные и программные ресурсы в первую очередь. При перераспределении приоритетов процессов следует помнить, что если вы установите высокий приоритет какому-либо второстепенному процессу, приоритет одного из жизненно важных для Windows системных процессов может автоматически стать низким, в результате чего скорость работы системы в целом заметно снизится или выполнение этого процесса будет полностью блокировано, что приведет к «зависанию» компьютера. Устанавливать высокий приоритет одному из процессов следует только в том случае, если его выполнение с «нормальным» приоритетом по каким-то причинам затруднено или невозможно.

vЧисло дескрипторов - Количество дескрипторов объектов в таблице объектов процесса.

vПереключений контекста - Количество переключений контекста, со времени запуска процесса. Так как, если и есть такое понятие, как контекст процесса, то оно не переключается, а переключается контекст потока. В этом столбце, вероятно, отображается сумма всех переключений контекста потоков, принадлежащих этому процессу.

Дополнительная информация

Ядро, стремясь эффективно разделять время процессора, переключается между потоками; эта деятельность называется переключением контекста. Когда поток выполняется в течение продолжительности его кванта времени или когда он блокируется из-за запрашивания ресурса, который в настоящий момент недоступен, ядро находит для запуска другой поток и переключается на его контекст. Система может также прервать текущий выполняющийся поток, чтобы запустить поток в результате асинхронного события, такого, как прерывание от устройства. Хотя оба сценария включают переключение контекста выполнения процессора, переключение между потоками происходит синхронно по отношению к текущему выполняющемуся потоку, тогда как обслуживание прерываний происходит асинхронно по отношению к текущему потоку. Кроме того, переключения контекста между процессами подразделяются на принудительные и добровольные. Добровольное переключение контекста происходит при блокировании процесса, поскольку он запрашивает недоступный ресурс. Принудительное переключение контекста имеет место, когда поток выполняется в течение своего кванта времени или когда система обнаруживает для запуска поток с более высоким приоритетом.

http://www.gateway.uz/freebsd/core/266-pereklyuchenie-konteksta

При переключении контекста происходит сохранение и восстановление следующей информации:

§Регистровый контекст регистров общего назначения (в том числе флаговый регистр)

§Контекст состояния сопроцессора с плавающей точкой

§Состояние регистров MMX/SSE (x86)

§Состояние сегментных регистров (x86)

§Состояние некоторых управляющих регистров (например, регистр CR3 отвечающий за страничное отображение памяти процесса) (x86)

В ядре ОС с каждым потоком связаны следующие структуры:

§Общая информация pid, tid, uid, gid, euid, egid,…

§Состояние процесса/потока

§Права доступа

§Используемые потоком ресурсы и блокировки

§Счетчики использования ресурсов (например таймеры использованного процессорного времени)

§Регионы памяти, выделенные процессу

http://ru.wikipedia.org/wiki/%CF%E5%F0%E5%EA%EB%FE%F7%E5%ED%E8%E5_%EA%EE%ED%F2%E5%EA%F1%F2%E0

vΔ переключений контекста - Количество переключений контекста, в промежуток между обновлениями.


Ввод/Вывод процесса

Навигация: От меня > Столбцы >

От меня

 В начало раздела
Показать/Скрыть скрытый текст

Ввод/Вывод процесса

vЧтений В/В - Количество операций чтения ввода-вывода, выполняемых процессом, начиная с его запуска, включая операции для устройств, файлов и сети.

vΔ Чтений В/В - Количество операций чтения ввода-вывода, за время между обновлениями.

vЗаписей В/В - Количество операций записи ввода-вывода, выполняемых процессом, включая операции для устройств, файлов и сети.

vΔ Записей В/В - Количество операций записи ввода-вывода, за время между обновлениями.

vДругих - Количество операций ввода-вывода, генерируемых процессом, начиная с его запуска, и не являющихся ни операциями чтения, ни операциями записи для устройств, файлов и сети.

vΔ Других - Количество операций ввода-вывода, генерируемых процессом, за время между обновлениями, и не являющихся ни операциями чтения, ни операциями записи для устройств, файлов и сети.

vИстория - Отображаются небольшие окошки с графиком.

vПриоритет - [image] Дополнительная информация

Несмотря на то, что операционная система Windows всегда поддерживала приоритеты использования ЦП, в ней отсутствовало понятие приоритетов операций ввода-вывода. Без поддержки приоритетов ввода-вывода фоновые операции, например индексация поиска, поиск вирусов и дефрагментация диска могут существенно ухудшать скорость ответа операций переднего плана. Пользователь, запускающий приложение или открывающий документ в то время, как другой процесс выполняет, например, операцию дискового ввода-вывода, сталкивается с задержками, поскольку приложению переднего плана приходится дожидаться доступа к диску. С теми же препятствиями сталкивается воспроизведение с жесткого диска потокового мультимедийного содержимого, например песни.

ОС Windows Vista обеспечивает два новых способа распределения приоритетов для предоставления предпочтения операциям ввода-вывода переднего плана: приоритеты на отдельные операции ввода-вывода и резервирование полосы пропускания ввода-вывода. Система ввода-вывода в ОС Windows Vista обеспечивает внутреннюю поддержку приоритетов операций ввода-вывода, как показано в таблице, но используются только четыре приоритета (возможно, следующие версии ОС Windows будут поддерживать приоритет High (Высокий)).

Критический | Диспетчер памяти
Высокий | Не используется
Нормальный | Приоритет по умолчанию
Низкий | Приоритет задачи по умолчанию
Очень низкий | Фоновые операции

vБайт прочитано - Количество байт, считанных в ходе операций ввода-вывода, генерируемых процессом, включая операции ввода-вывода для устройств, файлов и сети, начиная с запуска процесса.

vΔ прочитанных байт - Количество байт, считанных в ходе операций ввода-вывода, генерируемых процессом, включая операции ввода-вывода для устройств, файлов и сети, за время между обновлениями.

vБайт записано - Количество байт, записанных в ходе операций ввода-вывода, генерируемых процессом, включая операции ввода-вывода для устройств, файлов и сети, начиная с запуска процесса.

vΔ записанных байт - Количество байт, записанных в ходе операций ввода-вывода, генерируемых процессом, включая операции ввода-вывода для устройств, файлов и сети, за время между обновлениями.

vДругих байт - Количество байт, переданных в ходе генерируемых процессом операций ввода-вывода, которые не являются ни операциями чтения, ни операциями записи для устройств, файлов и сети, начиная с запуска процесса.

vΔ других байт - Количество байт, переданных в ходе генерируемых процессом операций ввода-вывода, которые не являются ни операциями чтения, ни операциями записи для устройств, файлов и сети, за время между обновлениями.

vΔ всех байт - Общее количество байт, записанных и считанных, за время между обновлениями


Память процесса

Навигация: От меня > Столбцы >

От меня

 В начало раздела
Показать/Скрыть скрытый текст

Память процесса

vОшибок страниц - Количество ошибок страниц, возникших с момента запуска процесса. Ошибки страниц происходят тогда, когда процесс обращается к странице памяти, которая отсутствует в рабочем наборе. Для устранения некоторых ошибок страниц требуется получить содержимое страницы с диска, а другие можно устранить без обращения к диску. (Это только называется - ошибки, на самом деле, это штатный режим.)

vΔ ошибок страниц - Количество ошибок страниц, возникших за время между обновлениями. (Название столбца в программе Δ файла подкачки)

vНеразделяемых байт - (Выделенных байт), Объем виртуальной памяти, выделенной процессу. Не знаю, может ли память отбираться у процесса, но добавляться может, впрочем, если есть столбец "Пик неразделяемых байт, значит память может и отбираться. В этом столбце указано общее количество байт виртуальной памяти, выделенной процессу, с учетом добавленной, с начала создания процесса.

vΔ неразделяемых байт - Объем виртуальной памяти, выделенной процессу за время между обновлениями.

v Виртуальный размер - Не знаю, видимо сумма разделяемых и неразделяемых байт.

vПик неразделяемых байт - Максимальный размер выделенных процессу байт. (Память у процесса может отбираться, потому, что я сейчас наглядно вижу, что значение в этом столбце больше, чем в столбце "Неразделяемых байт").

vИстория неразделяемых байт - Отображаются небольшие окрашенные окошки, дающие наглядное представление о выделении процессу неразделяемых байт в текущем сеансе.

vПриоритет памяти - [image] Дополнительная информация

В ОС Windows Vista каждая страница памяти имеет приоритет от 0 до 7, и диспетчер памяти разделяет список ожидания на 8 списков, в каждом из которых хранятся страницы с соответствующим приоритетом. Если диспетчеру памяти нужно забрать страницу из списка ожидания, первыми будут извлекаться страницы из списков с более низким приоритетом. Приоритет страницы обычно совпадает с приоритетом потока, который первым вызвал выделение этой страницы.

vМинимум рабочего набора - Все процессы начинают свой жизненный цикл с максимальным и минимальным размерами рабочего набора по умолчанию — 50 и 345 страниц соответственно. Размер страницы, обычно, 4 Кб, то есть, минимальный размер 50 * 4 = 200, а максимальный 345 * 4 = 1380. Система может уменьшить минимальный размер, при отсутствии подкачки страниц и потребности системы в физической памяти, и наоборот, увеличить максимальный размер, при интенсивной подкачки страниц и достаточного объема свободной памяти.

vМаксимум рабочего набора - смотри "Минимум рабочего набора".

vРазмер рабочего набора - Объем памяти в частном (неразделяемом) рабочем наборе плюс объем памяти, используемой процессом, которую нельзя использовать совместно с другими процессами. (Сумма значений в столбцах "Разделяемых байт рабочего набора" и "Неразделяемых байт рабочего набора")

vПиковый размер рабочего набора - Максимальный объем памяти рабочего набора, использованный процессом.

vРазделяемых байт рабочего набора - Объем неразделяемой части памяти рабочего набора.

vНеразделяемых байт рабочего набора - Объем разделяемой части памяти рабочего набора

vРазделенных байт рабочего набора -

vОбъектов GDI - Количество объектов библиотеки интерфейса графических устройств (GDI) программных интерфейсов (API) для графических устройств вывода.

vОбъектов USER - Количество объектов USER, использующихся процессом в данный момент. Объекты USER - объекты диспетчера окон, включая окна, меню, курсоры, значки, обработчики, ускорители, мониторы, раскладки клавиатуры, а также другие внутренние объекты.

vВыгружаемый пул - Объем страничной виртуальной памяти ядра, выделенной ядром или драйверами процессу. Страничная виртуальная память - это память, которую можно переписать на другой носитель, например жесткий диск.

vНевыгружаемый пул - Объем невыгружаемой памяти ядра, выделенной ядром или драйверами процессу. Невыгружаемая память - это память, которую нельзя переписать на другой носитель.